aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2017-09-06 18:52:44 +0000
committerSofian Brabez <sbz@FreeBSD.org>2017-09-06 18:52:44 +0000
commitf9d24cde254ea03e8ff353d2739fad687c91ffa8 (patch)
treefecf5d060f1131bdf2940df671328e7b3cb8542e
parent348a0607e7a3d5ad8ae68c09e6730d57518b99ec (diff)
downloadports-f9d24cde254ea03e8ff353d2739fad687c91ffa8.tar.gz
ports-f9d24cde254ea03e8ff353d2739fad687c91ffa8.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-feedparser/Makefile2
-rw-r--r--textproc/py3-feedparser/Makefile8
3 files changed, 10 insertions, 1 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 158034d5b0cd..ca0a09cea384 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1389,6 +1389,7 @@
SUBDIR += py3-asciinema
SUBDIR += py3-chardet
SUBDIR += py3-docutils
+ SUBDIR += py3-feedparser
SUBDIR += py3-humanfriendly
SUBDIR += py3-hunspell
SUBDIR += py3-libxml2
diff --git a/textproc/py-feedparser/Makefile b/textproc/py-feedparser/Makefile
index 377b82b7fa96..cea169f16e81 100644
--- a/textproc/py-feedparser/Makefile
+++ b/textproc/py-feedparser/Makefile
@@ -13,7 +13,7 @@ COMMENT= Universal feed parser written in Python
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python tar:bzip2
+USES?= python tar:bzip2
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/textproc/py3-feedparser/Makefile b/textproc/py3-feedparser/Makefile
new file mode 100644
index 000000000000..1b9a58700812
--- /dev/null
+++ b/textproc/py3-feedparser/Makefile
@@ -0,0 +1,8 @@
+# Created by: Danilo G. Baio <dbaio@bsd.com.br>
+# $FreeBSD$
+
+MASTERDIR= ${.CURDIR}/../py-feedparser
+
+USES= python:3.3+ tar:bzip2
+
+.include "${MASTERDIR}/Makefile"