aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBradley T. Hughes <bhughes@FreeBSD.org>2018-01-02 13:52:49 +0000
committerBradley T. Hughes <bhughes@FreeBSD.org>2018-01-02 13:52:49 +0000
commitfb07b9fac242a20ae82d79883b97cd48f51ac45b (patch)
treece7f36c93e9ee199c15a81eefea59715cee5649a
parent3e603282a367c75cf7816a4d71f99088659e2514 (diff)
downloadports-fb07b9fac242a20ae82d79883b97cd48f51ac45b.tar.gz
ports-fb07b9fac242a20ae82d79883b97cd48f51ac45b.zip
devel/awscli: use USE_PTYHON=noflavors, remove PKGNAMEPREFIX
The introduction of flavors caused the awscli package to be renamed to py27-awscli. Since this package is preinstalled on all AWS EC2 instances running a FreeBSD image, apply POLA and rename the package back to awscli. The assumption is that the rename was unintentional. Approved by: mat (co-mentor) MFH: 2018Q1 Differential Revision: https://reviews.freebsd.org/D13555
Notes
Notes: svn path=/head/; revision=457853
-rw-r--r--UPDATING8
-rw-r--r--devel/awscli/Makefile15
2 files changed, 15 insertions, 8 deletions
diff --git a/UPDATING b/UPDATING
index 5db5f39bc565..a0d50f1dda6e 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,14 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20180102:
+ AFFECTS: users of devel/awscli
+ AUTHOR: bhughes@FreeBSD.org
+
+ The package name for devel/awscli has changed (back) to just awscli.
+ The introduction of flavors erroneously caused the awscli package to
+ be renamed to py27-awscli.
+
20171230:
AFFECTS: users of net-im/ejabberd
AUTHOR: ashish@FreeBSD.org
diff --git a/devel/awscli/Makefile b/devel/awscli/Makefile
index 04d13dcd3188..c8ba4da47828 100644
--- a/devel/awscli/Makefile
+++ b/devel/awscli/Makefile
@@ -5,7 +5,6 @@ PORTNAME= awscli
PORTVERSION= 1.14.13
CATEGORIES= devel
MASTER_SITES= CHEESESHOP
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= bhughes@FreeBSD.org
COMMENT= Universal Command Line Interface for Amazon Web Services
@@ -13,15 +12,15 @@ COMMENT= Universal Command Line Interface for Amazon Web Services
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}botocore>=1.8.17:devel/py-botocore@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}colorama>=0.2.5:devel/py-colorama@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}s3transfer>=0.1.12:net/py-s3transfer@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}docutils>=0.10:textproc/py-docutils@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}rsa>=3.1.2:security/py-rsa@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}yaml>=3.10:devel/py-yaml@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}botocore>=1.8.17:devel/py-botocore@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}colorama>=0.2.5:devel/py-colorama@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}s3transfer>=0.1.12:net/py-s3transfer@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}docutils>=0.10:textproc/py-docutils@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}rsa>=3.1.2:security/py-rsa@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=3.10:devel/py-yaml@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist distutils concurrent
+USE_PYTHON= autoplist distutils concurrent noflavors
NO_ARCH= yes
.include <bsd.port.mk>