aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-09-24 21:42:22 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-09-24 21:42:22 +0000
commitfbe09b08cdef3c5b1ece1a00e2b3667f7e2af94c (patch)
tree188c4226efe2d63b9779d6534ce19793ab5dcd85
parentce78e585f7e4e0dfb4767697a3b65859abd9fbcf (diff)
downloadports-fbe09b08cdef3c5b1ece1a00e2b3667f7e2af94c.tar.gz
ports-fbe09b08cdef3c5b1ece1a00e2b3667f7e2af94c.zip
Notes
-rw-r--r--editors/codelite/Makefile22
-rw-r--r--editors/codelite/distinfo6
-rw-r--r--editors/codelite/pkg-plist43
3 files changed, 16 insertions, 55 deletions
diff --git a/editors/codelite/Makefile b/editors/codelite/Makefile
index 3fcfe82e8b89..d32f0160326e 100644
--- a/editors/codelite/Makefile
+++ b/editors/codelite/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= codelite
-DISTVERSION= ${REL_VERSION}.r${SVN_REVISION}
-PORTREVISION= 1
+DISTVERSION= 1.0.${SVN_REVISION}
CATEGORIES= editors
MASTER_SITES= SF
-DISTNAME= CodeLite-rev${SVN_REVISION}-v${REL_VERSION}.src
MAINTAINER= gahr@FreeBSD.org
COMMENT= An Open Source IDE for C/C++
@@ -19,21 +17,18 @@ LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl
OPTIONS= CSCOPE "Enable CScope integration" OFF
-WRKSRC= ${WRKDIR}/CodeLite-Rev${SVN_REVISION}-V${REL_VERSION}
-
-USE_ZIP= yes
USE_WX= 2.8
WX_UNICODE= yes
USE_GNOME= gtk20
USE_GMAKE= yes
-
-REL_VERSION= 1.0
-SVN_REVISION= 1789
+HAS_CONFIGURE= yes
.include <bsd.port.pre.mk>
ONLY_FOR_ARCHS= i386 amd64
+SVN_REVISION= 2128
+
.if defined(WITH_CSCOPE)
RUN_DEPENDS+= cscope:${PORTSDIR}/devel/cscope
.endif
@@ -42,8 +37,8 @@ post-patch:
${REINPLACE_CMD} -e 's|wx-config|${WX_CONFIG}|g' \
${WRKSRC}/configure ${WRKSRC}/makefile.base
${REINPLACE_CMD} -e 's|$${cur_rev}|${SVN_REVISION}|' \
- ${WRKSRC}/le_makerevision.sh
- # CTags already installed
+ ${WRKSRC}/le_makerevision.sh
+# CTags already installed
(if [ -f ${LOCALBASE}/include/readtags.h ]; then \
${RM} ${WRKSRC}/CodeLite/readtags.h; \
fi; \
@@ -53,9 +48,6 @@ post-patch:
${WRKSRC}/configure ${WRKSRC}/makefile.base
.endif
-do-configure:
- (cd ${WRKSRC} && ${SH} ${CONFIGURE_SCRIPT})
-
do-install:
${MKDIR} ${DATADIR}
${MKDIR} ${DATADIR}/config
@@ -76,8 +68,6 @@ do-install:
(cd ${WRKSRC}/Runtime/templates && ${COPYTREE_SHARE} \* ${DATADIR}/templates)
(cd ${WRKSRC}/Runtime/lexers && ${COPYTREE_SHARE} \* ${DATADIR}/lexers)
${INSTALL_DATA} ${WRKSRC}/lib/Debugger.so ${DATADIR}/debuggers
- ${INSTALL_DATA} ${WRKSRC}/Runtime/sdk/lib/unix/libUnitTest++.a ${PREFIX}/lib
- (cd ${WRKSRC}/Runtime/sdk/include/UnitTest++ && ${COPYTREE_SHARE} \* ${PREFIX}/include/UnitTest++)
.for lib in CodeFormatter Subversion cscope Gizmos
${INSTALL_DATA} ${WRKSRC}/lib/${lib}.so ${DATADIR}/plugins
.endfor
diff --git a/editors/codelite/distinfo b/editors/codelite/distinfo
index af2c55e978f6..0a88b40d41a0 100644
--- a/editors/codelite/distinfo
+++ b/editors/codelite/distinfo
@@ -1,3 +1,3 @@
-MD5 (CodeLite-rev1789-v1.0.src.zip) = a826e0edf5de7bc4ae7db981b03afa63
-SHA256 (CodeLite-rev1789-v1.0.src.zip) = a3fd65c174d86d81fa9effa04aa6bc53dcb22678309525d97cc8d08a7522a5cf
-SIZE (CodeLite-rev1789-v1.0.src.zip) = 7289149
+MD5 (codelite-1.0.2128.tar.gz) = faf4653aeb23921c0af75530dedbe593
+SHA256 (codelite-1.0.2128.tar.gz) = fdd01e3012bf640a3fe88ec40d7b2fcd88a4ce66d5fe191b1c18df5cde85a2a8
+SIZE (codelite-1.0.2128.tar.gz) = 5718825
diff --git a/editors/codelite/pkg-plist b/editors/codelite/pkg-plist
index 759488b1ed23..abb89e913580 100644
--- a/editors/codelite/pkg-plist
+++ b/editors/codelite/pkg-plist
@@ -3,13 +3,15 @@ bin/le_dos2unix.sh
bin/le_exec.sh
bin/le_killproc.sh
bin/ctags-le
-%%DATADIR%%/config/debuggers.xml
-%%DATADIR%%/config/debuggers.xml.gtk
-%%DATADIR%%/config/build_settings.xml
-%%DATADIR%%/config/codelite.xml.default
+%%DATADIR%%/config/accelerators.conf.default
+%%DATADIR%%/config/build_settings.xml.default
%%DATADIR%%/config/codelite.layout.default
+%%DATADIR%%/config/codelite.xml.default
+%%DATADIR%%/config/codelite.xml.default.gtk
+%%DATADIR%%/config/debuggers.xml.default
+%%DATADIR%%/config/debuggers.xml.gtk
%%DATADIR%%/config/liteeditor.xml.mac
-%%DATADIR%%/config/accelerators.conf.default
+%%DATADIR%%/config/plugins.xml.default
%%DATADIR%%/debuggers/Debugger.so
%%DATADIR%%/templates/projects/vc-executable/vc-executable.project
%%DATADIR%%/templates/projects/executable/main.cpp
@@ -69,34 +71,6 @@ bin/ctags-le
%%DATADIR%%/index.html
%%DATADIR%%/astyle.sample
%%DATADIR%%/svnreport.html
-include/UnitTest++/AssertException.h
-include/UnitTest++/CheckMacros.h
-include/UnitTest++/Checks.h
-include/UnitTest++/Config.h
-include/UnitTest++/DeferredTestReporter.h
-include/UnitTest++/DeferredTestResult.h
-include/UnitTest++/MemoryOutStream.h
-include/UnitTest++/Posix/SignalTranslator.cpp
-include/UnitTest++/Posix/SignalTranslator.h
-include/UnitTest++/Posix/TimeHelpers.cpp
-include/UnitTest++/Posix/TimeHelpers.h
-include/UnitTest++/ReportAssert.h
-include/UnitTest++/Test.h
-include/UnitTest++/TestDetails.h
-include/UnitTest++/TestList.h
-include/UnitTest++/TestMacros.h
-include/UnitTest++/TestReporter.h
-include/UnitTest++/TestReporterStdout.h
-include/UnitTest++/TestResults.h
-include/UnitTest++/TestRunner.h
-include/UnitTest++/TestSuite.h
-include/UnitTest++/TimeConstraint.h
-include/UnitTest++/TimeHelpers.h
-include/UnitTest++/UnitTest++.h
-include/UnitTest++/Win32/TimeHelpers.cpp
-include/UnitTest++/Win32/TimeHelpers.h
-include/UnitTest++/XmlTestReporter.h
-lib/libUnitTest++.a
share/applications/codelite.desktop
@dirrm %%DATADIR%%/templates/projects/vc-static-lib
@dirrm %%DATADIR%%/templates/projects/vc-executable
@@ -119,7 +93,4 @@ share/applications/codelite.desktop
@dirrm %%DATADIR%%/config
@dirrm %%DATADIR%%/images
@dirrm %%DATADIR%%
-@dirrm include/UnitTest++/Win32
-@dirrm include/UnitTest++/Posix
-@dirrm include/UnitTest++/
@dirrmtry share/applications