aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuangyuan Yang <ygy@FreeBSD.org>2020-12-31 07:20:52 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2020-12-31 07:20:52 +0000
commitfd1e329c602b93b8362f6e669b43d913b4150080 (patch)
tree317a5ae1c676091964f96615ccaf227851dd3e03
parent470775af0166eaf8146716e30dbb37205c20cc2b (diff)
downloadports-fd1e329c602b93b8362f6e669b43d913b4150080.tar.gz
ports-fd1e329c602b93b8362f6e669b43d913b4150080.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/R-cran-remotes/Makefile25
-rw-r--r--devel/R-cran-remotes/distinfo3
-rw-r--r--devel/R-cran-remotes/pkg-descr6
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d651217b460c..8dbdf110246a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -76,6 +76,7 @@
SUBDIR += R-cran-randomForest
SUBDIR += R-cran-registry
SUBDIR += R-cran-rematch2
+ SUBDIR += R-cran-remotes
SUBDIR += R-cran-repr
SUBDIR += R-cran-reshape
SUBDIR += R-cran-reshape2
diff --git a/devel/R-cran-remotes/Makefile b/devel/R-cran-remotes/Makefile
new file mode 100644
index 000000000000..4c39d23a1134
--- /dev/null
+++ b/devel/R-cran-remotes/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= remotes
+DISTVERSION= 2.2.0
+CATEGORIES= devel
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= ygy@FreeBSD.org
+COMMENT= R Package Installation from Remote Repositories, Including 'GitHub'
+
+LICENSE= GPLv2+
+
+BUILD_DEPENDS= R-cran-knitr>0:print/R-cran-knitr
+TEST_DEPENDS= R-cran-covr>0:devel/R-cran-covr \
+ R-cran-rprojroot>0:devel/R-cran-rprojroot \
+ R-cran-testthat>0:devel/R-cran-testthat \
+ R-cran-withr>0:devel/R-cran-withr \
+ R-cran-curl>0:ftp/R-cran-curl \
+ R-cran-knitr>0:print/R-cran-knitr \
+ R-cran-brew>0:textproc/R-cran-brew \
+ R-cran-rmarkdown>0:textproc/R-cran-rmarkdown
+
+USES= cran:auto-plist
+
+.include <bsd.port.mk>
diff --git a/devel/R-cran-remotes/distinfo b/devel/R-cran-remotes/distinfo
new file mode 100644
index 000000000000..7d218b0ebbbf
--- /dev/null
+++ b/devel/R-cran-remotes/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1609275763
+SHA256 (remotes_2.2.0.tar.gz) = 12f234fd8c46f4ac54e06a3c60e4015ed2193a32762ca4dd6854f120136f33b8
+SIZE (remotes_2.2.0.tar.gz) = 145553
diff --git a/devel/R-cran-remotes/pkg-descr b/devel/R-cran-remotes/pkg-descr
new file mode 100644
index 000000000000..b213b1b2a93c
--- /dev/null
+++ b/devel/R-cran-remotes/pkg-descr
@@ -0,0 +1,6 @@
+Download and install R packages stored in 'GitHub', 'GitLab', 'Bitbucket',
+'Bioconductor', or plain 'subversion' or 'git' repositories. This package
+provides the 'install_*' functions in 'devtools'. Indeed most of the code was
+copied over from 'devtools'.
+
+WWW: https://remotes.r-lib.org