aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Hurd <shurd@FreeBSD.org>2016-04-12 03:45:44 +0000
committerStephen Hurd <shurd@FreeBSD.org>2016-04-12 03:45:44 +0000
commitfd4835a1191f21ec43716b0591fe3b9d3105cf35 (patch)
treeacf9ccbb6e84d9b8cef2ad0b2d766285fcb7eb96
parent8ec8369d5ed056584a592bdd8b923ccc4810fd85 (diff)
downloadports-fd4835a1191f21ec43716b0591fe3b9d3105cf35.tar.gz
ports-fd4835a1191f21ec43716b0591fe3b9d3105cf35.zip
Notes
-rw-r--r--comms/qsstv/Makefile11
-rw-r--r--comms/qsstv/distinfo4
-rw-r--r--comms/qsstv/files/patch-qsstv_drmrx_demodulator.cpp11
-rw-r--r--comms/qsstv/pkg-plist14
4 files changed, 19 insertions, 21 deletions
diff --git a/comms/qsstv/Makefile b/comms/qsstv/Makefile
index 96a546a0a63a..d5b1ed1b0e4d 100644
--- a/comms/qsstv/Makefile
+++ b/comms/qsstv/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= qsstv
-PORTVERSION= 9.1.1
+PORTVERSION= 9.1.3
CATEGORIES= comms hamradio
MASTER_SITES= http://users.telenet.be/on4qz/qsstv/downloads/ \
LOCAL/shurd
@@ -12,16 +12,17 @@ COMMENT= Amateur Radio SSTV/FAX reception program for unix
LICENSE= GPLv3
-LIB_DEPENDS= libfftw3.so:math/fftw3 \
+LIB_DEPENDS= libasound.so:audio/alsa-lib \
+ libfftw3.so:math/fftw3 \
libfftw3f.so:math/fftw3-float \
libhamlib.so:comms/hamlib \
- libasound.so:audio/alsa-lib \
+ libopenjp2.so.7:graphics/openjpeg \
libpulse.so:audio/pulseaudio \
- libopenjp2.so.7:graphics/openjpeg
+ libv4l2.so:multimedia/libv4l
BUILD_DEPENDS= v4l_compat>=0:multimedia/v4l_compat
USES= qmake
-USE_QT5= buildtools core gui network xml
+USE_QT5= buildtools core gui network widgets xml
OPTIONS_DEFINE= DOCS
DOCS_CXXFLAGS= -DWITH_DOCS
diff --git a/comms/qsstv/distinfo b/comms/qsstv/distinfo
index 42a875705bb0..30e6351d53b8 100644
--- a/comms/qsstv/distinfo
+++ b/comms/qsstv/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qsstv_9.1.1.tar.gz) = 421a937901f98f8a0008f52ce6dde286733e5fd6a381ff8db0088e885bed6909
-SIZE (qsstv_9.1.1.tar.gz) = 12829697
+SHA256 (qsstv_9.1.3.tar.gz) = 1be5e97acde00affa3d2dd08c24174b34c38b40b6d1a246797db5de198ff1ddb
+SIZE (qsstv_9.1.3.tar.gz) = 12374404
diff --git a/comms/qsstv/files/patch-qsstv_drmrx_demodulator.cpp b/comms/qsstv/files/patch-qsstv_drmrx_demodulator.cpp
new file mode 100644
index 000000000000..e4f1e3945761
--- /dev/null
+++ b/comms/qsstv/files/patch-qsstv_drmrx_demodulator.cpp
@@ -0,0 +1,11 @@
+--- qsstv/drmrx/demodulator.cpp.orig 2016-04-08 23:08:29 UTC
++++ qsstv/drmrx/demodulator.cpp
+@@ -946,7 +946,7 @@ bool demodulator::channelEstimation()
+ temp2 += actual_pilots[2 * j] * next_pilots[2 * j + 1] -actual_pilots[2 * j + 1] * next_pilots[2 * j];
+
+ }
+- if (i != 0) delta_freq_offset = (float) atan2(temp2, temp1 + MIN_ABS_H);
++ if (i != 0) delta_freq_offset = atan2f(temp2, temp1 + MIN_ABS_H);
+
+ for (j = 0; j < K_max - K_min + 1; j++)
+ {
diff --git a/comms/qsstv/pkg-plist b/comms/qsstv/pkg-plist
index 3426ce5947da..97206ffb381b 100644
--- a/comms/qsstv/pkg-plist
+++ b/comms/qsstv/pkg-plist
@@ -111,19 +111,6 @@ bin/qsstv
%%PORTDOCS%%%%DOCSDIR%%/manual/folderclosed.png
%%PORTDOCS%%%%DOCSDIR%%/manual/folderopen.png
%%PORTDOCS%%%%DOCSDIR%%/manual/frect.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/ftv2blank.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/ftv2doc.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/ftv2folderclosed.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/ftv2folderopen.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/ftv2lastnode.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/ftv2link.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/ftv2mlastnode.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/ftv2mnode.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/ftv2node.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/ftv2plastnode.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/ftv2pnode.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/ftv2splitbar.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/ftv2vertline.png
%%PORTDOCS%%%%DOCSDIR%%/manual/gallery.html
%%PORTDOCS%%%%DOCSDIR%%/manual/gettingstarted.html
%%PORTDOCS%%%%DOCSDIR%%/manual/hybrid_checkbox.png
@@ -171,7 +158,6 @@ bin/qsstv
%%PORTDOCS%%%%DOCSDIR%%/manual/todo1.html
%%PORTDOCS%%%%DOCSDIR%%/manual/tone.png
%%PORTDOCS%%%%DOCSDIR%%/manual/transmitdrm.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/tx-with-template.png
%%PORTDOCS%%%%DOCSDIR%%/manual/txdrm_compression.png
%%PORTDOCS%%%%DOCSDIR%%/manual/txdrm_options.png
%%PORTDOCS%%%%DOCSDIR%%/manual/txdrm_status.png