aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-02-26 18:07:11 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-02-26 18:07:11 +0000
commitfd4dc6bd44879701b7fae89f23d2b7b7c62f30af (patch)
tree9b444b66e69aaad3f11badcdf2f6f1b4b230cb3d
parent97c0d306a87650c280093445d42cc272b7185a1e (diff)
- Update to MPICH 3.1.4
- Pass *FLAGS variables to configure via MPICHLIB_*FLAGS because otherwise they are hardcoded into mpicc [1] PR: 197563 [1]
Notes
Notes: svn path=/head/; revision=380043
-rw-r--r--net/mpich/Makefile23
-rw-r--r--net/mpich/distinfo4
-rw-r--r--net/mpich/files/patch-src-mpi-pt2pt-greq_start.c29
-rw-r--r--net/mpich/files/patch-src-mutex-mutex_create.c11
-rw-r--r--net/mpich/files/patch-src-mutex-mutex_free.c11
-rw-r--r--net/mpich/files/patch-src-mutex-mutex_lock.c11
-rw-r--r--net/mpich/files/patch-src-mutex-mutex_unlock.c11
-rw-r--r--net/mpich/pkg-plist6
8 files changed, 97 insertions, 9 deletions
diff --git a/net/mpich/Makefile b/net/mpich/Makefile
index 0e1c4a34b280..e381349c0f1e 100644
--- a/net/mpich/Makefile
+++ b/net/mpich/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= mpich
-PORTVERSION= 3.1.3
+PORTVERSION= 3.1.4
CATEGORIES= net parallel
MASTER_SITES= http://www.mpich.org/static/downloads/${DISTVERSION}/
@@ -17,6 +17,7 @@ LIB_DEPENDS= libhwloc.so:${PORTSDIR}/devel/hwloc
CONFLICTS= lam-7.* mpd-[0-9]* mpiexec-0.* mpich2-[0-9]*
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
USES= libtool pkgconfig
USE_LDCONFIG= yes
@@ -28,16 +29,27 @@ OPTIONS_RADIO_DEFAULTPM=DGFORKER DHYDRA
OPTIONS_DEFAULT= HYDRA DHYDRA
OPTIONS_SUB= yes
-FORTRAN_CONFIGURE_ENABLE= fortran
FORTRAN_USES= fortran
+FORTRAN_CONFIGURE_ENABLE= fortran
+FORTRAN_CONFIGURE_ON= \
+ MPICH_LDFLAGS="-Wl,-rpath=${LOCALBASE}/lib/gcc${_GCC_VER} \
+ -L${LOCALBASE}/lib/gcc${_GCC_VER} -B${LOCALBASE}/bin"
GFORKER_DESC= Simple local process manager
HYDRA_DESC= Parallel process manager
DGFORKER_DESC= Make gforker the default process manager
DHYDRA_DESC= Make hydra the default process manager
-CONFIGURE_ARGS= --with-hwloc-prefix=${LOCALBASE} ac_cv_path_BASH_SHELL="" \
- pkgconfigdir="${PREFIX}/libdata/pkgconfig"
+CONFIGURE_ARGS= --enable-fast="" --with-hwloc-prefix=${LOCALBASE} \
+ ac_cv_path_BASH_SHELL="" \
+ pkgconfigdir="${PREFIX}/libdata/pkgconfig" \
+ MPICHLIB_CFLAGS="${CFLAGS}" CFLAGS="" \
+ MPICHLIB_CPPFLAGS="${CPPFLAGS}" CPPFLAGS="" \
+ MPICHLIB_CXXFLAGS="${CXXFLAGS}" CXXFLAGS="" \
+ MPICHLIB_FFLAGS="${FFLAGS}" FFLAGS="" \
+ MPICHLIB_FCFLAGS="${FCFLAGS}" FCFLAGS="" \
+ MPICHLIB_LDFLAGS="${LDFLAGS}" LDFLAGS="" \
+ MPICHLIB_LIBS="${LIBS}" LIBS=""
.include <bsd.port.options.mk>
@@ -66,4 +78,7 @@ PLIST_SUB+= EXECGFORKER="@comment "
.endif
.endif
+post-patch:
+ @${RM} -r ${WRKSRC}/www
+
.include <bsd.port.mk>
diff --git a/net/mpich/distinfo b/net/mpich/distinfo
index 9cc1ac642564..cf50bf37887c 100644
--- a/net/mpich/distinfo
+++ b/net/mpich/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mpich-3.1.3.tar.gz) = afb690aa828467721e9d9ab233fe00c68cae2b7b930d744cb5f7f3eb08c8602c
-SIZE (mpich-3.1.3.tar.gz) = 11487313
+SHA256 (mpich-3.1.4.tar.gz) = f68b5330e94306c00ca5a1c0e8e275c7f53517d01d6c524d51ce9359d240466b
+SIZE (mpich-3.1.4.tar.gz) = 11325036
diff --git a/net/mpich/files/patch-src-mpi-pt2pt-greq_start.c b/net/mpich/files/patch-src-mpi-pt2pt-greq_start.c
new file mode 100644
index 000000000000..483da55126f6
--- /dev/null
+++ b/net/mpich/files/patch-src-mpi-pt2pt-greq_start.c
@@ -0,0 +1,29 @@
+--- src/mpi/pt2pt/greq_start.c.orig 2015-02-20 20:48:13 UTC
++++ src/mpi/pt2pt/greq_start.c
+@@ -236,7 +236,7 @@ int MPIX_Grequest_class_create(MPI_Grequ
+ MPI_Grequest_cancel_function *cancel_fn,
+ MPIX_Grequest_poll_function *poll_fn,
+ MPIX_Grequest_wait_function *wait_fn,
+- MPIX_Grequest_class *greq_class) __attribute__((weak,alias("MPIX_Grequest_class_create")));
++ MPIX_Grequest_class *greq_class) __attribute__((weak,alias("PMPIX_Grequest_class_create")));
+ #endif
+ /* -- End Profiling Symbol Block */
+
+@@ -328,7 +328,7 @@ fn_fail:
+ #elif defined(HAVE_PRAGMA_CRI_DUP)
+ #pragma _CRI duplicate MPIX_Grequest_class_allocate as PMPIX_Grequest_class_allocate
+ #elif defined(HAVE_WEAK_ATTRIBUTE)
+-int MPIX_Grequest_class_allocate(MPIX_Grequest_class greq_class, void *extra_state, MPI_Request *request) __attribute__((weak,alias("MPIX_Grequest_class_allocate")));
++int MPIX_Grequest_class_allocate(MPIX_Grequest_class greq_class, void *extra_state, MPI_Request *request) __attribute__((weak,alias("PMPIX_Grequest_class_allocate")));
+ #endif
+ /* -- End Profiling Symbol Block */
+
+@@ -379,7 +379,7 @@ int MPIX_Grequest_start( MPI_Grequest_qu
+ MPIX_Grequest_poll_function *poll_fn,
+ MPIX_Grequest_wait_function *wait_fn,
+ void *extra_state,
+- MPI_Request *request ) __attribute__((weak,alias("MPIX_Grequest_start")));
++ MPI_Request *request ) __attribute__((weak,alias("PMPIX_Grequest_start")));
+ #endif
+ /* -- End Profiling Symbol Block */
+
diff --git a/net/mpich/files/patch-src-mutex-mutex_create.c b/net/mpich/files/patch-src-mutex-mutex_create.c
new file mode 100644
index 000000000000..e1c7bf97d093
--- /dev/null
+++ b/net/mpich/files/patch-src-mutex-mutex_create.c
@@ -0,0 +1,11 @@
+--- src/mutex/mutex_create.c.orig 2015-02-20 20:48:13 UTC
++++ src/mutex/mutex_create.c
+@@ -23,7 +23,7 @@
+ #elif defined(HAVE_PRAGMA_CRI_DUP)
+ #pragma _CRI duplicate MPIX_Mutex_create as PMPIX_Mutex_create
+ #elif defined(HAVE_WEAK_ATTRIBUTE)
+-int MPIX_Mutex_create(int my_count, MPI_Comm comm, MPIX_Mutex * hdl_out) __attribute__((weak,alias("MPIX_Mutex_create")));
++int MPIX_Mutex_create(int my_count, MPI_Comm comm, MPIX_Mutex * hdl_out) __attribute__((weak,alias("PMPIX_Mutex_create")));
+ #endif
+ /* -- End Profiling Symbol Block */
+
diff --git a/net/mpich/files/patch-src-mutex-mutex_free.c b/net/mpich/files/patch-src-mutex-mutex_free.c
new file mode 100644
index 000000000000..801bed597631
--- /dev/null
+++ b/net/mpich/files/patch-src-mutex-mutex_free.c
@@ -0,0 +1,11 @@
+--- src/mutex/mutex_free.c.orig 2015-02-20 20:48:13 UTC
++++ src/mutex/mutex_free.c
+@@ -20,7 +20,7 @@
+ #elif defined(HAVE_PRAGMA_CRI_DUP)
+ #pragma _CRI duplicate MPIX_Mutex_free as PMPIX_Mutex_free
+ #elif defined(HAVE_WEAK_ATTRIBUTE)
+-int MPIX_Mutex_free(MPIX_Mutex * hdl_ptr) __attribute__((weak,alias("MPIX_Mutex_free")));
++int MPIX_Mutex_free(MPIX_Mutex * hdl_ptr) __attribute__((weak,alias("PMPIX_Mutex_free")));
+ #endif
+ /* -- End Profiling Symbol Block */
+
diff --git a/net/mpich/files/patch-src-mutex-mutex_lock.c b/net/mpich/files/patch-src-mutex-mutex_lock.c
new file mode 100644
index 000000000000..d6377021ed2d
--- /dev/null
+++ b/net/mpich/files/patch-src-mutex-mutex_lock.c
@@ -0,0 +1,11 @@
+--- src/mutex/mutex_lock.c.orig 2015-02-20 20:48:13 UTC
++++ src/mutex/mutex_lock.c
+@@ -21,7 +21,7 @@
+ #elif defined(HAVE_PRAGMA_CRI_DUP)
+ #pragma _CRI duplicate MPIX_Mutex_lock as PMPIX_Mutex_lock
+ #elif defined(HAVE_WEAK_ATTRIBUTE)
+-int MPIX_Mutex_lock(MPIX_Mutex hdl, int mutex, int proc) __attribute__((weak,alias("MPIX_Mutex_lock")));
++int MPIX_Mutex_lock(MPIX_Mutex hdl, int mutex, int proc) __attribute__((weak,alias("PMPIX_Mutex_lock")));
+ #endif
+ /* -- End Profiling Symbol Block */
+
diff --git a/net/mpich/files/patch-src-mutex-mutex_unlock.c b/net/mpich/files/patch-src-mutex-mutex_unlock.c
new file mode 100644
index 000000000000..3eeb4d3bcdf4
--- /dev/null
+++ b/net/mpich/files/patch-src-mutex-mutex_unlock.c
@@ -0,0 +1,11 @@
+--- src/mutex/mutex_unlock.c.orig 2015-02-20 20:48:13 UTC
++++ src/mutex/mutex_unlock.c
+@@ -21,7 +21,7 @@
+ #elif defined(HAVE_PRAGMA_CRI_DUP)
+ #pragma _CRI duplicate MPIX_Mutex_unlock as PMPIX_Mutex_unlock
+ #elif defined(HAVE_WEAK_ATTRIBUTE)
+-int MPIX_Mutex_unlock(MPIX_Mutex hdl, int mutex, int proc) __attribute__((weak,alias("MPIX_Mutex_unlock")));
++int MPIX_Mutex_unlock(MPIX_Mutex hdl, int mutex, int proc) __attribute__((weak,alias("PMPIX_Mutex_unlock")));
+ #endif
+ /* -- End Profiling Symbol Block */
+
diff --git a/net/mpich/pkg-plist b/net/mpich/pkg-plist
index e32d943f8e63..e8ce4781ec41 100644
--- a/net/mpich/pkg-plist
+++ b/net/mpich/pkg-plist
@@ -45,18 +45,18 @@ include/primitives/opa_unsafe.h
lib/libmpi.a
lib/libmpi.so
lib/libmpi.so.12
-lib/libmpi.so.12.0.4
+lib/libmpi.so.12.0.5
lib/libmpich.so
lib/libmpichcxx.so
%%FORTRAN%%lib/libmpichf90.so
lib/libmpicxx.a
lib/libmpicxx.so
lib/libmpicxx.so.12
-lib/libmpicxx.so.12.0.4
+lib/libmpicxx.so.12.0.5
%%FORTRAN%%lib/libmpifort.a
%%FORTRAN%%lib/libmpifort.so
%%FORTRAN%%lib/libmpifort.so.12
-%%FORTRAN%%lib/libmpifort.so.12.0.4
+%%FORTRAN%%lib/libmpifort.so.12.0.5
lib/libmpl.so
lib/libopa.so
libdata/pkgconfig/mpich.pc