aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMahdi Mokhtari <mmokhi@FreeBSD.org>2017-08-11 18:47:20 +0000
committerMahdi Mokhtari <mmokhi@FreeBSD.org>2017-08-11 18:47:20 +0000
commitfeeb5a15e8d042f3cc92040e2284ded3cc159b85 (patch)
treed4bbdc1d905861085fabd8cc24587a504ad41344
parent1b9d0ee3e32b4c99decddf93e8a41557975916c5 (diff)
downloadports-feeb5a15e8d042f3cc92040e2284ded3cc159b85.tar.gz
ports-feeb5a15e8d042f3cc92040e2284ded3cc159b85.zip
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/cyrus-sasl2-sql/Makefile29
-rw-r--r--security/cyrus-sasl2-sql/pkg-descr3
-rw-r--r--security/cyrus-sasl2/Makefile17
-rw-r--r--security/cyrus-sasl2/Makefile.common8
-rw-r--r--security/cyrus-sasl2/pkg-plist5
6 files changed, 35 insertions, 28 deletions
diff --git a/security/Makefile b/security/Makefile
index 2d5efcd1ae13..73462210d811 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -107,6 +107,7 @@
SUBDIR += cyrus-sasl2-gssapi
SUBDIR += cyrus-sasl2-ldapdb
SUBDIR += cyrus-sasl2-saslauthd
+ SUBDIR += cyrus-sasl2-sql
SUBDIR += cyrus-sasl2-srp
SUBDIR += d0_blind_id
SUBDIR += dcetest
diff --git a/security/cyrus-sasl2-sql/Makefile b/security/cyrus-sasl2-sql/Makefile
new file mode 100644
index 000000000000..c6fb223519bf
--- /dev/null
+++ b/security/cyrus-sasl2-sql/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PKGNAMESUFFIX= -sql
+
+COMMENT= SASL SQL plugins
+
+OPTIONS_DEFINE= MYSQL PGSQL
+OPTIONS_RADIO= SQLITE
+OPTIONS_RADIO_SQLITE= SQLITE2 SQLITE3
+
+OPTIONS_DEFAULT= MYSQL
+OPTIONS_SUB= yes
+
+MYSQL_USES= mysql
+MYSQL_CONFIGURE_ON= --with-mysql=${LOCALBASE}
+MYSQL_CONFIGURE_OFF= --without-mysql
+PGSQL_USES= pgsql
+PGSQL_CONFIGURE_ON= --with-pgsql=${LOCALBASE}
+PGSQL_CONFIGURE_OFF= --without-pgsql
+SQLITE2_USES= sqlite:2
+SQLITE2_CONFIGURE_ON= --with-sqlite=${LOCALBASE}
+SQLITE2_CONFIGURE_OFF= --without-sqlite
+SQLITE3_USES= sqlite:3
+SQLITE3_CONFIGURE_ON= --with-sqlite3=${LOCALBASE}
+SQLITE3_CONFIGURE_OFF= --without-sqlite3
+
+CONFIGURE_ARGS+= --enable-sql
+
+.include "${.CURDIR}/../../security/cyrus-sasl2/Makefile.common"
diff --git a/security/cyrus-sasl2-sql/pkg-descr b/security/cyrus-sasl2-sql/pkg-descr
new file mode 100644
index 000000000000..a0a0f928d52e
--- /dev/null
+++ b/security/cyrus-sasl2-sql/pkg-descr
@@ -0,0 +1,3 @@
+SASL SQL database plugin support
+
+WWW: http://cyrusimap.web.cmu.edu/
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index 8be42cc2ad9e..6ad87075c049 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -11,10 +11,9 @@ CYRUS_CONFIGURE_ARGS= --with-saslauthd=${SASLAUTHD_RUNPATH}
NO_OPTIONS_SORT= yes
OPTIONS_DEFINE= ALWAYSTRUE AUTHDAEMOND DOCS KEEP_DB_OPEN \
- OBSOLETE_CRAM_ATTR MYSQL PGSQL
-OPTIONS_RADIO= SASLDB SQLITE
+ OBSOLETE_CRAM_ATTR
+OPTIONS_RADIO= SASLDB
OPTIONS_RADIO_SASLDB= BDB1 BDB GDBM
-OPTIONS_RADIO_SQLITE= SQLITE2 SQLITE3
OPTIONS_GROUP= PLUGIN
OPTIONS_GROUP_PLUGIN= ANONYMOUS CRAM DIGEST LOGIN NTLM OTP PLAIN SCRAM
OPTIONS_DEFAULT= ANONYMOUS AUTHDAEMOND BDB1 OBSOLETE_CRAM_ATTR CRAM \
@@ -39,18 +38,6 @@ BDB1_CONFIGURE_ON= --with-dblib=ndbm
GDBM_LIB_DEPENDS= libgdbm.so:databases/gdbm
GDBM_CONFIGURE_ON= --with-dblib=gdbm \
--with-gdbm=${LOCALBASE}
-MYSQL_USES= mysql
-MYSQL_CONFIGURE_ON= --with-mysql=${LOCALBASE}
-MYSQL_CONFIGURE_OFF= --without-mysql
-PGSQL_USES= pgsql
-PGSQL_CONFIGURE_ON= --with-pgsql=${LOCALBASE}
-PGSQL_CONFIGURE_OFF= --without-pgsql
-SQLITE2_USES= sqlite:2
-SQLITE2_CONFIGURE_ON= --with-sqlite=${LOCALBASE}
-SQLITE2_CONFIGURE_OFF= --without-sqlite
-SQLITE3_USES= sqlite:3
-SQLITE3_CONFIGURE_ON= --with-sqlite3=${LOCALBASE}
-SQLITE3_CONFIGURE_OFF= --without-sqlite3
ANONYMOUS_DESC= ANONYMOUS authentication
ANONYMOUS_CONFIGURE_ENABLE= anon
CRAM_DESC= CRAM-MD5 authentication
diff --git a/security/cyrus-sasl2/Makefile.common b/security/cyrus-sasl2/Makefile.common
index 7414d6b27216..f81c8eb9e610 100644
--- a/security/cyrus-sasl2/Makefile.common
+++ b/security/cyrus-sasl2/Makefile.common
@@ -96,20 +96,12 @@ SASLDB_NAME= sasldb2
SASLDB= "@comment "
.endif
-.if ${PORT_OPTIONS:MMYSQL} || ${PORT_OPTIONS:MPGSQL} || \
- ${PORT_OPTIONS:MSQLITE2} || ${PORT_OPTIONS:MSQLITE3}
-CONFIGURE_ARGS+=--enable-sql
-.else
-SQL= "@comment "
-.endif
-
SUB_FILES= pkg-deinstall pkg-install pkg-message
SUB_LIST= CYRUS_USER=${CYRUS_USER} CYRUS_GROUP=${CYRUS_GROUP} \
SASLDB_NAME=${SASLDB_NAME}
PLIST_SUB+= PREFIX=${PREFIX} \
SASLDB=${SASLDB} \
- SQL=${SQL} \
DOCSDIR=${DOCSDIR:S/^${PREFIX}\///}
post-patch:
diff --git a/security/cyrus-sasl2/pkg-plist b/security/cyrus-sasl2/pkg-plist
index 35ce196a1b92..c17ac623ca35 100644
--- a/security/cyrus-sasl2/pkg-plist
+++ b/security/cyrus-sasl2/pkg-plist
@@ -35,11 +35,6 @@ lib/libsasl2.so.3.0.0
%%SCRAM%%lib/sasl2/libscram.so
%%SCRAM%%lib/sasl2/libscram.so.3
%%SCRAM%%lib/sasl2/libscram.so.3.0.0
-%%SQL%%lib/sasl2/libsql.a
-%%SQL%%lib/sasl2/libsql.la
-%%SQL%%lib/sasl2/libsql.so
-%%SQL%%lib/sasl2/libsql.so.3
-%%SQL%%lib/sasl2/libsql.so.3.0.0
%%NTLM%%lib/sasl2/libntlm.a
%%NTLM%%lib/sasl2/libntlm.la
%%NTLM%%lib/sasl2/libntlm.so