aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-23 14:04:12 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-23 14:04:12 +0000
commitfefd8c8fff1d9e02e2e3227fabe16175448af610 (patch)
tree1e0d67cbf7374c5d566d5f6dc39a9a2db51a0592
parentc0aa198926f0e8a547b7e93a3135163e055a7b12 (diff)
downloadports-fefd8c8fff1d9e02e2e3227fabe16175448af610.tar.gz
ports-fefd8c8fff1d9e02e2e3227fabe16175448af610.zip
Notes
-rw-r--r--games/Makefile1
-rw-r--r--games/prboom-plus/Makefile43
-rw-r--r--games/prboom-plus/Makefile.include24
-rw-r--r--games/prboom-plus/distinfo2
-rw-r--r--games/prboom-plus/pkg-descr5
-rw-r--r--games/prboom-plus/pkg-plist20
6 files changed, 95 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 4acc45db1e5a..774a2a5ef8ce 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -746,6 +746,7 @@
SUBDIR += powwow
SUBDIR += ppracer
SUBDIR += prboom
+ SUBDIR += prboom-plus
SUBDIR += primateplunge
SUBDIR += ptkei
SUBDIR += ptools
diff --git a/games/prboom-plus/Makefile b/games/prboom-plus/Makefile
new file mode 100644
index 000000000000..e14f6b2dbc59
--- /dev/null
+++ b/games/prboom-plus/Makefile
@@ -0,0 +1,43 @@
+# Created by: Jordan DeLong <fracture@allusion.net>
+# $FreeBSD$
+
+PORTNAME= prboom-plus
+PORTVERSION= 2.5.1.3
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= thiagohero501@gmail.com
+COMMENT= A fork of the doom game engine prboom
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libsmpeg.so:${PORTSDIR}/multimedia/smpeg \
+ libpng.so:${PORTSDIR}/graphics/png
+
+CONFLICTS= prboom-[2]*
+
+USES= gmake
+USE_SDL= mixer net sdl
+NEED_ROOT= yes
+
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS+=--with-waddir=${DATADIR}
+
+OPTIONS_DEFINE= OPENGL
+OPTIONS_DEFAULT=OPENGL
+
+DATADIR= ${DMDIR}
+
+OPENGL_CONFIGURE_ENABLE= gl
+OPENGL_USE= GL=yes
+
+post-patch:
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} \
+ -e '/^gamesdir/s|/games|/bin|' \
+ -e '/^docdir/s/@PACKAGE@-@VERSION@/@PACKAGE@/'
+
+.include "${.CURDIR}/Makefile.include"
+
+.include <bsd.port.mk>
diff --git a/games/prboom-plus/Makefile.include b/games/prboom-plus/Makefile.include
new file mode 100644
index 000000000000..79e888cfc9a4
--- /dev/null
+++ b/games/prboom-plus/Makefile.include
@@ -0,0 +1,24 @@
+# Makefile for defining variables used by other Doom related ports.
+
+DMPKGNAMEPREFIX?= doom-
+DMDIR?= ${LOCALBASE}/share/doom
+
+.if defined(PKGNAMEPREFIX) && ${PKGNAMEPREFIX} == ${DMPKGNAMEPREFIX} && defined(OPTIONSMKINCLUDED)
+. error include before <bsd.port.options.mk> if using DMPKGNAMEPREFIX
+.endif
+
+MAKE_ENV+= DMDIR="${DMDIR}"
+PLIST_SUB+= DMDIR="${DMDIR:S/${LOCALBASE}\///}"
+SUB_LIST+= DMDIR="${DMDIR}"
+
+.if defined(USE_CRLF)
+. if defined(USE_ZIP)
+EXTRACT_BEFORE_ARGS= -aqo
+. else
+pre-patch:
+ @${FIND} ${WRKDIR} -type f -print0 | \
+ ${XARGS} -0 ${FILE} | ${GREP} 'CRLF' | \
+ ${SED} -e "s/:.*//" | ${SED} -e 's/ /\\ /g' | \
+ ${XARGS} ${REINPLACE_CMD} -i "" -e "s/`${PRINTF} '\r'`$$//"
+. endif
+.endif
diff --git a/games/prboom-plus/distinfo b/games/prboom-plus/distinfo
new file mode 100644
index 000000000000..cc429ec9733a
--- /dev/null
+++ b/games/prboom-plus/distinfo
@@ -0,0 +1,2 @@
+SHA256 (prboom-plus-2.5.1.3.tar.gz) = 0a406fa9d275fbde94afcf726cbff6d3a022f83b413dbfb6d131872e4642668f
+SIZE (prboom-plus-2.5.1.3.tar.gz) = 1465003
diff --git a/games/prboom-plus/pkg-descr b/games/prboom-plus/pkg-descr
new file mode 100644
index 000000000000..d7f12ea7757a
--- /dev/null
+++ b/games/prboom-plus/pkg-descr
@@ -0,0 +1,5 @@
+A fork of PrBoom with uncapped framerate, variable gamespeed, re-record,
+walkcam, chasecam, full mouselook, fov and other features without loss of
+compatibility with original DOOM.
+
+WWW: http://prboom-plus.sourceforge.net/
diff --git a/games/prboom-plus/pkg-plist b/games/prboom-plus/pkg-plist
new file mode 100644
index 000000000000..7cef8d62bce3
--- /dev/null
+++ b/games/prboom-plus/pkg-plist
@@ -0,0 +1,20 @@
+bin/prboom-plus
+bin/prboom-plus-game-server
+man/man5/prboom-plus.cfg.5.gz
+man/man6/prboom-plus.6.gz
+man/man6/prboom-plus-game-server.6.gz
+%%DATADIR%%/prboom-plus.wad
+@dirrmtry %%DATADIR%%
+%%PORTDOCS%%%%DOCSDIR%%/MBF.txt
+%%PORTDOCS%%%%DOCSDIR%%/MBFFAQ.txt
+%%PORTDOCS%%%%DOCSDIR%%/README.compat
+%%PORTDOCS%%%%DOCSDIR%%/README.demos
+%%PORTDOCS%%%%DOCSDIR%%/boom.txt
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/prboom-plus-history.html
+%%PORTDOCS%%%%DOCSDIR%%/prboom-plus-history.txt
+%%PORTDOCS%%%%DOCSDIR%%/prboom-plus-usage.txt
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%