aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2018-02-26 11:22:36 +0000
committerJason E. Hale <jhale@FreeBSD.org>2018-02-26 11:22:36 +0000
commitff9dc9b22b5e05527cf3341a1e0f9fffa8ef550b (patch)
tree5482c3a59fe2095b80026f1854bfa7dae1ec1d0f
parent31d1cf70b46097603968a75a3cbd689f4caa287c (diff)
math/libqalculate: Update to 2.2.1
math/qalculate: Update to 2.2.1 Download the pre-rolled releases hosted on GitHub instead of using USE_GITHUB to avoid running autoreconf, etc. Backport upsteam patches for several instances of FindQalculate.cmake in KDE 4.x ports that could not detect the newer libqalculate. Bump PORTREVISION on dependent ports due to shared library version increase. Changes: https://qalculate.github.io/news.html Differential Revision: https://reviews.freebsd.org/D14459
Notes
Notes: svn path=/head/; revision=463014
-rw-r--r--deskutils/kdeplasma-addons-kde4/Makefile2
-rw-r--r--deskutils/kdeplasma-addons-kde4/files/patch-applets_qalculate_cmake__modules_FindQalculate.cmake67
-rw-r--r--math/cantor-kde4/Makefile2
-rw-r--r--math/cantor-kde4/files/patch-cmake_FindQalculate.cmake67
-rw-r--r--math/libqalculate/Makefile21
-rw-r--r--math/libqalculate/distinfo6
-rw-r--r--math/libqalculate/files/patch-git_issue3868
-rw-r--r--math/libqalculate/files/patch-libqalculate.pc.in13
-rw-r--r--math/libqalculate/pkg-plist6
-rw-r--r--math/qalculate/Makefile31
-rw-r--r--math/qalculate/distinfo6
-rw-r--r--math/qalculate/pkg-plist30
-rw-r--r--science/step-kde4/Makefile2
-rw-r--r--science/step-kde4/files/patch-cmake_modules_FindQalculate.cmake69
-rw-r--r--x11/kde-workspace-kde4/Makefile2
-rw-r--r--x11/kde-workspace-kde4/files/patch-cmake_modules_FindQalculate.cmake67
16 files changed, 317 insertions, 142 deletions
diff --git a/deskutils/kdeplasma-addons-kde4/Makefile b/deskutils/kdeplasma-addons-kde4/Makefile
index a1759e99b288..3712eb5f9ce3 100644
--- a/deskutils/kdeplasma-addons-kde4/Makefile
+++ b/deskutils/kdeplasma-addons-kde4/Makefile
@@ -2,7 +2,7 @@
PORTNAME= kdeplasma-addons
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= deskutils kde kde-kde4
MAINTAINER= kde@FreeBSD.org
diff --git a/deskutils/kdeplasma-addons-kde4/files/patch-applets_qalculate_cmake__modules_FindQalculate.cmake b/deskutils/kdeplasma-addons-kde4/files/patch-applets_qalculate_cmake__modules_FindQalculate.cmake
new file mode 100644
index 000000000000..20c5904223eb
--- /dev/null
+++ b/deskutils/kdeplasma-addons-kde4/files/patch-applets_qalculate_cmake__modules_FindQalculate.cmake
@@ -0,0 +1,67 @@
+Backport several commits from
+https://cgit.kde.org/plasma-workspace.git/tree/cmake/FindQalculate.cmake
+to make compatible with libqalculate >= 2.0.0. Specifically:
+8b3f6ac7a959300803334f6959184a6df34360f0
+b915e5b4bab10af938441ac5cae8e62cf6bbb843
+2aa504340e68ac11ac68a7b9573354ad431f2995
+
+--- applets/qalculate/cmake_modules/FindQalculate.cmake.orig 2014-10-25 07:17:51 UTC
++++ applets/qalculate/cmake_modules/FindQalculate.cmake
+@@ -22,20 +43,48 @@ if(QALCULATE_CFLAGS AND QALCULATE_LIBRARIES)
+
+ else(QALCULATE_CFLAGS AND QALCULATE_LIBRARIES)
+ if(NOT WIN32)
+- include(UsePkgConfig)
++ find_package(PkgConfig)
+
+ if(QALCULATE_MIN_VERSION)
+- exec_program(${PKGCONFIG_EXECUTABLE} ARGS libqalculate --atleast-version=${QALCULATE_MIN_VERSION} RETURN_VALUE _return_VALUE OUTPUT_VARIABLE _pkgconfigDevNull)
++ pkg_check_modules(_pc_QALCULATE libqalculate>=${QALCULATE_MIN_VERSION})
+ else(QALCULATE_MIN_VERSION)
+- exec_program(${PKGCONFIG_EXECUTABLE} ARGS libqalculate --exists RETURN_VALUE _return_VALUE OUTPUT_VARIABLE _pkgconfigDevNull)
++ pkg_check_modules(_pc_QALCULATE libqalculate)
+ endif(QALCULATE_MIN_VERSION)
+
+- if(_return_VALUE STREQUAL "0")
+- exec_program(${PKGCONFIG_EXECUTABLE} ARGS libqalculate --libs OUTPUT_VARIABLE QALCULATE_LIBRARIES)
+- exec_program(${PKGCONFIG_EXECUTABLE} ARGS cln --libs OUTPUT_VARIABLE CLN_LIBRARIES)
+- exec_program(${PKGCONFIG_EXECUTABLE} ARGS libqalculate --cflags OUTPUT_VARIABLE QALCULATE_CFLAGS)
+- set(QALCULATE_FOUND TRUE)
+- endif(_return_VALUE STREQUAL "0")
++ if(_pc_QALCULATE_FOUND)
++ if(${_pc_QALCULATE_VERSION} VERSION_LESS 2.0.0)
++ pkg_check_modules(_pc_CLN cln)
++ endif()
++ set(QALCULATE_CFLAGS ${_pc_QALCULATE_CFLAGS})
++ endif()
++
++ find_library(QALCULATE_LIBRARIES
++ NAMES
++ qalculate
++ PATHS
++ ${_pc_QALCULATE_LIBRARY_DIRS}
++ ${LIB_INSTALL_DIR}
++ )
++
++ find_path(QALCULATE_INCLUDE_DIR
++ NAMES
++ libqalculate
++ PATHS
++ ${_pc_QALCULATE_INCLUDE_DIRS}
++ ${INCLUDE_INSTALL_DIR}
++ )
++
++ if(_pc_QALCULATE_FOUND)
++ if(${_pc_QALCULATE_VERSION} VERSION_LESS 2.0.0)
++ find_library(CLN_LIBRARIES
++ NAMES
++ cln
++ PATHS
++ ${_pc_CLN_LIBRARY_DIRS}
++ ${LIB_INSTALL_DIR}
++ )
++ endif()
++ endif()
+
+ else(NOT WIN32)
+ # XXX: currently no libqalculate on windows
diff --git a/math/cantor-kde4/Makefile b/math/cantor-kde4/Makefile
index e8df1d3b6802..337008724492 100644
--- a/math/cantor-kde4/Makefile
+++ b/math/cantor-kde4/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cantor
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= math kde kde-kde4
MAINTAINER= kde@FreeBSD.org
diff --git a/math/cantor-kde4/files/patch-cmake_FindQalculate.cmake b/math/cantor-kde4/files/patch-cmake_FindQalculate.cmake
new file mode 100644
index 000000000000..0f6d0569e1c3
--- /dev/null
+++ b/math/cantor-kde4/files/patch-cmake_FindQalculate.cmake
@@ -0,0 +1,67 @@
+Backport several commits from
+https://cgit.kde.org/plasma-workspace.git/tree/cmake/FindQalculate.cmake
+to make compatible with libqalculate >= 2.0.0. Specifically:
+8b3f6ac7a959300803334f6959184a6df34360f0
+b915e5b4bab10af938441ac5cae8e62cf6bbb843
+2aa504340e68ac11ac68a7b9573354ad431f2995
+
+--- cmake/FindQalculate.cmake.orig 2014-11-01 12:56:09 UTC
++++ cmake/FindQalculate.cmake
+@@ -22,20 +43,48 @@ if(QALCULATE_CFLAGS AND QALCULATE_LIBRARIES)
+
+ else(QALCULATE_CFLAGS AND QALCULATE_LIBRARIES)
+ if(NOT WIN32)
+- include(UsePkgConfig)
++ find_package(PkgConfig)
+
+ if(QALCULATE_MIN_VERSION)
+- exec_program(${PKGCONFIG_EXECUTABLE} ARGS libqalculate --atleast-version=${QALCULATE_MIN_VERSION} RETURN_VALUE _return_VALUE OUTPUT_VARIABLE _pkgconfigDevNull)
++ pkg_check_modules(_pc_QALCULATE libqalculate>=${QALCULATE_MIN_VERSION})
+ else(QALCULATE_MIN_VERSION)
+- exec_program(${PKGCONFIG_EXECUTABLE} ARGS libqalculate --exists RETURN_VALUE _return_VALUE OUTPUT_VARIABLE _pkgconfigDevNull)
++ pkg_check_modules(_pc_QALCULATE libqalculate)
+ endif(QALCULATE_MIN_VERSION)
+
+- if(_return_VALUE STREQUAL "0")
+- exec_program(${PKGCONFIG_EXECUTABLE} ARGS libqalculate --libs OUTPUT_VARIABLE QALCULATE_LIBRARIES)
+- exec_program(${PKGCONFIG_EXECUTABLE} ARGS cln --libs OUTPUT_VARIABLE CLN_LIBRARIES)
+- exec_program(${PKGCONFIG_EXECUTABLE} ARGS libqalculate --cflags OUTPUT_VARIABLE QALCULATE_CFLAGS)
+- set(QALCULATE_FOUND TRUE)
+- endif(_return_VALUE STREQUAL "0")
++ if(_pc_QALCULATE_FOUND)
++ if(${_pc_QALCULATE_VERSION} VERSION_LESS 2.0.0)
++ pkg_check_modules(_pc_CLN cln)
++ endif()
++ set(QALCULATE_CFLAGS ${_pc_QALCULATE_CFLAGS})
++ endif()
++
++ find_library(QALCULATE_LIBRARIES
++ NAMES
++ qalculate
++ PATHS
++ ${_pc_QALCULATE_LIBRARY_DIRS}
++ ${LIB_INSTALL_DIR}
++ )
++
++ find_path(QALCULATE_INCLUDE_DIR
++ NAMES
++ libqalculate
++ PATHS
++ ${_pc_QALCULATE_INCLUDE_DIRS}
++ ${INCLUDE_INSTALL_DIR}
++ )
++
++ if(_pc_QALCULATE_FOUND)
++ if(${_pc_QALCULATE_VERSION} VERSION_LESS 2.0.0)
++ find_library(CLN_LIBRARIES
++ NAMES
++ cln
++ PATHS
++ ${_pc_CLN_LIBRARY_DIRS}
++ ${LIB_INSTALL_DIR}
++ )
++ endif()
++ endif()
+
+ else(NOT WIN32)
+ # XXX: currently no libqalculate on windows
diff --git a/math/libqalculate/Makefile b/math/libqalculate/Makefile
index 4451d23a3dd9..8dd81c0af853 100644
--- a/math/libqalculate/Makefile
+++ b/math/libqalculate/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= libqalculate
-DISTVERSION= 1.0.0a
-DISTVERSIONPREFIX= v
+PORTVERSION= 2.2.1
CATEGORIES= math
+MASTER_SITES= https://github.com/Qalculate/${PORTNAME}/releases/download/v${PORTVERSION}/
MAINTAINER= jhale@FreeBSD.org
COMMENT= Multi-purpose desktop calculator (backend library)
@@ -12,25 +12,26 @@ COMMENT= Multi-purpose desktop calculator (backend library)
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libcln.so:math/cln
+LIB_DEPENDS= libicuuc.so:devel/icu \
+ libcurl.so:ftp/curl \
+ libgmp.so:math/gmp \
+ libmpfr.so:math/mpfr
-USES= autoreconf gmake gettext libtool localbase \
+USES= gmake gettext iconv libtool localbase \
ncurses pathfix pkgconfig readline:port
-USE_GNOME= glib20 intltool libxml2
+USE_GNOME= intltool libxml2
USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USE_GITHUB= yes
-GH_ACCOUNT= Qalculate
-
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
post-patch-NLS-off:
- @${REINPLACE_CMD} -e '/^SUBDIRS =/s|po ||g' ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -e '/^SUBDIRS =/s|po ||g' ${WRKSRC}/Makefile.in
post-patch:
- @${REINPLACE_CMD} -e '/^SUBDIRS =/s|docs||g' ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -e '/^SUBDIRS =/s|docs||g' ${WRKSRC}/Makefile.in
.include <bsd.port.mk>
diff --git a/math/libqalculate/distinfo b/math/libqalculate/distinfo
index 75f1877f0bf8..285a393ef63f 100644
--- a/math/libqalculate/distinfo
+++ b/math/libqalculate/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1501594307
-SHA256 (Qalculate-libqalculate-v1.0.0a_GH0.tar.gz) = 3d9e9e983cf1bfded8063e4704587d42e2253cbfc5d60a9ecefc1b9b43ab2f8a
-SIZE (Qalculate-libqalculate-v1.0.0a_GH0.tar.gz) = 599217
+TIMESTAMP = 1518998683
+SHA256 (libqalculate-2.2.1.tar.gz) = 1752b6a046eaf84ee62a7dc8d2c874b538517956ce8affac80df09a3b55bef5d
+SIZE (libqalculate-2.2.1.tar.gz) = 1717947
diff --git a/math/libqalculate/files/patch-git_issue38 b/math/libqalculate/files/patch-git_issue38
deleted file mode 100644
index 9cf369b54dd5..000000000000
--- a/math/libqalculate/files/patch-git_issue38
+++ /dev/null
@@ -1,68 +0,0 @@
-Prevent qalc from segfaulting if started and immediately exited.
-See: https://github.com/Qalculate/libqalculate/issues/38
-
-diff --git a/libqalculate/Calculator.cc b/libqalculate/Calculator.cc
-index f5c183f..4963351 100644
---- libqalculate/Calculator.cc.orig
-+++ libqalculate/Calculator.cc
-@@ -224,8 +226,11 @@ void autoConvert(const MathStructure &morig, MathStructure &mconv, const Evaluat
- void CalculateThread::run() {
- enableAsynchronousCancel();
- while(true) {
-- bool b_parse = read<bool>();
-- void *x = read<void *>();
-+ bool failed = false;
-+ bool b_parse = read<bool>(&failed);
-+ if(failed) break;
-+ void *x = read<void *>(&failed);
-+ if(failed) break;
- MathStructure *mstruct = (MathStructure*) x;
- CALCULATOR->startControl();
- if(b_parse) {
-diff --git a/libqalculate/util.h b/libqalculate/util.h
-index 0edcb50..533f5c7 100644
---- libqalculate/util.h.orig
-+++ libqalculate/util.h
-@@ -128,14 +128,16 @@ public:
- protected:
- virtual void run() = 0;
- void enableAsynchronousCancel();
-- template <class T> T read() {
-+ template <class T> T read(bool *failed = NULL) {
- #ifdef _WIN32
- MSG msg;
- int ret = GetMessage(&msg, NULL, WM_USER, WM_USER);
-+ if(failed && (ret == 0 || ret == -1)) *failed = true;
- return (T) msg.wParam;
- #else
- T x;
-- fread(&x, sizeof(T), 1, m_pipe_r);
-+ int ret = fread(&x, sizeof(T), 1, m_pipe_r);
-+ if(failed && ret != 1) *failed = true;
- return x;
- #endif
- }
-diff --git a/src/qalc.cc b/src/qalc.cc
-index 4a4e4b2..43c3556 100644
---- src/qalc.cc.orig
-+++ src/qalc.cc
-@@ -2821,12 +2821,15 @@ void on_abort_display() {
-
- void ViewThread::run() {
- while(true) {
--
-- void *x = read<void *>();
-+
-+ bool failed = false;
-+ void *x = read<void *>(&failed);
-+ if(failed) break;
- MathStructure m(*((MathStructure*) x));
- //bool b_stack = read<bool>();
-- read<bool>();
-- x = read<void *>();
-+ read<bool>(&failed);
-+ x = read<void *>(&failed);
-+ if(failed) break;
- CALCULATOR->startControl();
- if(x) {
- PrintOptions po;
diff --git a/math/libqalculate/files/patch-libqalculate.pc.in b/math/libqalculate/files/patch-libqalculate.pc.in
deleted file mode 100644
index d62088e09d4d..000000000000
--- a/math/libqalculate/files/patch-libqalculate.pc.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- libqalculate.pc.in.orig 2016-08-25 18:49:39 UTC
-+++ libqalculate.pc.in
-@@ -5,7 +5,7 @@ includedir=@includedir@
-
- Name: libqalculate
- Description: libqalculate
--Requires: glib-2.0 libxml-2.0
-+Requires: cln glib-2.0 libxml-2.0
- Version: @VERSION@
- Libs: -L${libdir} -lqalculate
--Cflags: -I${includedir}
-\ No newline at end of file
-+Cflags: -I${includedir}
diff --git a/math/libqalculate/pkg-plist b/math/libqalculate/pkg-plist
index ae77d17be4f7..884d2a11f8af 100644
--- a/math/libqalculate/pkg-plist
+++ b/math/libqalculate/pkg-plist
@@ -14,8 +14,8 @@ include/libqalculate/qalculate.h
include/libqalculate/util.h
lib/libqalculate.a
lib/libqalculate.so
-lib/libqalculate.so.10
-lib/libqalculate.so.10.0.0
+lib/libqalculate.so.14
+lib/libqalculate.so.14.0.0
libdata/pkgconfig/libqalculate.pc
%%NLS%%share/locale/fr/LC_MESSAGES/libqalculate.mo
%%NLS%%share/locale/nl/LC_MESSAGES/libqalculate.mo
@@ -24,8 +24,10 @@ libdata/pkgconfig/libqalculate.pc
share/qalculate/currencies.xml
share/qalculate/datasets.xml
share/qalculate/elements.xml
+share/qalculate/eurofxref-daily.xml
share/qalculate/functions.xml
share/qalculate/planets.xml
share/qalculate/prefixes.xml
+share/qalculate/rates.json
share/qalculate/units.xml
share/qalculate/variables.xml
diff --git a/math/qalculate/Makefile b/math/qalculate/Makefile
index 12ee1d90b46c..45b427d695dc 100644
--- a/math/qalculate/Makefile
+++ b/math/qalculate/Makefile
@@ -2,33 +2,38 @@
# $FreeBSD$
PORTNAME= qalculate
-PORTVERSION= 1.0.0
-PORTREVISION= 1
-DISTVERSIONPREFIX= v
+PORTVERSION= 2.2.1
CATEGORIES= math
+MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/v${PORTVERSION}/
+DISTNAME= ${GH_PROJECT}-${PORTVERSION}
MAINTAINER= jhale@FreeBSD.org
COMMENT= Multi-purpose desktop calculator (GTK+3 frontend)
-LICENSE= GPLv2
+LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libcln.so:math/cln \
- libqalculate.so:math/libqalculate
-RUN_DEPENDS= gnuplot:math/gnuplot \
- wget:ftp/wget
-
BROKEN_powerpc64= fails to compile: main.cc: undefined reference to Calculator::temporaryCategory[abi:cxx11]()
-USES= autoreconf compiler:c++11-lang gettext gmake \
+LIB_DEPENDS= libqalculate.so:math/libqalculate
+RUN_DEPENDS= gnuplot:math/gnuplot
+
+USES= compiler:c++11-lang gettext gmake \
libtool:build localbase pkgconfig
USE_GNOME= cairo gdkpixbuf2 gtk30 intltool libxml2
+
+# USE_GITHUB= Use MASTER_SITES so that the pre-rolled release is downloaded
+GH_ACCOUNT= Qalculate
+GH_PROJECT= ${PORTNAME}-gtk
+
GNU_CONFIGURE= yes
DATADIR= share/${GH_PROJECT}
DOCSDIR= share/doc/${GH_PROJECT}
-USE_GITHUB= yes
-GH_ACCOUNT= Qalculate
-GH_PROJECT= ${PORTNAME}-gtk
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+post-patch-NLS-off:
+ @${REINPLACE_CMD} -e '/^SUBDIRS =/s|po ||g' ${WRKSRC}/Makefile.in
.include <bsd.port.mk>
diff --git a/math/qalculate/distinfo b/math/qalculate/distinfo
index 9e23f3fab2d8..59beaf656c01 100644
--- a/math/qalculate/distinfo
+++ b/math/qalculate/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1501601677
-SHA256 (Qalculate-qalculate-gtk-v1.0.0_GH0.tar.gz) = f314153b376411e752924e513b0cfb9d89caac116aa151a896fd36c7dc344f23
-SIZE (Qalculate-qalculate-gtk-v1.0.0_GH0.tar.gz) = 1731963
+TIMESTAMP = 1519000762
+SHA256 (qalculate-gtk-2.2.1.tar.gz) = 8bccd336c8b591c33e52d554fdd2c57ca7db6e34420da1e0ad10a15f984f129b
+SIZE (qalculate-gtk-2.2.1.tar.gz) = 2340404
diff --git a/math/qalculate/pkg-plist b/math/qalculate/pkg-plist
index d22e12d24214..755d7724b59c 100644
--- a/math/qalculate/pkg-plist
+++ b/math/qalculate/pkg-plist
@@ -6,6 +6,7 @@ share/applications/qalculate-gtk.desktop
%%DOCSDIR%%/html/figures/completion.png
%%DOCSDIR%%/html/figures/convert-number-bases.png
%%DOCSDIR%%/html/figures/convert-unit.png
+%%DOCSDIR%%/html/figures/edit-function-simplified.png
%%DOCSDIR%%/html/figures/edit-function.png
%%DOCSDIR%%/html/figures/edit-matrix.png
%%DOCSDIR%%/html/figures/edit-unit.png
@@ -28,34 +29,11 @@ share/applications/qalculate-gtk.desktop
%%DOCSDIR%%/html/qalculate-expressions.html
%%DOCSDIR%%/html/qalculate-functions.html
%%DOCSDIR%%/html/qalculate-introduction.html
+%%DOCSDIR%%/html/qalculate-mode.html
%%DOCSDIR%%/html/qalculate-plotting.html
-%%DOCSDIR%%/html/qalculate-result.html
%%DOCSDIR%%/html/qalculate-units.html
%%DOCSDIR%%/html/qalculate-user-interface.html
%%DOCSDIR%%/html/qalculate-variables.html
-share/locale/nl/LC_MESSAGES/qalculate-gtk.mo
-share/locale/sv/LC_MESSAGES/qalculate-gtk.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/qalculate-gtk.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/qalculate-gtk.mo
share/pixmaps/qalculate.png
-%%DATADIR%%/ui/argumentrules.ui
-%%DATADIR%%/ui/csvexport.ui
-%%DATADIR%%/ui/csvimport.ui
-%%DATADIR%%/ui/datasetedit.ui
-%%DATADIR%%/ui/datasets.ui
-%%DATADIR%%/ui/decimals.ui
-%%DATADIR%%/ui/functionedit.ui
-%%DATADIR%%/ui/functions.ui
-%%DATADIR%%/ui/main.ui
-%%DATADIR%%/ui/matrix.ui
-%%DATADIR%%/ui/matrixedit.ui
-%%DATADIR%%/ui/namesedit.ui
-%%DATADIR%%/ui/nbases.ui
-%%DATADIR%%/ui/periodictable.ui
-%%DATADIR%%/ui/plot.ui
-%%DATADIR%%/ui/precision.ui
-%%DATADIR%%/ui/preferences.ui
-%%DATADIR%%/ui/setbase.ui
-%%DATADIR%%/ui/unitedit.ui
-%%DATADIR%%/ui/units.ui
-%%DATADIR%%/ui/unknownedit.ui
-%%DATADIR%%/ui/variableedit.ui
-%%DATADIR%%/ui/variables.ui
diff --git a/science/step-kde4/Makefile b/science/step-kde4/Makefile
index c9593ef9a724..6e70a590128f 100644
--- a/science/step-kde4/Makefile
+++ b/science/step-kde4/Makefile
@@ -2,7 +2,7 @@
PORTNAME= step
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= science kde kde-kde4
MAINTAINER= kde@FreeBSD.org
diff --git a/science/step-kde4/files/patch-cmake_modules_FindQalculate.cmake b/science/step-kde4/files/patch-cmake_modules_FindQalculate.cmake
new file mode 100644
index 000000000000..9c3ec797d98d
--- /dev/null
+++ b/science/step-kde4/files/patch-cmake_modules_FindQalculate.cmake
@@ -0,0 +1,69 @@
+Backport several commits from
+https://cgit.kde.org/plasma-workspace.git/tree/cmake/FindQalculate.cmake
+to make compatible with libqalculate >= 2.0.0. Specifically:
+8b3f6ac7a959300803334f6959184a6df34360f0
+b915e5b4bab10af938441ac5cae8e62cf6bbb843
+2aa504340e68ac11ac68a7b9573354ad431f2995
+
+--- cmake/modules/FindQalculate.cmake.orig 2014-10-14 06:53:43 UTC
++++ cmake/modules/FindQalculate.cmake
+@@ -22,22 +43,49 @@ if(QALCULATE_CFLAGS AND QALCULATE_LIBRARIES)
+
+ else(QALCULATE_CFLAGS AND QALCULATE_LIBRARIES)
+ if(NOT WIN32)
+- include(UsePkgConfig)
++ find_package(PkgConfig)
+
+ if(QALCULATE_MIN_VERSION)
+- exec_program(${PKGCONFIG_EXECUTABLE} ARGS libqalculate --atleast-version=${QALCULATE_MIN_VERSION} RETURN_VALUE _return_VALUE OUTPUT_VARIABLE _pkgconfigDevNull)
++ pkg_check_modules(_pc_QALCULATE libqalculate>=${QALCULATE_MIN_VERSION})
+ else(QALCULATE_MIN_VERSION)
+- exec_program(${PKGCONFIG_EXECUTABLE} ARGS libqalculate --exists RETURN_VALUE _return_VALUE OUTPUT_VARIABLE _pkgconfigDevNull)
++ pkg_check_modules(_pc_QALCULATE libqalculate)
+ endif(QALCULATE_MIN_VERSION)
+
+- if(_return_VALUE STREQUAL "0")
+- exec_program(${PKGCONFIG_EXECUTABLE} ARGS libqalculate --libs OUTPUT_VARIABLE QALCULATE_LIBRARIES)
+- exec_program(${PKGCONFIG_EXECUTABLE} ARGS cln --libs OUTPUT_VARIABLE CLN_LIBRARIES)
+- exec_program(${PKGCONFIG_EXECUTABLE} ARGS libqalculate --cflags OUTPUT_VARIABLE QALCULATE_CFLAGS)
+- set(QALCULATE_FOUND TRUE)
+- message(STATUS "qalculate found and cln is:" ${CLN_LIBRARIES})
+- endif(_return_VALUE STREQUAL "0")
++ if(_pc_QALCULATE_FOUND)
++ if(${_pc_QALCULATE_VERSION} VERSION_LESS 2.0.0)
++ pkg_check_modules(_pc_CLN cln)
++ endif()
++ set(QALCULATE_CFLAGS ${_pc_QALCULATE_CFLAGS})
++ endif()
+
++ find_library(QALCULATE_LIBRARIES
++ NAMES
++ qalculate
++ PATHS
++ ${_pc_QALCULATE_LIBRARY_DIRS}
++ ${LIB_INSTALL_DIR}
++ )
++
++ find_path(QALCULATE_INCLUDE_DIR
++ NAMES
++ libqalculate
++ PATHS
++ ${_pc_QALCULATE_INCLUDE_DIRS}
++ ${INCLUDE_INSTALL_DIR}
++ )
++
++ if(_pc_QALCULATE_FOUND)
++ if(${_pc_QALCULATE_VERSION} VERSION_LESS 2.0.0)
++ find_library(CLN_LIBRARIES
++ NAMES
++ cln
++ PATHS
++ ${_pc_CLN_LIBRARY_DIRS}
++ ${LIB_INSTALL_DIR}
++ )
++ endif()
++ endif()
++
+ else(NOT WIN32)
+ # XXX: currently no libqalculate on windows
+ set(QALCULATE_FOUND FALSE)
diff --git a/x11/kde-workspace-kde4/Makefile b/x11/kde-workspace-kde4/Makefile
index 470ee050cb9f..723de9a2c05d 100644
--- a/x11/kde-workspace-kde4/Makefile
+++ b/x11/kde-workspace-kde4/Makefile
@@ -2,7 +2,7 @@
PORTNAME= kde-workspace
PORTVERSION= ${KDE4_WORKSPACE_VERSION}
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= x11 kde kde-applications
PKGNAMESUFFIX= -kde4
diff --git a/x11/kde-workspace-kde4/files/patch-cmake_modules_FindQalculate.cmake b/x11/kde-workspace-kde4/files/patch-cmake_modules_FindQalculate.cmake
new file mode 100644
index 000000000000..c7f17c1edfe3
--- /dev/null
+++ b/x11/kde-workspace-kde4/files/patch-cmake_modules_FindQalculate.cmake
@@ -0,0 +1,67 @@
+Backport several commits from
+https://cgit.kde.org/plasma-workspace.git/tree/cmake/FindQalculate.cmake
+to make compatible with libqalculate >= 2.0.0. Specifically:
+8b3f6ac7a959300803334f6959184a6df34360f0
+b915e5b4bab10af938441ac5cae8e62cf6bbb843
+2aa504340e68ac11ac68a7b9573354ad431f2995
+
+--- cmake/modules/FindQalculate.cmake.orig 2015-08-12 07:03:15 UTC
++++ cmake/modules/FindQalculate.cmake
+@@ -22,20 +43,48 @@ if(QALCULATE_CFLAGS AND QALCULATE_LIBRARIES)
+
+ else(QALCULATE_CFLAGS AND QALCULATE_LIBRARIES)
+ if(NOT WIN32)
+- include(UsePkgConfig)
++ find_package(PkgConfig)
+
+ if(QALCULATE_MIN_VERSION)
+- exec_program(${PKGCONFIG_EXECUTABLE} ARGS libqalculate --atleast-version=${QALCULATE_MIN_VERSION} RETURN_VALUE _return_VALUE OUTPUT_VARIABLE _pkgconfigDevNull)
++ pkg_check_modules(_pc_QALCULATE libqalculate>=${QALCULATE_MIN_VERSION})
+ else(QALCULATE_MIN_VERSION)
+- exec_program(${PKGCONFIG_EXECUTABLE} ARGS libqalculate --exists RETURN_VALUE _return_VALUE OUTPUT_VARIABLE _pkgconfigDevNull)
++ pkg_check_modules(_pc_QALCULATE libqalculate)
+ endif(QALCULATE_MIN_VERSION)
+
+- if(_return_VALUE STREQUAL "0")
+- exec_program(${PKGCONFIG_EXECUTABLE} ARGS libqalculate --libs OUTPUT_VARIABLE QALCULATE_LIBRARIES)
+- exec_program(${PKGCONFIG_EXECUTABLE} ARGS cln --libs OUTPUT_VARIABLE CLN_LIBRARIES)
+- exec_program(${PKGCONFIG_EXECUTABLE} ARGS libqalculate --cflags OUTPUT_VARIABLE QALCULATE_CFLAGS)
+- set(QALCULATE_FOUND TRUE)
+- endif(_return_VALUE STREQUAL "0")
++ if(_pc_QALCULATE_FOUND)
++ if(${_pc_QALCULATE_VERSION} VERSION_LESS 2.0.0)
++ pkg_check_modules(_pc_CLN cln)
++ endif()
++ set(QALCULATE_CFLAGS ${_pc_QALCULATE_CFLAGS})
++ endif()
++
++ find_library(QALCULATE_LIBRARIES
++ NAMES
++ qalculate
++ PATHS
++ ${_pc_QALCULATE_LIBRARY_DIRS}
++ ${LIB_INSTALL_DIR}
++ )
++
++ find_path(QALCULATE_INCLUDE_DIR
++ NAMES
++ libqalculate
++ PATHS
++ ${_pc_QALCULATE_INCLUDE_DIRS}
++ ${INCLUDE_INSTALL_DIR}
++ )
++
++ if(_pc_QALCULATE_FOUND)
++ if(${_pc_QALCULATE_VERSION} VERSION_LESS 2.0.0)
++ find_library(CLN_LIBRARIES
++ NAMES
++ cln
++ PATHS
++ ${_pc_CLN_LIBRARY_DIRS}
++ ${LIB_INSTALL_DIR}
++ )
++ endif()
++ endif()
+
+ else(NOT WIN32)
+ # XXX: currently no libqalculate on windows