aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2003-11-11 15:13:08 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2003-11-11 15:13:08 +0000
commitffa7e9deb9b8a7c11bde2ca00d8335cddd3142f5 (patch)
tree46b1c089a2cb6f524c425c115f9e76c5498fb40f
parentc198a32f6149bf72e0e74d32042ce2c6eb29ec9d (diff)
downloadports-ffa7e9deb9b8a7c11bde2ca00d8335cddd3142f5.tar.gz
ports-ffa7e9deb9b8a7c11bde2ca00d8335cddd3142f5.zip
Notes
-rw-r--r--databases/sqlite/Makefile7
-rw-r--r--databases/sqlite/distinfo2
-rw-r--r--databases/sqlite/files/patch-Makefile.in136
-rw-r--r--databases/sqlite/files/patch-makefile206
-rw-r--r--databases/sqlite2/Makefile7
-rw-r--r--databases/sqlite2/distinfo2
-rw-r--r--databases/sqlite2/files/patch-Makefile.in136
-rw-r--r--databases/sqlite2/files/patch-makefile206
8 files changed, 282 insertions, 420 deletions
diff --git a/databases/sqlite/Makefile b/databases/sqlite/Makefile
index 56a4b1e39c68..28bea54581f9 100644
--- a/databases/sqlite/Makefile
+++ b/databases/sqlite/Makefile
@@ -12,7 +12,7 @@
# SQLITE_WITH_TCL83 and SQLITE_WITH_TCL84.
PORTNAME= sqlite
-PORTVERSION= 2.8.3
+PORTVERSION= 2.8.6
PORTREVISION= 0
CATEGORIES= databases
MASTER_SITES= http://www.hwaci.com/sw/sqlite/
@@ -22,8 +22,8 @@ MAINTAINER= gh@ghaering.de
COMMENT= An SQL database engine in a C library, including a Tcl wrapper
# Defaults, for building the docs:
-TCL_V= 8.3
-TCL_SHORT_V= 83
+TCL_V= 8.4
+TCL_SHORT_V= 84
.if defined(SQLITE_WITH_TCL83)
CATEGORIES+= tcl83
@@ -33,6 +33,7 @@ WITH_TCL= YES
.endif
.if defined(SQLITE_WITH_TCL84)
+CATEGORIES+= tcl84
TCL_V= 8.4
TCL_SHORT_V= 84
WITH_TCL= YES
diff --git a/databases/sqlite/distinfo b/databases/sqlite/distinfo
index 2041e11bdad7..4d0e52703ddc 100644
--- a/databases/sqlite/distinfo
+++ b/databases/sqlite/distinfo
@@ -1 +1 @@
-MD5 (sqlite-2.8.3.tar.gz) = b038f5812157359c8e87487a017fa3d8
+MD5 (sqlite-2.8.6.tar.gz) = 3047e24370d7e49d7bfd9728addf76cf
diff --git a/databases/sqlite/files/patch-Makefile.in b/databases/sqlite/files/patch-Makefile.in
new file mode 100644
index 000000000000..76834ce6f015
--- /dev/null
+++ b/databases/sqlite/files/patch-Makefile.in
@@ -0,0 +1,136 @@
+--- Makefile.in.orig Thu Aug 21 22:36:16 2003
++++ Makefile.in Tue Nov 11 14:02:32 2003
+@@ -33,7 +33,7 @@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ INSTALL = @INSTALL@
+-LIBTOOL = ./libtool
++LIBTOOL = %%LIBTOOL%%
+
+ # Compiler options needed for programs that use the TCL library.
+ #
+@@ -168,12 +168,12 @@
+
+ libsqlite.la: $(LIBOBJ)
+ $(LIBTOOL) $(TCC) -o libsqlite.la $(LIBOBJ) -rpath $(exec_prefix)/lib \
+- -version-info "8:6:8"
++ -version-info "2:0:0"
+
+ libtclsqlite.la: tclsqlite.lo libsqlite.la
+ $(LIBTOOL) $(TCC) -o libtclsqlite.la tclsqlite.lo \
+ libsqlite.la $(LIBTCL) -rpath $(exec_prefix)/lib \
+- -version-info "8:6:8"
++ -version-info "2:0:0"
+
+ sqlite: $(TOP)/src/shell.c libsqlite.la sqlite.h
+ $(LIBTOOL) $(TCC) $(READLINE_FLAGS) -o sqlite $(TOP)/src/shell.c \
+@@ -341,67 +341,67 @@
+ ./testfixture $(TOP)/test/quick.test
+
+ index.html: $(TOP)/www/index.tcl last_change
+- tclsh $(TOP)/www/index.tcl `cat $(TOP)/VERSION` >index.html
++ $(TCLSH) $(TOP)/www/index.tcl `cat $(TOP)/VERSION` >index.html
+
+ sqlite.html: $(TOP)/www/sqlite.tcl
+- tclsh $(TOP)/www/sqlite.tcl >sqlite.html
++ $(TCLSH) $(TOP)/www/sqlite.tcl >sqlite.html
+
+ c_interface.html: $(TOP)/www/c_interface.tcl
+- tclsh $(TOP)/www/c_interface.tcl >c_interface.html
++ $(TCLSH) $(TOP)/www/c_interface.tcl >c_interface.html
+
+ changes.html: $(TOP)/www/changes.tcl
+- tclsh $(TOP)/www/changes.tcl >changes.html
++ $(TCLSH) $(TOP)/www/changes.tcl >changes.html
+
+ lang.html: $(TOP)/www/lang.tcl
+- tclsh $(TOP)/www/lang.tcl >lang.html
++ $(TCLSH) $(TOP)/www/lang.tcl >lang.html
+
+ vdbe.html: $(TOP)/www/vdbe.tcl
+- tclsh $(TOP)/www/vdbe.tcl >vdbe.html
++ $(TCLSH) $(TOP)/www/vdbe.tcl >vdbe.html
+
+ arch.html: $(TOP)/www/arch.tcl
+- tclsh $(TOP)/www/arch.tcl >arch.html
++ $(TCLSH) $(TOP)/www/arch.tcl >arch.html
+
+ arch.png: $(TOP)/www/arch.png
+ cp $(TOP)/www/arch.png .
+
+ opcode.html: $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c
+- tclsh $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c >opcode.html
++ $(TCLSH) $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c >opcode.html
+
+ mingw.html: $(TOP)/www/mingw.tcl
+- tclsh $(TOP)/www/mingw.tcl >mingw.html
++ $(TCLSH) $(TOP)/www/mingw.tcl >mingw.html
+
+ tclsqlite.html: $(TOP)/www/tclsqlite.tcl
+- tclsh $(TOP)/www/tclsqlite.tcl >tclsqlite.html
++ $(TCLSH) $(TOP)/www/tclsqlite.tcl >tclsqlite.html
+
+ speed.html: $(TOP)/www/speed.tcl
+- tclsh $(TOP)/www/speed.tcl >speed.html
++ $(TCLSH) $(TOP)/www/speed.tcl >speed.html
+
+ faq.html: $(TOP)/www/faq.tcl
+- tclsh $(TOP)/www/faq.tcl >faq.html
++ $(TCLSH) $(TOP)/www/faq.tcl >faq.html
+
+ formatchng.html: $(TOP)/www/formatchng.tcl
+- tclsh $(TOP)/www/formatchng.tcl >formatchng.html
++ $(TCLSH) $(TOP)/www/formatchng.tcl >formatchng.html
+
+ conflict.html: $(TOP)/www/conflict.tcl
+- tclsh $(TOP)/www/conflict.tcl >conflict.html
++ $(TCLSH) $(TOP)/www/conflict.tcl >conflict.html
+
+ download.html: $(TOP)/www/download.tcl
+- tclsh $(TOP)/www/download.tcl >download.html
++ $(TCLSH) $(TOP)/www/download.tcl >download.html
+
+ omitted.html: $(TOP)/www/omitted.tcl
+- tclsh $(TOP)/www/omitted.tcl >omitted.html
++ $(TCLSH) $(TOP)/www/omitted.tcl >omitted.html
+
+ datatypes.html: $(TOP)/www/datatypes.tcl
+- tclsh $(TOP)/www/datatypes.tcl >datatypes.html
++ $(TCLSH) $(TOP)/www/datatypes.tcl >datatypes.html
+
+ quickstart.html: $(TOP)/www/quickstart.tcl
+- tclsh $(TOP)/www/quickstart.tcl >quickstart.html
++ $(TCLSH) $(TOP)/www/quickstart.tcl >quickstart.html
+
+ fileformat.html: $(TOP)/www/fileformat.tcl
+- tclsh $(TOP)/www/fileformat.tcl >fileformat.html
++ $(TCLSH) $(TOP)/www/fileformat.tcl >fileformat.html
+
+ nulls.html: $(TOP)/www/nulls.tcl
+- tclsh $(TOP)/www/nulls.tcl >nulls.html
++ $(TCLSH) $(TOP)/www/nulls.tcl >nulls.html
+
+
+ # Files to be published on the website.
+@@ -435,13 +435,19 @@
+
+ install: sqlite libsqlite.la sqlite.h
+ $(INSTALL) -d $(exec_prefix)/lib
+- $(LIBTOOL) $(INSTALL) libsqlite.la $(exec_prefix)/lib
++ $(INSTALL) .libs/libsqlite.a $(exec_prefix)/lib
++ $(INSTALL) .libs/libsqlite.so $(exec_prefix)/lib
++ $(INSTALL) .libs/libsqlite.so.2 $(exec_prefix)/lib
+ $(INSTALL) -d $(exec_prefix)/bin
+- $(LIBTOOL) $(INSTALL) sqlite $(exec_prefix)/bin
++ $(INSTALL) .libs/sqlite $(exec_prefix)/bin
+ $(INSTALL) -d $(prefix)/include
+ $(INSTALL) -m 0644 sqlite.h $(prefix)/include
+ $(INSTALL) -d $(exec_prefix)/lib/pkgconfig; \
+ $(INSTALL) -m 0644 sqlite.pc $(exec_prefix)/lib/pkgconfig; \
++
++install-tcl: libtclsqlite.la
++ $(INSTALL) -d $(prefix)/lib/sqlite
++ $(INSTALL) .libs/libtclsqlite.so $(prefix)/lib/sqlite
+
+ clean:
+ rm -f *.lo *.la *.o sqlite libsqlite.la sqlite.h opcodes.*
diff --git a/databases/sqlite/files/patch-makefile b/databases/sqlite/files/patch-makefile
deleted file mode 100644
index a3739872b3c1..000000000000
--- a/databases/sqlite/files/patch-makefile
+++ /dev/null
@@ -1,206 +0,0 @@
-*** ../../tmp/sqlite/Makefile.in Sat May 17 04:26:29 2003
---- Makefile.in Sun Jun 8 18:54:50 2003
-***************
-*** 33,39 ****
- prefix = @prefix@
- exec_prefix = @exec_prefix@
- INSTALL = @INSTALL@
-! LIBTOOL = ./libtool
-
- # Compiler options needed for programs that use the TCL library.
- #
---- 33,39 ----
- prefix = @prefix@
- exec_prefix = @exec_prefix@
- INSTALL = @INSTALL@
-! LIBTOOL = %%LIBTOOL%%
-
- # Compiler options needed for programs that use the TCL library.
- #
-***************
-*** 166,172 ****
- | awk '{print $$5,$$6}' >last_change
-
- libsqlite.la: $(LIBOBJ)
-! $(LIBTOOL) $(TCC) -o libsqlite.la $(LIBOBJ) -rpath $(exec_prefix)/lib
-
- libtclsqlite.la: tclsqlite.lo libsqlite.la
- $(LIBTOOL) $(TCC) -o libtclsqlite.la tclsqlite.lo \
---- 166,172 ----
- | awk '{print $$5,$$6}' >last_change
-
- libsqlite.la: $(LIBOBJ)
-! $(LIBTOOL) $(TCC) -o libsqlite.la $(LIBOBJ) -rpath $(exec_prefix)/lib -version-info 2:0:0
-
- libtclsqlite.la: tclsqlite.lo libsqlite.la
- $(LIBTOOL) $(TCC) -o libtclsqlite.la tclsqlite.lo \
-***************
-*** 338,404 ****
- ./testfixture $(TOP)/test/quick.test
-
- index.html: $(TOP)/www/index.tcl last_change
-! tclsh $(TOP)/www/index.tcl `cat $(TOP)/VERSION` >index.html
-
- sqlite.html: $(TOP)/www/sqlite.tcl
-! tclsh $(TOP)/www/sqlite.tcl >sqlite.html
-
- c_interface.html: $(TOP)/www/c_interface.tcl
-! tclsh $(TOP)/www/c_interface.tcl >c_interface.html
-
- changes.html: $(TOP)/www/changes.tcl
-! tclsh $(TOP)/www/changes.tcl >changes.html
-
- lang.html: $(TOP)/www/lang.tcl
-! tclsh $(TOP)/www/lang.tcl >lang.html
-
- vdbe.html: $(TOP)/www/vdbe.tcl
-! tclsh $(TOP)/www/vdbe.tcl >vdbe.html
-
- arch.html: $(TOP)/www/arch.tcl
-! tclsh $(TOP)/www/arch.tcl >arch.html
-
- arch.png: $(TOP)/www/arch.png
- cp $(TOP)/www/arch.png .
-
- opcode.html: $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c
-! tclsh $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c >opcode.html
-
- mingw.html: $(TOP)/www/mingw.tcl
-! tclsh $(TOP)/www/mingw.tcl >mingw.html
-
- tclsqlite.html: $(TOP)/www/tclsqlite.tcl
-! tclsh $(TOP)/www/tclsqlite.tcl >tclsqlite.html
-
- speed.html: $(TOP)/www/speed.tcl
-! tclsh $(TOP)/www/speed.tcl >speed.html
-
- faq.html: $(TOP)/www/faq.tcl
-! tclsh $(TOP)/www/faq.tcl >faq.html
-
- formatchng.html: $(TOP)/www/formatchng.tcl
-! tclsh $(TOP)/www/formatchng.tcl >formatchng.html
-
- conflict.html: $(TOP)/www/conflict.tcl
-! tclsh $(TOP)/www/conflict.tcl >conflict.html
-
- download.html: $(TOP)/www/download.tcl
-! tclsh $(TOP)/www/download.tcl >download.html
-
- omitted.html: $(TOP)/www/omitted.tcl
-! tclsh $(TOP)/www/omitted.tcl >omitted.html
-
- datatypes.html: $(TOP)/www/datatypes.tcl
-! tclsh $(TOP)/www/datatypes.tcl >datatypes.html
-
- quickstart.html: $(TOP)/www/quickstart.tcl
-! tclsh $(TOP)/www/quickstart.tcl >quickstart.html
-
- fileformat.html: $(TOP)/www/fileformat.tcl
-! tclsh $(TOP)/www/fileformat.tcl >fileformat.html
-
- nulls.html: $(TOP)/www/nulls.tcl
-! tclsh $(TOP)/www/nulls.tcl >nulls.html
-
-
- # Files to be published on the website.
---- 338,404 ----
- ./testfixture $(TOP)/test/quick.test
-
- index.html: $(TOP)/www/index.tcl last_change
-! $(TCLSH) $(TOP)/www/index.tcl `cat $(TOP)/VERSION` >index.html
-
- sqlite.html: $(TOP)/www/sqlite.tcl
-! $(TCLSH) $(TOP)/www/sqlite.tcl >sqlite.html
-
- c_interface.html: $(TOP)/www/c_interface.tcl
-! $(TCLSH) $(TOP)/www/c_interface.tcl >c_interface.html
-
- changes.html: $(TOP)/www/changes.tcl
-! $(TCLSH) $(TOP)/www/changes.tcl >changes.html
-
- lang.html: $(TOP)/www/lang.tcl
-! $(TCLSH) $(TOP)/www/lang.tcl >lang.html
-
- vdbe.html: $(TOP)/www/vdbe.tcl
-! $(TCLSH) $(TOP)/www/vdbe.tcl >vdbe.html
-
- arch.html: $(TOP)/www/arch.tcl
-! $(TCLSH) $(TOP)/www/arch.tcl >arch.html
-
- arch.png: $(TOP)/www/arch.png
- cp $(TOP)/www/arch.png .
-
- opcode.html: $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c
-! $(TCLSH) $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c >opcode.html
-
- mingw.html: $(TOP)/www/mingw.tcl
-! $(TCLSH) $(TOP)/www/mingw.tcl >mingw.html
-
- tclsqlite.html: $(TOP)/www/tclsqlite.tcl
-! $(TCLSH) $(TOP)/www/tclsqlite.tcl >tclsqlite.html
-
- speed.html: $(TOP)/www/speed.tcl
-! $(TCLSH) $(TOP)/www/speed.tcl >speed.html
-
- faq.html: $(TOP)/www/faq.tcl
-! $(TCLSH) $(TOP)/www/faq.tcl >faq.html
-
- formatchng.html: $(TOP)/www/formatchng.tcl
-! $(TCLSH) $(TOP)/www/formatchng.tcl >formatchng.html
-
- conflict.html: $(TOP)/www/conflict.tcl
-! $(TCLSH) $(TOP)/www/conflict.tcl >conflict.html
-
- download.html: $(TOP)/www/download.tcl
-! $(TCLSH) $(TOP)/www/download.tcl >download.html
-
- omitted.html: $(TOP)/www/omitted.tcl
-! $(TCLSH) $(TOP)/www/omitted.tcl >omitted.html
-
- datatypes.html: $(TOP)/www/datatypes.tcl
-! $(TCLSH) $(TOP)/www/datatypes.tcl >datatypes.html
-
- quickstart.html: $(TOP)/www/quickstart.tcl
-! $(TCLSH) $(TOP)/www/quickstart.tcl >quickstart.html
-
- fileformat.html: $(TOP)/www/fileformat.tcl
-! $(TCLSH) $(TOP)/www/fileformat.tcl >fileformat.html
-
- nulls.html: $(TOP)/www/nulls.tcl
-! $(TCLSH) $(TOP)/www/nulls.tcl >nulls.html
-
-
- # Files to be published on the website.
-***************
-*** 432,444 ****
-
- install: sqlite libsqlite.la sqlite.h
- $(INSTALL) -d $(exec_prefix)/lib
-! $(LIBTOOL) $(INSTALL) libsqlite.la $(exec_prefix)/lib
- $(INSTALL) -d $(exec_prefix)/bin
-! $(LIBTOOL) $(INSTALL) sqlite $(exec_prefix)/bin
- $(INSTALL) -d $(prefix)/include
- $(INSTALL) -m 0644 sqlite.h $(prefix)/include
-! $(INSTALL) -d $(exec_prefix)/lib/pkgconfig; \
-! $(INSTALL) -m 0644 sqlite.pc $(exec_prefix)/lib/pkgconfig; \
-
- clean:
- rm -f *.lo *.la *.o sqlite libsqlite.la sqlite.h opcodes.*
---- 432,448 ----
-
- install: sqlite libsqlite.la sqlite.h
- $(INSTALL) -d $(exec_prefix)/lib
-! $(INSTALL) .libs/libsqlite.a $(prefix)/lib
-! $(INSTALL) .libs/libsqlite.so $(prefix)/lib
-! $(INSTALL) .libs/libsqlite.so.2 $(prefix)/lib
- $(INSTALL) -d $(exec_prefix)/bin
-! $(INSTALL) .libs/sqlite $(exec_prefix)/bin
- $(INSTALL) -d $(prefix)/include
- $(INSTALL) -m 0644 sqlite.h $(prefix)/include
-!
-! install-tcl: libtclsqlite.la
-! $(INSTALL) -d $(prefix)/lib/sqlite
-! $(INSTALL) .libs/libtclsqlite.so $(prefix)/lib/sqlite
-
- clean:
- rm -f *.lo *.la *.o sqlite libsqlite.la sqlite.h opcodes.*
diff --git a/databases/sqlite2/Makefile b/databases/sqlite2/Makefile
index 56a4b1e39c68..28bea54581f9 100644
--- a/databases/sqlite2/Makefile
+++ b/databases/sqlite2/Makefile
@@ -12,7 +12,7 @@
# SQLITE_WITH_TCL83 and SQLITE_WITH_TCL84.
PORTNAME= sqlite
-PORTVERSION= 2.8.3
+PORTVERSION= 2.8.6
PORTREVISION= 0
CATEGORIES= databases
MASTER_SITES= http://www.hwaci.com/sw/sqlite/
@@ -22,8 +22,8 @@ MAINTAINER= gh@ghaering.de
COMMENT= An SQL database engine in a C library, including a Tcl wrapper
# Defaults, for building the docs:
-TCL_V= 8.3
-TCL_SHORT_V= 83
+TCL_V= 8.4
+TCL_SHORT_V= 84
.if defined(SQLITE_WITH_TCL83)
CATEGORIES+= tcl83
@@ -33,6 +33,7 @@ WITH_TCL= YES
.endif
.if defined(SQLITE_WITH_TCL84)
+CATEGORIES+= tcl84
TCL_V= 8.4
TCL_SHORT_V= 84
WITH_TCL= YES
diff --git a/databases/sqlite2/distinfo b/databases/sqlite2/distinfo
index 2041e11bdad7..4d0e52703ddc 100644
--- a/databases/sqlite2/distinfo
+++ b/databases/sqlite2/distinfo
@@ -1 +1 @@
-MD5 (sqlite-2.8.3.tar.gz) = b038f5812157359c8e87487a017fa3d8
+MD5 (sqlite-2.8.6.tar.gz) = 3047e24370d7e49d7bfd9728addf76cf
diff --git a/databases/sqlite2/files/patch-Makefile.in b/databases/sqlite2/files/patch-Makefile.in
new file mode 100644
index 000000000000..76834ce6f015
--- /dev/null
+++ b/databases/sqlite2/files/patch-Makefile.in
@@ -0,0 +1,136 @@
+--- Makefile.in.orig Thu Aug 21 22:36:16 2003
++++ Makefile.in Tue Nov 11 14:02:32 2003
+@@ -33,7 +33,7 @@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ INSTALL = @INSTALL@
+-LIBTOOL = ./libtool
++LIBTOOL = %%LIBTOOL%%
+
+ # Compiler options needed for programs that use the TCL library.
+ #
+@@ -168,12 +168,12 @@
+
+ libsqlite.la: $(LIBOBJ)
+ $(LIBTOOL) $(TCC) -o libsqlite.la $(LIBOBJ) -rpath $(exec_prefix)/lib \
+- -version-info "8:6:8"
++ -version-info "2:0:0"
+
+ libtclsqlite.la: tclsqlite.lo libsqlite.la
+ $(LIBTOOL) $(TCC) -o libtclsqlite.la tclsqlite.lo \
+ libsqlite.la $(LIBTCL) -rpath $(exec_prefix)/lib \
+- -version-info "8:6:8"
++ -version-info "2:0:0"
+
+ sqlite: $(TOP)/src/shell.c libsqlite.la sqlite.h
+ $(LIBTOOL) $(TCC) $(READLINE_FLAGS) -o sqlite $(TOP)/src/shell.c \
+@@ -341,67 +341,67 @@
+ ./testfixture $(TOP)/test/quick.test
+
+ index.html: $(TOP)/www/index.tcl last_change
+- tclsh $(TOP)/www/index.tcl `cat $(TOP)/VERSION` >index.html
++ $(TCLSH) $(TOP)/www/index.tcl `cat $(TOP)/VERSION` >index.html
+
+ sqlite.html: $(TOP)/www/sqlite.tcl
+- tclsh $(TOP)/www/sqlite.tcl >sqlite.html
++ $(TCLSH) $(TOP)/www/sqlite.tcl >sqlite.html
+
+ c_interface.html: $(TOP)/www/c_interface.tcl
+- tclsh $(TOP)/www/c_interface.tcl >c_interface.html
++ $(TCLSH) $(TOP)/www/c_interface.tcl >c_interface.html
+
+ changes.html: $(TOP)/www/changes.tcl
+- tclsh $(TOP)/www/changes.tcl >changes.html
++ $(TCLSH) $(TOP)/www/changes.tcl >changes.html
+
+ lang.html: $(TOP)/www/lang.tcl
+- tclsh $(TOP)/www/lang.tcl >lang.html
++ $(TCLSH) $(TOP)/www/lang.tcl >lang.html
+
+ vdbe.html: $(TOP)/www/vdbe.tcl
+- tclsh $(TOP)/www/vdbe.tcl >vdbe.html
++ $(TCLSH) $(TOP)/www/vdbe.tcl >vdbe.html
+
+ arch.html: $(TOP)/www/arch.tcl
+- tclsh $(TOP)/www/arch.tcl >arch.html
++ $(TCLSH) $(TOP)/www/arch.tcl >arch.html
+
+ arch.png: $(TOP)/www/arch.png
+ cp $(TOP)/www/arch.png .
+
+ opcode.html: $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c
+- tclsh $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c >opcode.html
++ $(TCLSH) $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c >opcode.html
+
+ mingw.html: $(TOP)/www/mingw.tcl
+- tclsh $(TOP)/www/mingw.tcl >mingw.html
++ $(TCLSH) $(TOP)/www/mingw.tcl >mingw.html
+
+ tclsqlite.html: $(TOP)/www/tclsqlite.tcl
+- tclsh $(TOP)/www/tclsqlite.tcl >tclsqlite.html
++ $(TCLSH) $(TOP)/www/tclsqlite.tcl >tclsqlite.html
+
+ speed.html: $(TOP)/www/speed.tcl
+- tclsh $(TOP)/www/speed.tcl >speed.html
++ $(TCLSH) $(TOP)/www/speed.tcl >speed.html
+
+ faq.html: $(TOP)/www/faq.tcl
+- tclsh $(TOP)/www/faq.tcl >faq.html
++ $(TCLSH) $(TOP)/www/faq.tcl >faq.html
+
+ formatchng.html: $(TOP)/www/formatchng.tcl
+- tclsh $(TOP)/www/formatchng.tcl >formatchng.html
++ $(TCLSH) $(TOP)/www/formatchng.tcl >formatchng.html
+
+ conflict.html: $(TOP)/www/conflict.tcl
+- tclsh $(TOP)/www/conflict.tcl >conflict.html
++ $(TCLSH) $(TOP)/www/conflict.tcl >conflict.html
+
+ download.html: $(TOP)/www/download.tcl
+- tclsh $(TOP)/www/download.tcl >download.html
++ $(TCLSH) $(TOP)/www/download.tcl >download.html
+
+ omitted.html: $(TOP)/www/omitted.tcl
+- tclsh $(TOP)/www/omitted.tcl >omitted.html
++ $(TCLSH) $(TOP)/www/omitted.tcl >omitted.html
+
+ datatypes.html: $(TOP)/www/datatypes.tcl
+- tclsh $(TOP)/www/datatypes.tcl >datatypes.html
++ $(TCLSH) $(TOP)/www/datatypes.tcl >datatypes.html
+
+ quickstart.html: $(TOP)/www/quickstart.tcl
+- tclsh $(TOP)/www/quickstart.tcl >quickstart.html
++ $(TCLSH) $(TOP)/www/quickstart.tcl >quickstart.html
+
+ fileformat.html: $(TOP)/www/fileformat.tcl
+- tclsh $(TOP)/www/fileformat.tcl >fileformat.html
++ $(TCLSH) $(TOP)/www/fileformat.tcl >fileformat.html
+
+ nulls.html: $(TOP)/www/nulls.tcl
+- tclsh $(TOP)/www/nulls.tcl >nulls.html
++ $(TCLSH) $(TOP)/www/nulls.tcl >nulls.html
+
+
+ # Files to be published on the website.
+@@ -435,13 +435,19 @@
+
+ install: sqlite libsqlite.la sqlite.h
+ $(INSTALL) -d $(exec_prefix)/lib
+- $(LIBTOOL) $(INSTALL) libsqlite.la $(exec_prefix)/lib
++ $(INSTALL) .libs/libsqlite.a $(exec_prefix)/lib
++ $(INSTALL) .libs/libsqlite.so $(exec_prefix)/lib
++ $(INSTALL) .libs/libsqlite.so.2 $(exec_prefix)/lib
+ $(INSTALL) -d $(exec_prefix)/bin
+- $(LIBTOOL) $(INSTALL) sqlite $(exec_prefix)/bin
++ $(INSTALL) .libs/sqlite $(exec_prefix)/bin
+ $(INSTALL) -d $(prefix)/include
+ $(INSTALL) -m 0644 sqlite.h $(prefix)/include
+ $(INSTALL) -d $(exec_prefix)/lib/pkgconfig; \
+ $(INSTALL) -m 0644 sqlite.pc $(exec_prefix)/lib/pkgconfig; \
++
++install-tcl: libtclsqlite.la
++ $(INSTALL) -d $(prefix)/lib/sqlite
++ $(INSTALL) .libs/libtclsqlite.so $(prefix)/lib/sqlite
+
+ clean:
+ rm -f *.lo *.la *.o sqlite libsqlite.la sqlite.h opcodes.*
diff --git a/databases/sqlite2/files/patch-makefile b/databases/sqlite2/files/patch-makefile
deleted file mode 100644
index a3739872b3c1..000000000000
--- a/databases/sqlite2/files/patch-makefile
+++ /dev/null
@@ -1,206 +0,0 @@
-*** ../../tmp/sqlite/Makefile.in Sat May 17 04:26:29 2003
---- Makefile.in Sun Jun 8 18:54:50 2003
-***************
-*** 33,39 ****
- prefix = @prefix@
- exec_prefix = @exec_prefix@
- INSTALL = @INSTALL@
-! LIBTOOL = ./libtool
-
- # Compiler options needed for programs that use the TCL library.
- #
---- 33,39 ----
- prefix = @prefix@
- exec_prefix = @exec_prefix@
- INSTALL = @INSTALL@
-! LIBTOOL = %%LIBTOOL%%
-
- # Compiler options needed for programs that use the TCL library.
- #
-***************
-*** 166,172 ****
- | awk '{print $$5,$$6}' >last_change
-
- libsqlite.la: $(LIBOBJ)
-! $(LIBTOOL) $(TCC) -o libsqlite.la $(LIBOBJ) -rpath $(exec_prefix)/lib
-
- libtclsqlite.la: tclsqlite.lo libsqlite.la
- $(LIBTOOL) $(TCC) -o libtclsqlite.la tclsqlite.lo \
---- 166,172 ----
- | awk '{print $$5,$$6}' >last_change
-
- libsqlite.la: $(LIBOBJ)
-! $(LIBTOOL) $(TCC) -o libsqlite.la $(LIBOBJ) -rpath $(exec_prefix)/lib -version-info 2:0:0
-
- libtclsqlite.la: tclsqlite.lo libsqlite.la
- $(LIBTOOL) $(TCC) -o libtclsqlite.la tclsqlite.lo \
-***************
-*** 338,404 ****
- ./testfixture $(TOP)/test/quick.test
-
- index.html: $(TOP)/www/index.tcl last_change
-! tclsh $(TOP)/www/index.tcl `cat $(TOP)/VERSION` >index.html
-
- sqlite.html: $(TOP)/www/sqlite.tcl
-! tclsh $(TOP)/www/sqlite.tcl >sqlite.html
-
- c_interface.html: $(TOP)/www/c_interface.tcl
-! tclsh $(TOP)/www/c_interface.tcl >c_interface.html
-
- changes.html: $(TOP)/www/changes.tcl
-! tclsh $(TOP)/www/changes.tcl >changes.html
-
- lang.html: $(TOP)/www/lang.tcl
-! tclsh $(TOP)/www/lang.tcl >lang.html
-
- vdbe.html: $(TOP)/www/vdbe.tcl
-! tclsh $(TOP)/www/vdbe.tcl >vdbe.html
-
- arch.html: $(TOP)/www/arch.tcl
-! tclsh $(TOP)/www/arch.tcl >arch.html
-
- arch.png: $(TOP)/www/arch.png
- cp $(TOP)/www/arch.png .
-
- opcode.html: $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c
-! tclsh $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c >opcode.html
-
- mingw.html: $(TOP)/www/mingw.tcl
-! tclsh $(TOP)/www/mingw.tcl >mingw.html
-
- tclsqlite.html: $(TOP)/www/tclsqlite.tcl
-! tclsh $(TOP)/www/tclsqlite.tcl >tclsqlite.html
-
- speed.html: $(TOP)/www/speed.tcl
-! tclsh $(TOP)/www/speed.tcl >speed.html
-
- faq.html: $(TOP)/www/faq.tcl
-! tclsh $(TOP)/www/faq.tcl >faq.html
-
- formatchng.html: $(TOP)/www/formatchng.tcl
-! tclsh $(TOP)/www/formatchng.tcl >formatchng.html
-
- conflict.html: $(TOP)/www/conflict.tcl
-! tclsh $(TOP)/www/conflict.tcl >conflict.html
-
- download.html: $(TOP)/www/download.tcl
-! tclsh $(TOP)/www/download.tcl >download.html
-
- omitted.html: $(TOP)/www/omitted.tcl
-! tclsh $(TOP)/www/omitted.tcl >omitted.html
-
- datatypes.html: $(TOP)/www/datatypes.tcl
-! tclsh $(TOP)/www/datatypes.tcl >datatypes.html
-
- quickstart.html: $(TOP)/www/quickstart.tcl
-! tclsh $(TOP)/www/quickstart.tcl >quickstart.html
-
- fileformat.html: $(TOP)/www/fileformat.tcl
-! tclsh $(TOP)/www/fileformat.tcl >fileformat.html
-
- nulls.html: $(TOP)/www/nulls.tcl
-! tclsh $(TOP)/www/nulls.tcl >nulls.html
-
-
- # Files to be published on the website.
---- 338,404 ----
- ./testfixture $(TOP)/test/quick.test
-
- index.html: $(TOP)/www/index.tcl last_change
-! $(TCLSH) $(TOP)/www/index.tcl `cat $(TOP)/VERSION` >index.html
-
- sqlite.html: $(TOP)/www/sqlite.tcl
-! $(TCLSH) $(TOP)/www/sqlite.tcl >sqlite.html
-
- c_interface.html: $(TOP)/www/c_interface.tcl
-! $(TCLSH) $(TOP)/www/c_interface.tcl >c_interface.html
-
- changes.html: $(TOP)/www/changes.tcl
-! $(TCLSH) $(TOP)/www/changes.tcl >changes.html
-
- lang.html: $(TOP)/www/lang.tcl
-! $(TCLSH) $(TOP)/www/lang.tcl >lang.html
-
- vdbe.html: $(TOP)/www/vdbe.tcl
-! $(TCLSH) $(TOP)/www/vdbe.tcl >vdbe.html
-
- arch.html: $(TOP)/www/arch.tcl
-! $(TCLSH) $(TOP)/www/arch.tcl >arch.html
-
- arch.png: $(TOP)/www/arch.png
- cp $(TOP)/www/arch.png .
-
- opcode.html: $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c
-! $(TCLSH) $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c >opcode.html
-
- mingw.html: $(TOP)/www/mingw.tcl
-! $(TCLSH) $(TOP)/www/mingw.tcl >mingw.html
-
- tclsqlite.html: $(TOP)/www/tclsqlite.tcl
-! $(TCLSH) $(TOP)/www/tclsqlite.tcl >tclsqlite.html
-
- speed.html: $(TOP)/www/speed.tcl
-! $(TCLSH) $(TOP)/www/speed.tcl >speed.html
-
- faq.html: $(TOP)/www/faq.tcl
-! $(TCLSH) $(TOP)/www/faq.tcl >faq.html
-
- formatchng.html: $(TOP)/www/formatchng.tcl
-! $(TCLSH) $(TOP)/www/formatchng.tcl >formatchng.html
-
- conflict.html: $(TOP)/www/conflict.tcl
-! $(TCLSH) $(TOP)/www/conflict.tcl >conflict.html
-
- download.html: $(TOP)/www/download.tcl
-! $(TCLSH) $(TOP)/www/download.tcl >download.html
-
- omitted.html: $(TOP)/www/omitted.tcl
-! $(TCLSH) $(TOP)/www/omitted.tcl >omitted.html
-
- datatypes.html: $(TOP)/www/datatypes.tcl
-! $(TCLSH) $(TOP)/www/datatypes.tcl >datatypes.html
-
- quickstart.html: $(TOP)/www/quickstart.tcl
-! $(TCLSH) $(TOP)/www/quickstart.tcl >quickstart.html
-
- fileformat.html: $(TOP)/www/fileformat.tcl
-! $(TCLSH) $(TOP)/www/fileformat.tcl >fileformat.html
-
- nulls.html: $(TOP)/www/nulls.tcl
-! $(TCLSH) $(TOP)/www/nulls.tcl >nulls.html
-
-
- # Files to be published on the website.
-***************
-*** 432,444 ****
-
- install: sqlite libsqlite.la sqlite.h
- $(INSTALL) -d $(exec_prefix)/lib
-! $(LIBTOOL) $(INSTALL) libsqlite.la $(exec_prefix)/lib
- $(INSTALL) -d $(exec_prefix)/bin
-! $(LIBTOOL) $(INSTALL) sqlite $(exec_prefix)/bin
- $(INSTALL) -d $(prefix)/include
- $(INSTALL) -m 0644 sqlite.h $(prefix)/include
-! $(INSTALL) -d $(exec_prefix)/lib/pkgconfig; \
-! $(INSTALL) -m 0644 sqlite.pc $(exec_prefix)/lib/pkgconfig; \
-
- clean:
- rm -f *.lo *.la *.o sqlite libsqlite.la sqlite.h opcodes.*
---- 432,448 ----
-
- install: sqlite libsqlite.la sqlite.h
- $(INSTALL) -d $(exec_prefix)/lib
-! $(INSTALL) .libs/libsqlite.a $(prefix)/lib
-! $(INSTALL) .libs/libsqlite.so $(prefix)/lib
-! $(INSTALL) .libs/libsqlite.so.2 $(prefix)/lib
- $(INSTALL) -d $(exec_prefix)/bin
-! $(INSTALL) .libs/sqlite $(exec_prefix)/bin
- $(INSTALL) -d $(prefix)/include
- $(INSTALL) -m 0644 sqlite.h $(prefix)/include
-!
-! install-tcl: libtclsqlite.la
-! $(INSTALL) -d $(prefix)/lib/sqlite
-! $(INSTALL) .libs/libtclsqlite.so $(prefix)/lib/sqlite
-
- clean:
- rm -f *.lo *.la *.o sqlite libsqlite.la sqlite.h opcodes.*