aboutsummaryrefslogtreecommitdiff
path: root/CHANGES
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2022-12-17 20:13:44 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2022-12-17 20:20:28 +0000
commit2b3e37f30c249db5e9957c3ee41c25dea3191fc5 (patch)
tree7e0d7403892e331cd0d944333c0feb82ad629416 /CHANGES
parent212b995746a04fa8ef4d417b1943f611a8ef79b7 (diff)
downloadports-2b3e37f30c249db5e9957c3ee41c25dea3191fc5.tar.gz
ports-2b3e37f30c249db5e9957c3ee41c25dea3191fc5.zip
framework: Add new USES=llvm to more easily depend on one an llvm port
USES=llvm supports two kinds of arguments: * mode <none>: defaults to build build: add a BUILD_DEPENDS on chosen llvm-port run: add a RUN_DEPENDS on chosen llvm-port lib: add a LIB_DEPENDS on chosen llvm-port * version <none>: defaults to ${LLVM_DEFAULT} number: use explicitly the specified version min=number: use specified min if ${LLVM_DEFAULT} is lower max=number: use specified max if ${LLVM_DEFAULT} is higher An example usage might be: USES= llvm or USES= llvm:13,build or USES= llvm:min=14,lib The following variables are exposed to be used in the ports tree at the moment: * LLVM_VERSION version chosen from the arguments to llvm.mk * LLVM_PORT chosen llvm port * LLVM_CONFIG llvm-config of the chosen port * LLVM_LIBLLVM libLLVM.so of the chosen port * LLVM_PREFIX installation prefix of the chosen port Reviewed by: manu, bapt Differential Revision: https://reviews.freebsd.org/D37728
Diffstat (limited to 'CHANGES')
-rw-r--r--CHANGES33
1 files changed, 33 insertions, 0 deletions
diff --git a/CHANGES b/CHANGES
index 2cbcf2bd6a31..35c4205aee0b 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,39 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20221217:
+AUTHOR: tcberner@FreeBSD.org
+
+ USES=llvm has been added to more easily depend on llvm.
+
+ USES=llvm supports two kinds of arguments:
+
+ * mode
+ <none>: defaults to build
+ build: add a BUILD_DEPENDS on chosen llvm-port
+ run: add a RUN_DEPENDS on chosen llvm-port
+ lib: add a LIB_DEPENDS on chosen llvm-port
+
+ * version
+ <none>: defaults to ${LLVM_DEFAULT}
+ number: use explicitly the specified version
+ min=number: use specified min if ${LLVM_DEFAULT} is lower
+ max=number: use specified max if ${LLVM_DEFAULT} is higher
+
+ An example usage might be:
+ USES= llvm
+ or
+ USES= llvm:13,build
+ or
+ USES= llvm:min=14,lib
+
+ The following variables are exposed to be used in the ports tree at the moment:
+ * LLVM_VERSION version chosen from the arguments to llvm.mk
+ * LLVM_PORT chosen llvm port
+ * LLVM_CONFIG llvm-config of the chosen port
+ * LLVM_LIBLLVM libLLVM.so of the chosen port
+ * LLVM_PREFIX installation prefix of the chosen port
+
20221026:
AUTHOR: bapt@FreeBSD.org
3 new features are available now: PIE, RELRO, BIND_NOW, each port can