aboutsummaryrefslogtreecommitdiff
path: root/CHANGES
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-08-24 14:50:04 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-08-24 14:50:04 +0000
commita8409dba34324641cc6a5a9952da57067ace186e (patch)
tree2ea794732811d2a0fb93f0cd87576b38d773968e /CHANGES
parent03c995b4fa9a9072450ef339026d5e5f263d5c51 (diff)
downloadports-a8409dba34324641cc6a5a9952da57067ace186e.tar.gz
ports-a8409dba34324641cc6a5a9952da57067ace186e.zip
Add GH_SUBDIR, automatically moves a secondary distfile to the right
place inside ${WRKSRC}. Before: GH_TUPLE= Regaddi:Chart.js:f13f99b:chart_js \ FVANCOP:ChartNew.js:77e7f87:chartnew_js post-extract: @${RMDIR} ${WRKSRC}/database ${WRKSRC}/3rd/Chart.js @${MV} ${WRKSRC_database} ${WRKSRC}/database @${MV} ${WRKSRC_chart_js} ${WRKSRC}/3rd/Chart.js After: GH_TUPLE= Regaddi:Chart.js:f13f99b:chart_js/3rd/Chart.js \ FVANCOP:ChartNew.js:77e7f87:chartnew_js/3rd/ChartNew.js Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D7583
Notes
Notes: svn path=/head/; revision=420795
Diffstat (limited to 'CHANGES')
-rw-r--r--CHANGES31
1 files changed, 29 insertions, 2 deletions
diff --git a/CHANGES b/CHANGES
index 38ba51897028..b5571d026405 100644
--- a/CHANGES
+++ b/CHANGES
@@ -11,7 +11,34 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
20160824:
+AUTHOR: mat@FreeBSD.org
+
+ To complete the USE_GITHUB framework, a GH_SUBDIR variable has been added.
+ It automatically moves a secondary distfile to the right place inside WRKSRC.
+ It also extends the GH_TUPLE variable to make it as easy to use as possible.
+
+ Before:
+
+ GH_TUPLE= Regaddi:Chart.js:f13f99b:chart_js \
+ FVANCOP:ChartNew.js:77e7f87:chartnew_js
+ post-extract:
+ @${RMDIR} ${WRKSRC}/database ${WRKSRC}/3rd/Chart.js
+ @${MV} ${WRKSRC_database} ${WRKSRC}/database
+ @${MV} ${WRKSRC_chart_js} ${WRKSRC}/3rd/Chart.js
+
+ After:
+
+ GH_TUPLE= Regaddi:Chart.js:f13f99b:chart_js/3rd/Chart.js \
+ FVANCOP:ChartNew.js:77e7f87:chartnew_js/3rd/ChartNew.js
+
+ It also works if not using GH_TUPLE but the regular
+ GH_ACCOUNT/PROJECT/TAGNAME variables:
+
+ GH_SUBDIR= 3rd/Chart.js:chart_js 3rd/ChartNew.js:chartnew_js
+
+20160824:
AUTHOR: kde@FreeBSD.org
+
A new USES file has been introduced: USES=kde:4, which replaces the old
bsd.kde4.mk file in preparation for upcoming KDE Frameworks and Plasma5
ports.
@@ -42,8 +69,8 @@ AUTHOR: mat@FreeBSD.org
From time to time, the values are too generic, and they get in the way of
other stuff.
- This adds the possibility to have a `VAR_regex=regex` that will be used
- instead of the `VAR=string` to search for possible replacements.
+ This adds the possibility to have a VAR_regex=regex that will be used
+ instead of the VAR=string to search for possible replacements.
For example, in lang/perl5*, there is PERL_ARCH=mach, which will get replaced
in paths if a file is called, say "machine", will end up being