aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-07-14 08:18:16 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-07-14 08:18:16 +0000
commit3a7c8c1833c80610310b11754d8c95670604cdc5 (patch)
tree164faae3cef070a9beee3bfc71457c82b042a549 /Makefile
parentf8a38f5ab6823eae28928f268d345fe0f742dc46 (diff)
downloadports-3a7c8c1833c80610310b11754d8c95670604cdc5.tar.gz
ports-3a7c8c1833c80610310b11754d8c95670604cdc5.zip
* Be even more explicit about partial ports trees being unsupported
for INDEX builds [1] * Remove the parallel target from Makefile; this is heavily tied to the package build cluster and can be better done in the makeparallel script (commit to follow) [2] * Extend the format of INDEX to separately list the EXTRACT/PATCH/FETCH_DEPENDS instead of lumping them all in together with BUILD_DEPENDS. The three new fields are appended to the end of the record in that order. [2] * Change BROKEN to IGNORE in BROKEN_WITH_MYSQL failure code [3] * Support non-default PREFIX for perl 5.00503 [5] * Use pkg_info -I instead of ls when searching for conflicts [6] * Allow local customization of the port subdirectories by including ${.CURDIR}/Makefile.local in bsd.subdir.mk if it exists [7] * Fix 'make search' when ${PORTSDIR} is a symlink to a directory name containing extended regexp metacharacters [8] Submitted by: linimon [1] [3], kris [2], lth [4], sem [5], eik [5] [6], Roman Neuhauser <neuhauser@chello.cz> [7] PR: 68299 [1], 67705 [3], 67264 [4], 59696 [5], 66568 [6], 68072 [7]
Notes
Notes: svn path=/head/; revision=113603
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile29
1 files changed, 12 insertions, 17 deletions
diff --git a/Makefile b/Makefile
index bdf840091c87..b9ac02bcc7ea 100644
--- a/Makefile
+++ b/Makefile
@@ -99,11 +99,17 @@ ${.CURDIR}/${INDEXFILE}:
echo "********************************************************************"; \
echo "Before reporting this error, verify that you are running a supported"; \
echo "version of FreeBSD (see http://www.FreeBSD.org/ports/) and that you"; \
- echo "have a complete and up-to-date ports collection (INDEX builds are"; \
- echo "not supported with partial or out-of-date ports collections). If"; \
- echo "so, then report the failure to ports@FreeBSD.org together with"; \
- echo "relevant details of your ports configuration (including FreeBSD"; \
- echo "version, environment and /etc/make.conf settings)."; \
+ echo "have a complete and up-to-date ports collection. (INDEX builds are"; \
+ echo "not supported with partial or out-of-date ports collections -- in"; \
+ echo "particular, if you are using cvsup, you must cvsup the \"ports-all\""; \
+ echo "collection, and have no \"refuse\" files.) If that is the case, then"; \
+ echo "report the failure to ports@FreeBSD.org together with relevant"; \
+ echo "details of your ports configuration (including FreeBSD version,"; \
+ echo "your architecture, your environment, and your /etc/make.conf"; \
+ echo "settings, especially compiler flags and WITH/WITHOUT settings)."; \
+ echo; \
+ echo "Note: the latest pre-generated version of INDEX may be fetched"; \
+ echo "automatically with \"make fetchindex\"."; \
echo "********************************************************************"; \
echo; \
fi; \
@@ -122,18 +128,7 @@ ${.CURDIR}/${INDEXFILE}:
echo " Done."
print-index: ${.CURDIR}/${INDEXFILE}
- @awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9); }' < ${.CURDIR}/${INDEXFILE}
-
-parallel: ${.CURDIR}/${INDEXFILE}
-.if !defined(branch)
- @echo "The parallel target requires a branch parameter,"
- @echo "e.g.: \"make parallel branch=X\""
- @false
-.endif
-.for dir in ${SUBDIR}
- @[ -r ${dir}/Makefile ] && echo "all: ${dir}-all" || true
-.endfor
- @awk -F '|' '{me=$$1; here=$$2; bdep=$$8; rdep=$$9; split(here, tmp, "/"); if (bdep != "") { gsub("$$", ".tgz", bdep); gsub(" ", ".tgz ", bdep); } if (rdep != "") { gsub("$$", ".tgz", rdep); gsub(" ", ".tgz ", rdep); } print tmp[4] "-all: " me ".tgz"; print me ": " me ".tgz"; print me ".tgz: " bdep " " rdep; printf("\t@/var/portbuild/scripts/pdispatch ${branch} /var/portbuild/scripts/portbuild %s.tgz %s", me, here); if (bdep != "") printf(" %s", bdep); if (rdep != "") printf(" %s", rdep); printf("\n")}' < ${.CURDIR}/${INDEXFILE}
+ @awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\nE-deps:\t%s\nP-deps:\t%s\nF-deps:\t%s\nWWW:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9, $$11, $$12, $$13, $$10); }' < ${.CURDIR}/${INDEXFILE}
CVS?= cvs
SUP?= cvsup