aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2009-10-22 13:56:49 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2009-10-22 13:56:49 +0000
commit83490d18ddac692e4d009305b8585b9bb2f3dc0f (patch)
tree33883366f64efcf39893ab36e69a2a7cfcbe8375 /Makefile
parent81bbe6fc439f3618f7ed6e2ac0d1134209b6f3e2 (diff)
downloadports-83490d18ddac692e4d009305b8585b9bb2f3dc0f.tar.gz
ports-83490d18ddac692e4d009305b8585b9bb2f3dc0f.zip
- Allow users to redefine an update target.
Approved by: no objections in ports-developers@
Notes
Notes: svn path=/head/; revision=243216
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index d07f3ca4c561..eb3e6443b95c 100644
--- a/Makefile
+++ b/Makefile
@@ -162,6 +162,7 @@ PORTSNAP_FLAGS?= -p ${.CURDIR}
.if defined(SUPHOST)
SUPFLAGS+= -h ${SUPHOST}
.endif
+.if !target(update)
update:
.if defined(SUP_UPDATE) && defined(PORTSSUPFILE)
@echo "--------------------------------------------------------------"
@@ -188,3 +189,4 @@ update:
@${PORTSNAP} ${PORTSNAP_FLAGS} update
.endif
.endif
+.endif