aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-02 12:05:48 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-02 12:05:48 +0000
commit964883bc4c1face1156f387fb99ababe106470b1 (patch)
treefee472e74fc8814e175cf170dbae641092e55b5f /Makefile
parent9e11d2c6ecb263652cf08c563a43b9507b72307c (diff)
downloadports-964883bc4c1face1156f387fb99ababe106470b1.tar.gz
ports-964883bc4c1face1156f387fb99ababe106470b1.zip
Do not hardcode make for make index
Notes
Notes: svn path=/head/; revision=317095
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 960f67784479..2dc83dbe9264 100644
--- a/Makefile
+++ b/Makefile
@@ -70,7 +70,7 @@ PORTSTOP= yes
index:
@rm -f ${INDEXDIR}/${INDEXFILE}
- @cd ${.CURDIR} && make ${INDEXDIR}/${INDEXFILE}
+ @cd ${.CURDIR} && ${MAKE} ${INDEXDIR}/${INDEXFILE}
fetchindex: ${INDEXDIR}/${INDEXFILE}.bz2
@bunzip2 < ${INDEXDIR}/${INDEXFILE}.bz2 > ${INDEXDIR}/${INDEXFILE} && \
@@ -112,7 +112,7 @@ ${INDEXDIR}/${INDEXFILE}:
fi; \
tmpdir=`/usr/bin/mktemp -d -t index` || exit 1; \
trap "rm -rf $${tmpdir}; exit 1" 1 2 3 5 10 13 15; \
- ( cd ${.CURDIR}; for i in ${INDEX_PORTS}; do (cd $${i} && make -j${INDEX_JOBS} INDEX_TMPDIR=$${tmpdir} BUILDING_INDEX=1 \
+ ( cd ${.CURDIR}; for i in ${INDEX_PORTS}; do (cd $${i} && ${MAKE} -j${INDEX_JOBS} INDEX_TMPDIR=$${tmpdir} BUILDING_INDEX=1 \
__MAKE_SHELL=${INDEX_SHELL} \
ECHO_MSG="${INDEX_ECHO_MSG}" describe); done ) || \
(rm -rf $${tmpdir} ; \