aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2011-05-04 22:33:13 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2011-05-04 22:33:13 +0000
commitc406a95c53be1709ff514cf7bc6de9de5c057057 (patch)
treefaf7a68307086a82d03faf511024bed2ea1b9a79 /Makefile
parentdd741f84d0f826a69db5d81fd036fd2f22a05fb0 (diff)
downloadports-c406a95c53be1709ff514cf7bc6de9de5c057057.tar.gz
ports-c406a95c53be1709ff514cf7bc6de9de5c057057.zip
Latest round of infrastructure changes.
- bsd.port.mk: add INDEX_PORTS, to support INDEX creation for a subset of the ports tree [1] - bsd.port.mk: call target "install-rc-script" before "post-install" [2] - [patch] ports/Mk bsd.port.mk order if groups/users are created by package [3] - [bsd.port.mk] [patch] reaper of the dead: md5 has been in /sbin for a while [4] - [bsd.port.mk] [patch] remove support for pre 7.x systems (b.*.m) [5] - [patch] [bsd.port.mk] reaper of the dead: are three variable defintions needed [6] PR: ports/156575 [1], ports/139116 [2], ports/152498 [3], ports/155983 [4], ports/155510 [5], ports/156340 [6] Submitted by: Florent Thoumie <flz@xbsd.org> [1], Sergey Skvortsov <skv@freebsd.org> [2], Olli Hauer <ohauer@FreeBSD.org> [3], Eitan Adler <lists@eitanadler.com> [4], Eitan Adler <lists@eitanadler.com> [5], Eitan Adler <lists@eitanadler.com> [6]
Notes
Notes: svn path=/head/; revision=273640
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 76061672c406..e6234de75349 100644
--- a/Makefile
+++ b/Makefile
@@ -101,6 +101,10 @@ INDEX_SHELL= /rescue/sh
INDEX_SHELL= /bin/sh
.endif
+.if !defined(INDEX_PORTS)
+INDEX_PORTS=.
+.endif
+
${INDEXDIR}/${INDEXFILE}:
@${INDEX_ECHO_1ST} "Generating ${INDEXFILE} - please wait.."; \
if [ "${INDEX_PRISTINE}" != "" ]; then \
@@ -108,9 +112,9 @@ ${INDEXDIR}/${INDEXFILE}:
fi; \
tmpdir=`/usr/bin/mktemp -d -t index` || exit 1; \
trap "rm -rf $${tmpdir}; exit 1" 1 2 3 5 10 13 15; \
- ( cd ${.CURDIR} && make -j${INDEX_JOBS} INDEX_TMPDIR=$${tmpdir} BUILDING_INDEX=1 \
+ ( cd ${.CURDIR}; for i in ${INDEX_PORTS}; do (cd $${i} && make -j${INDEX_JOBS} INDEX_TMPDIR=$${tmpdir} BUILDING_INDEX=1 \
__MAKE_SHELL=${INDEX_SHELL} \
- ECHO_MSG="${INDEX_ECHO_MSG}" describe ) || \
+ ECHO_MSG="${INDEX_ECHO_MSG}" describe); done ) || \
(rm -rf $${tmpdir} ; \
if [ "${INDEX_QUIET}" = "" ]; then \
echo; \