aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2019-09-04 14:07:48 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2019-09-04 14:07:48 +0000
commitf9d8d0eb8b943e13ae6190ba4dff0a542126c194 (patch)
treede07ee69915495f0d8b9c9a7bbc2788f31118786 /Makefile
parent9efc370e8f27b9ce67ded1eb7b13122061c5688f (diff)
downloadports-f9d8d0eb8b943e13ae6190ba4dff0a542126c194.tar.gz
ports-f9d8d0eb8b943e13ae6190ba4dff0a542126c194.zip
Use sort with "modern" option
When building index we were using obsolete (but still supported options) let use the non obsolete one. PR: 166188 Submitted by: lgfbsd@be-well.ilk.org
Notes
Notes: svn path=/head/; revision=511095
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 1d7cda47390e..2c2b50258f70 100644
--- a/Makefile
+++ b/Makefile
@@ -77,7 +77,7 @@ fetchindex: ${INDEXDIR}/${INDEXFILE}.bz2
chmod a+r ${INDEXDIR}/${INDEXFILE} && ${RM} ${INDEXDIR}/${INDEXFILE}.bz2
${INDEXDIR}/${INDEXFILE}.bz2: .PHONY
- @${FETCHINDEX} ${INDEXDIR}/${INDEXFILE}.bz2 ${MASTER_SITE_INDEX}${INDEXFILE}.bz2
+ ${FETCHINDEX} ${INDEXDIR}/${INDEXFILE}.bz2 ${MASTER_SITE_INDEX}${INDEXFILE}.bz2
MASTER_SITE_INDEX?= https://www.FreeBSD.org/ports/
SETENV?= /usr/bin/env
@@ -148,7 +148,7 @@ ${INDEXDIR}/${INDEXFILE}:
sed -e 's|${.CURDIR}|${PORTSDIR}|g' | \
(cd ${.CURDIR} ; ${MAKE_INDEX}) | \
sed -e 's/ */ /g' -e 's/| */|/g' -e 's/ *|/|/g' -e 's./..g' | \
- sort -t '|' +1 -2 | \
+ sort -t '|' -k 2,3 | \
sed -Ee 's../.g' -e ':a' -e 's|/[^/]+/\.\.||; ta' \
-e 's|${PORTSDIR}|/usr/ports|g' \
-e 's|${.CURDIR}|/usr/ports|g' > ${INDEXDIR}/${INDEXFILE}.tmp; \