aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1998-12-28 12:35:10 +0000
committerSatoshi Asami <asami@FreeBSD.org>1998-12-28 12:35:10 +0000
commitfd7d6a00cdb25b0a91c2cfa1bb5644815d3b5486 (patch)
tree715c58b49e9f57b6e9c9750de1e066b790d2ed36 /Makefile
parentb73500f17e0a4b67e102be710134fa6aca4dd023 (diff)
downloadports-fd7d6a00cdb25b0a91c2cfa1bb5644815d3b5486.tar.gz
ports-fd7d6a00cdb25b0a91c2cfa1bb5644815d3b5486.zip
Add new target "parallel" which creates a parallelizable Makefile for
building all packages. This is to be used in conjunction with the scripts under the "Tools" directory. Note this version has hardcoded paths and other general badness -- those will be fixed later.
Notes
Notes: svn path=/head/; revision=15678
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 2c375239252d..ff55921cc6f4 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-# $Id: Makefile,v 1.39 1998/10/30 23:38:26 jkh Exp $
+# $Id: Makefile,v 1.40 1998/12/12 07:41:46 asami Exp $
#
SUBDIR += archivers
@@ -67,3 +67,6 @@ search: ${.CURDIR}/INDEX
.else
@grep -i "${key}|" ${.CURDIR}/INDEX | awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9); }'
.endif
+
+parallel: ${.CURDIR}/INDEX
+ @sed -e 's/|/.tgz|/' ${.CURDIR}/INDEX | awk -F '|' '{me=$$1; here=$$2; bdep=$$8; rdep=$$9; if (bdep != "") { gsub("$$", ".tgz", bdep); gsub(" ", ".tgz ", bdep); } if (rdep != "") { gsub("$$", ".tgz", rdep); gsub(" ", ".tgz ", rdep); } print "all:: " me; print me ": " bdep " " rdep; printf("\t@/a/asami/portbuild/pdispatch /a/asami/portbuild/portbuild %s %s", me, here); if (bdep != "") printf(" %s", bdep); if (rdep != "") printf(" %s", rdep); printf("\n")}'