aboutsummaryrefslogtreecommitdiff
path: root/Mk/Uses
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2021-01-15 14:38:44 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2021-01-15 14:38:44 +0000
commit290134abb30e7c261a661c1bdc719ae8e99c7001 (patch)
tree5f0aabce23a1fb09c6f3b7a4a71dbf4ea4891143 /Mk/Uses
parentec14be9090fe4a413f8585296f8433d06b0e684a (diff)
downloadports-290134abb30e7c261a661c1bdc719ae8e99c7001.tar.gz
ports-290134abb30e7c261a661c1bdc719ae8e99c7001.zip
Mk/Uses/python.mk: Remove PY_SPHINX shared macro
This shared macro was necessary to use with flavors and not break ports with USES=python (all versions). All ports that depends on Sphinx are using the latest version on tree. Approved by: python (with hat)
Notes
Notes: svn path=/head/; revision=561645
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/python.mk2
1 files changed, 0 insertions, 2 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index 354f05b4ee38..4dbee4f6dbc7 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -645,11 +645,9 @@ PYNUMPY= ${PYTHON_PKGNAMEPREFIX}numpy>=1.16,1<1.20,1:math/py-numpy@${PY_FLAVOR}
# Common Python modules that can be needed but only for some versions of Python.
.if ${PYTHON_REL} < 3500
PY_PYGMENTS= ${PYTHON_PKGNAMEPREFIX}pygments-25>=2.5.1<3:textproc/py-pygments-25@${PY_FLAVOR}
-PY_SPHINX= ${PYTHON_PKGNAMEPREFIX}sphinx18>=0,1:textproc/py-sphinx18@${PY_FLAVOR}
.else
PY_PILLOW= ${PYTHON_PKGNAMEPREFIX}pillow>=7.0.0:graphics/py-pillow@${PY_FLAVOR}
PY_PYGMENTS= ${PYTHON_PKGNAMEPREFIX}pygments>=2.5.1<3:textproc/py-pygments@${PY_FLAVOR}
-PY_SPHINX= ${PYTHON_PKGNAMEPREFIX}sphinx>=3.0,1:textproc/py-sphinx@${PY_FLAVOR}
.endif
.if ${PYTHON_REL} < 3400