aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.commands.mk
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-04-14 16:46:41 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-04-14 16:46:41 +0000
commita616189c8c0b779f7e18ae1aadd41ed5f145177a (patch)
treead67cbb81194feade046ef9d06697801fbdce527 /Mk/bsd.commands.mk
parent4c68fbe1bef2d9a6d3e5a0e16141c24579ab5c45 (diff)
downloadports-a616189c8c0b779f7e18ae1aadd41ed5f145177a.tar.gz
ports-a616189c8c0b779f7e18ae1aadd41ed5f145177a.zip
Support @rmtry in pkg-plist, analogous to @dirrmtry but for single file rm.
PR: ports/116219 Submitted by: edwin Make USE_DISPLAY more general: set up virtual X server when USE_DISPLAY is defined and no DISPLAY variable is in environment; pass DISPLAY value in CONFIGURE_ENV and MAKE_ENV. PR: ports/116244 Submitted by: edwin Define ${PW}. PR: ports/119821 Submitted by: Matthew Seaman <m.seaman@infracaninophile.co.uk> Move SHA256, MD5, GMAKE and XMKMF to bsd.commands.mk. PR: ports/119879 Submitted by: edwin Fix a build failure for ports that define their own MTREE File. PR: ports/120200 Submitted by: dinoex Don't recreate mtree symlinks if they are already present. PR: ports/121681 Submitted by: sobomax Fix LIB_DEPENDS for libraries whose name contains plus sign. Both intuitive and old escaped syntax works. PR: ports/121741 (based on) Submitted by: fjoe Disable post-install security checks if DISABLE_SECURITY_CHECK variable is defined. PR: ports/122224 Submitted by: Bjoern Koenig <bkoenig@alpha-tierchen.de> Remove versioned Tcl/Tk categories. PR: ports/122622 Submitted by: pav
Notes
Notes: svn path=/head/; revision=211254
Diffstat (limited to 'Mk/bsd.commands.mk')
-rw-r--r--Mk/bsd.commands.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/Mk/bsd.commands.mk b/Mk/bsd.commands.mk
index a994b8119617..2114f0b769d0 100644
--- a/Mk/bsd.commands.mk
+++ b/Mk/bsd.commands.mk
@@ -42,6 +42,7 @@ FALSE?= false # Shell builtin
FILE?= /usr/bin/file
FIND?= /usr/bin/find
FMT?= /usr/bin/fmt
+GMAKE?= gmake
GREP?= /usr/bin/grep
GUNZIP_CMD?= /usr/bin/gunzip -f
GZCAT?= /usr/bin/gzcat
@@ -67,6 +68,7 @@ OBJDUMP?= /usr/bin/objdump
PASTE?= /usr/bin/paste
PAX?= /bin/pax
PRINTF?= /usr/bin/printf
+PW?= /usr/sbin/pw
REALPATH?= /bin/realpath
RM?= /bin/rm
RMDIR?= /bin/rmdir
@@ -87,8 +89,22 @@ UNMAKESELF_CMD?= ${LOCALBASE}/bin/unmakeself
UNZIP_CMD?= ${LOCALBASE}/bin/unzip
WHICH?= /usr/bin/which
XARGS?= /usr/bin/xargs
+XMKMF?= ${LOCALBASE}/bin/xmkmf -a
YACC?= /usr/bin/yacc
+.if exists(/sbin/md5)
+MD5?= /sbin/md5
+.else
+MD5?= md5
+.endif
+.if exists(/sbin/sha256)
+SHA256?= /sbin/sha256
+.elif exists(${LOCALBASE}/sbin/sha256)
+SHA256?= ${LOCALBASE}/sbin/sha256
+.else
+SHA256?= NO
+.endif
+
# ECHO is defined in /usr/share/mk/sys.mk, which can either be "echo",
# or "true" if the make flag -s is given. Use ECHO_CMD where you mean
# the echo command.