aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.commands.mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-04-20 11:13:32 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-04-20 11:13:32 +0000
commitc1a60b6300cccc5a63300c822a8a9dd96b14eeab (patch)
treeadfb001b4dfb6c8507dceaa358006a97025f76ec /Mk/bsd.commands.mk
parent1e86ec689a3908aa74ffcdbb0a39d90c355807ed (diff)
downloadports-c1a60b6300cccc5a63300c822a8a9dd96b14eeab.tar.gz
ports-c1a60b6300cccc5a63300c822a8a9dd96b14eeab.zip
Add a RLN command (relative ln), it can be used to create relative
symlinks using install's relative symlinks feature. If you were going through hoops doing things like this to get relative symlinks: ${LN} -sf ../lib/some/thing ${STAGEDIR}${PREFIX}/bin You can now use full paths for both the source and destination: ${RLN} ${STAGEDIR}${PREFIX}/libexec/some/thing ${STAGEDIR}${PREFIX}/bin One caveat is that the source must exist when this is run, because install needs to run realpath(1) on it. Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=438938
Diffstat (limited to 'Mk/bsd.commands.mk')
-rw-r--r--Mk/bsd.commands.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Mk/bsd.commands.mk b/Mk/bsd.commands.mk
index c68f8c96cf9c..959ee6f53cbf 100644
--- a/Mk/bsd.commands.mk
+++ b/Mk/bsd.commands.mk
@@ -75,6 +75,7 @@ PS_CMD?= /bin/ps
PW?= /usr/sbin/pw
READELF?= /usr/bin/readelf
REALPATH?= /bin/realpath
+RLN?= ${INSTALL} -l rs
RM?= /bin/rm -f
RMDIR?= /bin/rmdir
SED?= /usr/bin/sed