aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.default-versions.mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-14 13:34:25 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-14 13:34:25 +0000
commit9097255acf7543c263b071072648645652b2917a (patch)
tree44b3cc0fe5188a890d14702e5f0834aa43a27a4a /Mk/bsd.default-versions.mk
parent2f8784c834d92e53b058b5b3aca11921ef49b1fb (diff)
downloadports-9097255acf7543c263b071072648645652b2917a.tar.gz
ports-9097255acf7543c263b071072648645652b2917a.zip
Try to be more helpful to our users, and keep all the possible versions
close to their default value in Mk/bsd.default-versions.mk. Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=413261
Diffstat (limited to 'Mk/bsd.default-versions.mk')
-rw-r--r--Mk/bsd.default-versions.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index 1a8e7e2d69cc..d187feb5ca62 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -18,13 +18,21 @@ _l= ${lang:C/=.*//g}
${_l:tu}_DEFAULT= ${lang:C/.*=//g}
.endfor
+# Possible values: 2.2, 2.4
APACHE_DEFAULT?= 2.4
+# Possible values: 2.5
FIREBIRD_DEFAULT?= 2.5
+# Possible values: 3.0.0
FPC_DEFAULT?= 3.0.0
+# Possible values: 4.6, 4.7, 4.8, 4.9, 5
GCC_DEFAULT?= 4.8
+# Possible values: 7, 8, 9, agpl
GHOSTSCRIPT_DEFAULT?= agpl
+# Possible values: 5.1, 5.2, 5.3
LUA_DEFAULT?= 5.2
+# Possible values: 5.1, 5.5, 5.6, 5.7, 5.5m, 10.0m, 10.1m, 5.5p, 5.6p
MYSQL_DEFAULT?= 5.6
+# Possible values: 5.18, 5.20, 5.22, devel
.if !exists(${LOCALBASE}/bin/perl) || (!defined(_PORTS_ENV_CHECK) && \
defined(PACKAGE_BUILDING))
PERL5_DEFAULT?= 5.20
@@ -39,12 +47,19 @@ _PERL5_FROM_BIN!= perl -e 'printf "%vd\n", $$^V;'
_EXPORTED_VARS+= _PERL5_FROM_BIN
PERL5_DEFAULT:= ${_PERL5_FROM_BIN:R}
.endif
+# Possible values: 9.0, 9.1, 9.2, 9.3, 9.4, 9.5
PGSQL_DEFAULT?= 9.3
+# Possible values: 5.5, 5.6, 7.0
PHP_DEFAULT?= 5.6
+# Possible values: 2.7, 3.3, 3.4, 3.5
PYTHON_DEFAULT?= 2.7
+# Possible values: 2.7
PYTHON2_DEFAULT?= 2.7
+# Possible values: 3.3, 3.4, 3.5
PYTHON3_DEFAULT?= 3.4
+# Possible values: 2.0, 2.1, 2.2, 2.3
RUBY_DEFAULT?= 2.2
+# Possible values: 8.4, 8.5, 8.6
TCLTK_DEFAULT?= 8.6
# Version of lang/gcc. Do not override!