aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gcc.mk
diff options
context:
space:
mode:
authorAndreas Tobler <andreast@FreeBSD.org>2018-12-29 15:38:30 +0000
committerAndreas Tobler <andreast@FreeBSD.org>2018-12-29 15:38:30 +0000
commit118dee2cf737dbd68ac1f61f86f6ab419a0ca6d1 (patch)
tree8593e298528c1e86017e6f216aee1358b2804f7d /Mk/bsd.gcc.mk
parent02a89eab1a2ac143d396eccc650e2a81147b3915 (diff)
downloadports-118dee2cf737dbd68ac1f61f86f6ab419a0ca6d1.tar.gz
ports-118dee2cf737dbd68ac1f61f86f6ab419a0ca6d1.zip
Fix build of GCC on powerpc64.
While building GCC itself we have to use the built GCC libraries to configure additional parts of GCC and not the libraires from the host. Install the built 32-bit libraries. This was not done up to now. PR: 231804 Approved by: gerald@
Notes
Notes: svn path=/head/; revision=488673
Diffstat (limited to 'Mk/bsd.gcc.mk')
-rw-r--r--Mk/bsd.gcc.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 52361fdc82ca..37e7a109c0dc 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -150,9 +150,16 @@ CC:= gcc${V}
CXX:= g++${V}
CPP:= cpp${V}
_GCC_RUNTIME:= ${LOCALBASE}/lib/gcc${V}
+. if ${PORTNAME} == gcc
+# We don't want the rpath stuff while building GCC itself
+# so we do not set the FLAGS as done in the else part.
+# When building a GCC, we want the target libraries to be used and not the
+# host GCC libraries.
+. else
CFLAGS+= -Wl,-rpath=${_GCC_RUNTIME}
CXXFLAGS+= -Wl,-rpath=${_GCC_RUNTIME}
LDFLAGS+= -Wl,-rpath=${_GCC_RUNTIME} -L${_GCC_RUNTIME}
+. endif
. else # Use GCC in base.
CC:= gcc
CXX:= g++