aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gcc.mk
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2013-03-29 11:26:14 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2013-03-29 11:26:14 +0000
commit6898d925064fc2ee9868daa25b5c7ff9409bce03 (patch)
tree248e50757cea58a7c6b169cc9ddcc77ddb74c0c4 /Mk/bsd.gcc.mk
parent66e4b6bc2b0a58ae8860b6217e7edf9d6c53a533 (diff)
downloadports-6898d925064fc2ee9868daa25b5c7ff9409bce03.tar.gz
ports-6898d925064fc2ee9868daa25b5c7ff9409bce03.zip
Merge two loops and initialize _GCC_FOUND${v} and check whether USE_GCC
points to a valid version in parallel.
Notes
Notes: svn path=/head/; revision=315538
Diffstat (limited to 'Mk/bsd.gcc.mk')
-rw-r--r--Mk/bsd.gcc.mk23
1 files changed, 9 insertions, 14 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 09476fbf5c3a..5ef0197089a4 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -129,20 +129,8 @@ _GCC_ORLATER:= true
. endif # ${USE_GCC} == any
-# Check if USE_GCC points to a valid version.
-.for v in ${GCCVERSIONS}
-. if ${_USE_GCC}==${_GCCVERSION_${v}_V}
-_GCCVERSION_OKAY= true;
-. endif
-.endfor
-
-.if !defined(_GCCVERSION_OKAY)
-IGNORE= Unknown version of GCC specified (USE_GCC=${USE_GCC})
-.endif
-
-#
-# Initialize _GCC_FOUND${v}.
-#
+# Initialize _GCC_FOUND${v}. In parallel, check if USE_GCC points to a
+# valid version to begin with.
.for v in ${GCCVERSIONS}
. if exists(${LOCALBASE}/bin/gcc${_GCCVERSION_${v}_V:S/.//})
_GCC_FOUND${v}= port
@@ -151,8 +139,15 @@ _GCC_FOUND${v}= port
_GCC_FOUND${v}= base
. endif
. endif
+. if ${_USE_GCC}==${_GCCVERSION_${v}_V}
+_GCCVERSION_OKAY= true
+. endif
.endfor
+.if !defined(_GCCVERSION_OKAY)
+IGNORE= Unknown version of GCC specified (USE_GCC=${USE_GCC})
+.endif
+
# If the GCC package defined in USE_GCC does not exist, but a later
# version is allowed (for example 4.2+), see if there is a later.
# First check if the base installed version is good enough, otherwise