aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gcc.mk
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2010-06-06 17:17:04 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2010-06-06 17:17:04 +0000
commit6c6e96d7367bd8da3be5d94e139048a52e1b8d93 (patch)
tree8cf0987e45f915d1d9871d5e5059b019085801eb /Mk/bsd.gcc.mk
parent023b8d63a7232782cadd83f3b31b91938a7b3f56 (diff)
downloadports-6c6e96d7367bd8da3be5d94e139048a52e1b8d93.tar.gz
ports-6c6e96d7367bd8da3be5d94e139048a52e1b8d93.zip
USE_GCC=4.3 is deprecated (and no port uses it anymore). USE_GCC=4.3+
is transparently rewritten to USE_GCC=4.4+ and lang/gcc43 will be disconnected from the USE_GCC infrastructure soon.
Notes
Notes: svn path=/head/; revision=255910
Diffstat (limited to 'Mk/bsd.gcc.mk')
-rw-r--r--Mk/bsd.gcc.mk10
1 files changed, 9 insertions, 1 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index f5e46bafdb06..f3e94290d6a1 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -12,7 +12,10 @@
# the version. Note that the Fortran compiler is specified with the
# USE_FORTRAN knob.
#
-# For example:
+# As of 2010-06-06, USE_GCC=4.3 is deprecated and USE_GCC=4.3+ is
+# transparently rewritten to USE_GCC=4.4+.
+#
+# Examples:
# USE_GCC= 4.2+ # port requires GCC 4.2 or later.
# USE_GCC= 4.5 # port requires GCC 4.5.
#
@@ -114,6 +117,11 @@ MAKE_ENV+= F77="${F77}" FC="${FC}" FFLAGS="${FFLAGS}"
.if defined(USE_GCC)
+# USE_GCC=4.3 is deprecated...
+.if ${USE_GCC} == 4.3+
+USE_GCC:=4.4+
+.endif
+
# See if we can use a later version
_USE_GCC:= ${USE_GCC:S/+//}
.if ${USE_GCC} != ${_USE_GCC}