aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gcc.mk
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2018-06-02 08:03:59 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2018-06-02 08:03:59 +0000
commit6d96e19baf3ee9cadbd96d108136a6f4c824af1c (patch)
treedb088fecb294c0439e3429c8bef9933ad2cb93e8 /Mk/bsd.gcc.mk
parent369780cba6603dd0c8a71426ad7668e81a226ccd (diff)
downloadports-6d96e19baf3ee9cadbd96d108136a6f4c824af1c.tar.gz
ports-6d96e19baf3ee9cadbd96d108136a6f4c824af1c.zip
Document the form USE_GCC=X+ instead of the older form USE_GCC=X.Y+
that has been necessary for the GCC 4.x series and should not see any new usage anways. Use more current versions of GCC in examples, choosing the two most realistic options.
Notes
Notes: svn path=/head/; revision=471347
Diffstat (limited to 'Mk/bsd.gcc.mk')
-rw-r--r--Mk/bsd.gcc.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 720b62e50910..d3fde25e7899 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -14,15 +14,15 @@
#
# If your port needs a specific (minimum) version of GCC, you can easily
# specify that with a USE_GCC= statement. Unless absolutely necessary
-# do so by specifying USE_GCC=X.Y+ which requests at least GCC version
-# X.Y. To request a specific version omit the trailing + sign.
+# do so by specifying USE_GCC=X+ which requests at least GCC version X.
+# To request a specific version omit the trailing + sign.
#
# Examples:
# USE_GCC= yes # port requires a current version of GCC
# # as defined in bsd.default-versions.mk.
# USE_GCC= any # port requires GCC 4.2 or later.
-# USE_GCC= 6+ # port requires GCC 6 or later.
-# USE_GCC= 4.9 # port requires GCC 4.9.
+# USE_GCC= 7+ # port requires GCC 7 or later.
+# USE_GCC= 5 # port requires GCC 5.
#
# If you are wondering what your port exactly does, use "make test-gcc"
# to see some debugging.