aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gcc.mk
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2011-11-12 22:03:55 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2011-11-12 22:03:55 +0000
commit9ce9cd09616485ea0dbee77030eac9d720cf7354 (patch)
treea2bd6b42077bf9bb32034ddd9c2c4278d5ebb9f5 /Mk/bsd.gcc.mk
parentb197d467d41311b41de3f63b1a4094768daa33ed (diff)
downloadports-9ce9cd09616485ea0dbee77030eac9d720cf7354.tar.gz
ports-9ce9cd09616485ea0dbee77030eac9d720cf7354.zip
Disconnect GCC 4.5 alias lang/gcc45.
No ports uses this directly any more via USE_GCC=4.5 and for the sake of those nine that have USE_GCC=4.5+ we transparently rewrite this to USE_GCC=4.6+ which has already happened for weeks for tinderbox builds. Feature safe: yes
Notes
Notes: svn path=/head/; revision=285671
Diffstat (limited to 'Mk/bsd.gcc.mk')
-rw-r--r--Mk/bsd.gcc.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 58900f124e82..39ae0e7449ff 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -36,7 +36,7 @@ GCC_Include_MAINTAINER= gerald@FreeBSD.org
# All GCC versions supported by the ports framework. Keep them in
# ascending order and in sync with the table below.
-GCCVERSIONS= 030402 040200 040400 040500 040600 040700
+GCCVERSIONS= 030402 040200 040400 040600 040700
# The first field if the OSVERSION in which it appeared in the base.
# The second field is the OSVERSION in which it disappeared from the base.
@@ -44,7 +44,6 @@ GCCVERSIONS= 030402 040200 040400 040500 040600 040700
GCCVERSION_030402= 502126 700042 3.4
GCCVERSION_040200= 700042 9999999 4.2
GCCVERSION_040400= 0 0 4.4
-GCCVERSION_040500= 0 0 4.5
GCCVERSION_040600= 0 0 4.6
GCCVERSION_040700= 0 0 4.7
@@ -102,7 +101,12 @@ MAKE_ENV+= F77="${F77}" FC="${FC}" FFLAGS="${FFLAGS}"
.if defined(USE_GCC)
-# See if we can use a later version
+# GCC 4.5 got disconnected 2011-11-12, take care of any uses.
+.if ${USE_GCC} == "4.5+"
+USE_GCC= 4.6+
+.endif
+
+# See if we can use a later version or exclusively the one specified.
_USE_GCC:= ${USE_GCC:S/+//}
.if ${USE_GCC} != ${_USE_GCC}
_GCC_ORLATER:= true