aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gcc.mk
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2014-02-23 02:20:02 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2014-02-23 02:20:02 +0000
commita4c007fb2837085d8046decb40859a84025b3758 (patch)
tree1f686a1d205ef49a353db824694c2c0a353951cc /Mk/bsd.gcc.mk
parent276a405ee5bff6aaf66b54a9c0c9fb1f7eddb2b6 (diff)
downloadports-a4c007fb2837085d8046decb40859a84025b3758.tar.gz
ports-a4c007fb2837085d8046decb40859a84025b3758.zip
Remove the _GCC_BUILD_DEPENDS variable which we had kept for the sake
of some ports using this unexpectedly. There are no further instances in the tree any more. If there is an absolute need to refer to the GCC runtime directory that cannot be covered by CFLAGS, LDFLAGS or the like, use _GCC_RUNTIME. This hardly ever should be necessary, though. Avoid whenever possible!
Notes
Notes: svn path=/head/; revision=345690
Diffstat (limited to 'Mk/bsd.gcc.mk')
-rw-r--r--Mk/bsd.gcc.mk3
1 files changed, 0 insertions, 3 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index b9a43e4df3d9..4de0de1fc32a 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -160,9 +160,6 @@ _GCC_RUNTIME:= ${LOCALBASE}/lib/gcc${V}
CFLAGS+= -Wl,-rpath=${_GCC_RUNTIME}
CXXFLAGS+= -Wl,-rpath=${_GCC_RUNTIME}
LDFLAGS+= -Wl,-rpath=${_GCC_RUNTIME} -L${_GCC_RUNTIME}
-# The following is for the sakes of some ports which use this without
-# ever telling us; to be fixed.
-_GCC_BUILD_DEPENDS:= ${_GCC_PORT_DEPENDS}
. else # Use GCC in base.
CC:= gcc
CXX:= g++