aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gcc.mk
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2020-04-16 22:25:20 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2020-04-16 22:25:20 +0000
commitc03743e5b7b270d2ac749f0a22907583ffd38006 (patch)
tree44101e5020e5dfdbb322d946cdba0c440b58d597 /Mk/bsd.gcc.mk
parent4739b55c9a9322fd2ea3a4f9b33672a4b8e8f529 (diff)
downloadports-c03743e5b7b270d2ac749f0a22907583ffd38006.tar.gz
ports-c03743e5b7b270d2ac749f0a22907583ffd38006.zip
Finalize the streamlining of data structures holding version-specific
information in the light of us only encountering at most one version (GCC 4.2) in the base system these days.
Notes
Notes: svn path=/head/; revision=531883
Diffstat (limited to 'Mk/bsd.gcc.mk')
-rw-r--r--Mk/bsd.gcc.mk12
1 files changed, 3 insertions, 9 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 24164668a190..276aa744e961 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -34,13 +34,7 @@ GCC_Include_MAINTAINER= gerald@FreeBSD.org
# All GCC versions supported by the ports framework. Keep them in
# ascending order and in sync with the table below.
# When updating this, keep Mk/bsd.default-versions.mk in sync.
-GCCVERSIONS= 040800 070000 080000 090000
-
-# The right side is the version as USE_GCC uses it.
-_GCCVERSION_040800_V= 4.8
-_GCCVERSION_070000_V= 7
-_GCCVERSION_080000_V= 8
-_GCCVERSION_090000_V= 9
+GCCVERSIONS= 4.8 7 8 9
# No configurable parts below this. ####################################
#
@@ -72,9 +66,9 @@ _GCC_ORLATER:= true
# and save that into _GCC_FOUND. In parallel, check if USE_GCC refers
# to a valid version to begin with.
.for v in ${GCCVERSIONS}
-. if ${_USE_GCC}==${_GCCVERSION_${v}_V}
+. if ${_USE_GCC} == ${v}
_GCCVERSION_OKAY= true
-. if exists(${LOCALBASE}/bin/gcc${_GCCVERSION_${v}_V:S/.//})
+. if exists(${LOCALBASE}/bin/gcc${v:S/.//})
_GCC_FOUND:= ${_USE_GCC}
. endif
. endif