aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gcc.mk
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2012-11-06 00:23:43 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2012-11-06 00:23:43 +0000
commitc3b86ec30823a3722173dbc8e7dd70283f1b892e (patch)
tree1b5643995c7d76a3cec1d7e63952841d6b97e8a2 /Mk/bsd.gcc.mk
parent81d9fe7c505ed2091b45e3c4be8e873d7010a73f (diff)
downloadports-c3b86ec30823a3722173dbc8e7dd70283f1b892e.tar.gz
ports-c3b86ec30823a3722173dbc8e7dd70283f1b892e.zip
In addition to CFLAGS and LDFLAGS now also CXXFLAGS set an rpath to
the GCC run-time. This extends revision r246991 (2010-01-02) and should not be necessary in most cases since LDFLAGS already covers linking, but one can always compile and link in one swoop, and this makes things consistent between C and C++. Feature safe: yes
Notes
Notes: svn path=/head/; revision=307045
Diffstat (limited to 'Mk/bsd.gcc.mk')
-rw-r--r--Mk/bsd.gcc.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 25883ae3aa5e..b22074e9ea09 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -202,6 +202,7 @@ CPP:= cpp${V}
. if ${_USE_GCC} != 3.4
_GCC_RUNTIME:= ${LOCALBASE}/lib/gcc${V}
CFLAGS+= -Wl,-rpath=${_GCC_RUNTIME}
+CXXFLAGS+= -Wl,-rpath=${_GCC_RUNTIME}
LDFLAGS+= -Wl,-rpath=${_GCC_RUNTIME}
. if defined (USE_FORTRAN)
. if ${USE_FORTRAN} == yes