aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gcc.mk
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2013-11-10 20:29:52 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2013-11-10 20:29:52 +0000
commitcee7e50a714b6b269ba28c7e67f2f4403e95c8ef (patch)
tree59e678b3efc2af651d075bac02593fd3267b8cb7 /Mk/bsd.gcc.mk
parent728b5c34898c65a2e98ccf91526e92c3ed38df3d (diff)
downloadports-cee7e50a714b6b269ba28c7e67f2f4403e95c8ef.tar.gz
ports-cee7e50a714b6b269ba28c7e67f2f4403e95c8ef.zip
Document USE_GCC=any. Reformat the description a bit and use newer
versions of GCC for reference.
Notes
Notes: svn path=/head/; revision=333442
Diffstat (limited to 'Mk/bsd.gcc.mk')
-rw-r--r--Mk/bsd.gcc.mk16
1 files changed, 11 insertions, 5 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index c40ec93e953d..50ea0ff8a48d 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -7,20 +7,26 @@
#
# To request the use of a current version of GCC, specify USE_GCC=yes in
# your port/system configuration. This is the preferred use of USE_GCC.
-# It defines a canonical, default version of GCC; the same version of
+# It defines a canonical, default version of GCC. The same version of
# GCC is also implied by USE_FORTRAN=yes.
+#
+# USE_GCC=any is similar, except that it also accepts the old GCC 4.2-
+# based system compiler in older versions of FreeBSD.
#
# If your port needs a specific (minimum) version of GCC, you can easily
# specify that with a USE_GCC= statement. Unless absolutely necessary
# do so by specifying USE_GCC=X.Y+ which requests at least GCC version
-# X.Y. To request a specific version omit the trailing + sign. Use of
-# a Fortran compiler is declared by the USE_FORTRAN knob, not USE_GCC.
+# X.Y. To request a specific version omit the trailing + sign.
+#
+# Use of a Fortran compiler is declared by the USE_FORTRAN knob, not
+# USE_GCC.
#
# Examples:
# USE_GCC= yes # port requires a current version of GCC
# # (4.6 as of today, subject to change).
-# USE_GCC= 4.2+ # port requires GCC 4.2 or later.
-# USE_GCC= 4.7 # port requires GCC 4.7.
+# USE_GCC= any # port requires GCC 4.2 or later.
+# USE_GCC= 4.8+ # port requires GCC 4.8 or later.
+# USE_GCC= 4.8 # port requires GCC 4.8.
#
# If your port needs a Fortran compiler, please specify that with the
# USE_FORTRAN= knob. Here is the list of options for that knob: