aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gcc.mk
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2018-08-05 13:30:30 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2018-08-05 13:30:30 +0000
commitf3ce3b9d7b07410324d3d10a7b0df61bcf77108c (patch)
tree77195721835319f88871ee9650e1541951627ef5 /Mk/bsd.gcc.mk
parent05f32954249779b0896df2b9e18297cfa8deb0f7 (diff)
downloadports-f3ce3b9d7b07410324d3d10a7b0df61bcf77108c.tar.gz
ports-f3ce3b9d7b07410324d3d10a7b0df61bcf77108c.zip
Filter -mretpoline, which is specific to clang and not supported by
GCC, from CFLAGS and CXXFLAGS. This also establishes a good place where to add any additional such cases in the future. PR: 230200 Submitted by: rozhuk.im@gmail.com
Notes
Notes: svn path=/head/; revision=476413
Diffstat (limited to 'Mk/bsd.gcc.mk')
-rw-r--r--Mk/bsd.gcc.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 92c9655d9e8f..52361fdc82ca 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -166,6 +166,10 @@ CPP:= cpp
.endfor
.undef V
+# Now filter unsupported flags for CC and CXX.
+CFLAGS:= ${CFLAGS:N-mretpoline}
+CXXFLAGS:= ${CXXFLAGS:N-mretpoline}
+
.if defined(_GCC_PORT_DEPENDS)
BUILD_DEPENDS+= ${_GCC_PORT_DEPENDS}:lang/${_GCC_PORT}
RUN_DEPENDS+= ${_GCC_PORT_DEPENDS}:lang/${_GCC_PORT}