aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gecko.mk
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-10-29 09:56:42 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-10-29 09:56:42 +0000
commitb4e94c32aad9c661027303f5dc082dcdcd3e1ad7 (patch)
treecae78bb6e250ee298b7dd13b9e20feab779b6a44 /Mk/bsd.gecko.mk
parent9557620e1696e31e70298edf8b535b9920daca91 (diff)
downloadports-b4e94c32aad9c661027303f5dc082dcdcd3e1ad7.tar.gz
ports-b4e94c32aad9c661027303f5dc082dcdcd3e1ad7.zip
gecko: unbreak with non-default CC/CXX
checking for clang for bindgen... not found checking for libclang for bindgen... not found ERROR: Could not find clang to generate run bindings for C/C++. Please install the necessary packages, run `mach bootstrap`, or use --with-clang-path to give the location of clang. checking for llvm-objdump... not found DEBUG: llvm_objdump: Trying llvm-objdump ERROR: Cannot find llvm-objdump Reported by: pkg-fallout (powerpc64)
Notes
Notes: svn path=/head/; revision=553595
Diffstat (limited to 'Mk/bsd.gecko.mk')
-rw-r--r--Mk/bsd.gecko.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 47e37dcfe0cd..32f56038342a 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -82,13 +82,16 @@ BUILD_DEPENDS+= llvm${LLVM_DEFAULT}>0:devel/llvm${LLVM_DEFAULT} \
node:www/node
LIB_DEPENDS+= libdrm.so:graphics/libdrm
MOZ_EXPORT+= ${CONFIGURE_ENV} \
- LLVM_CONFIG=llvm-config${LLVM_DEFAULT} \
PERL="${PERL}" \
PYTHON3="${PYTHON_CMD}" \
RUSTFLAGS="${RUSTFLAGS}"
MOZ_OPTIONS+= --prefix="${PREFIX}"
MOZ_MK_OPTIONS+=MOZ_OBJDIR="${BUILD_WRKSRC}"
+MOZ_OPTIONS+= --with-libclang-path="${LOCALBASE}/llvm${LLVM_DEFAULT}/lib"
+.if !exists(/usr/bin/llvm-objdump) # WITHOUT_CLANG_EXTRAS
+MOZ_EXPORT+= LLVM_OBJDUMP="${LOCALBASE}/bin/llvm-objdump${LLVM_DEFAULT}"
+.endif
# Require newer Clang than what's in base system unless user opted out
. if ${CC} == cc && ${CXX} == c++ && exists(/usr/lib/libc++.so)
BUILD_DEPENDS+= ${LOCALBASE}/bin/clang${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT}