aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gecko.mk
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2014-04-29 20:35:24 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2014-04-29 20:35:24 +0000
commitb6e8f8d98d01f9b6b048db019ce0b54b6952ca76 (patch)
tree0e3c95500987c19648fa815255fecf2288db4054 /Mk/bsd.gecko.mk
parent6ab229ab60f4505591bc8aebc12e641ea792d73a (diff)
downloadports-b6e8f8d98d01f9b6b048db019ce0b54b6952ca76.tar.gz
ports-b6e8f8d98d01f9b6b048db019ce0b54b6952ca76.zip
- Update Firefox to 29.0
- Update Firefox ESR to 24.5.0 - Update Thunderbird to 24.5.0 - Update NSS to 3.16 - Use port dependency for soundtouch library - Require recent graphite2 version explicitly [1] - Require gst-libav version that doesn't crash on seeking [2] and doesn't error out on plugin load [3] - Remove gstreamer note in pkg-message for www/firefox, [3] may still happen with www/firefox-esr but only until it tracks esr31 (ca 2014-09-01) - Fix USE_XPI in mail/thunderbird-i18n [4] Security: http://www.vuxml.org/freebsd/985d4d6c-cfbd-11e3-a003-b4b52fce4ce8.html PR: ports/187939 [1] PR: ports/188133 [2] PR: ports/181964 [3] PR: ports/188984 [4] Submitted by: Toomas Aas <toomas.aas@raad.tartu.ee> [1] Submitted by: Jakub Lach <jakub_lach@mailplus.pl> [2] Submitted by: Jan Beich [3] and this update! Submitted by: Toni Ballesta <mustelator@yahoo.es> [4] Approved by: portmgr (bdrewery, security update to non-staged port)
Notes
Notes: svn path=/head/; revision=352640
Diffstat (limited to 'Mk/bsd.gecko.mk')
-rw-r--r--Mk/bsd.gecko.mk37
1 files changed, 31 insertions, 6 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 69e681e9658c..3cb46090bf81 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -33,7 +33,8 @@ Gecko_Pre_Include= bsd.gecko.mk
# listed in '_ALL_DEPENDS'. If your port doesn't
# need one of those then you can use '-' like
# 'USE_MOZILLA= -png -vpx' to subtract the
-# dependencies.
+# dependencies. Experimental deps use '+' like
+# 'USE_MOZILLA= +speex +theora'.
#
# GECKO_PLIST_PRE_FILES Manual add files in the plist if it needs.
#
@@ -140,7 +141,7 @@ MOZ_OPTIONS+= --enable-jemalloc
.endif
# Standard depends
-_ALL_DEPENDS= cairo event ffi harfbuzz hunspell icu jpeg nspr nss opus png pixman sqlite vorbis vpx
+_ALL_DEPENDS= cairo event ffi graphite harfbuzz hunspell icu jpeg nspr nss opus png pixman soundtouch sqlite vorbis vpx
cairo_LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo
cairo_MOZ_OPTIONS= --enable-system-cairo
@@ -155,10 +156,13 @@ ffi_MOZ_OPTIONS= --enable-system-ffi
ffi_EXTRACT_AFTER_ARGS= --exclude mozilla*/js/src/ctypes/libffi
.if exists(${FILESDIR}/patch-bug847568) || exists(${FILESDIR}/patch-z-bug847568)
+graphite_LIB_DEPENDS= libgraphite2.so:${PORTSDIR}/graphics/graphite2
+graphite_MOZ_OPTIONS= --with-system-graphite2
+graphite_EXTRACT_AFTER_ARGS= --exclude mozilla*/gfx/graphite2
+
harfbuzz_LIB_DEPENDS= libharfbuzz.so:${PORTSDIR}/print/harfbuzz
-harfbuzz_MOZ_OPTIONS= --with-system-harfbuzz --with-system-graphite2
-harfbuzz_EXTRACT_AFTER_ARGS= --exclude mozilla*/gfx/harfbuzz \
- --exclude mozilla*/gfx/graphite2
+harfbuzz_MOZ_OPTIONS= --with-system-harfbuzz
+harfbuzz_EXTRACT_AFTER_ARGS= --exclude mozilla*/gfx/harfbuzz
.endif
hunspell_LIB_DEPENDS= libhunspell-1.3.so:${PORTSDIR}/textproc/hunspell
@@ -197,11 +201,27 @@ png_LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
png_MOZ_OPTIONS= --with-system-png=${LOCALBASE}
png_EXTRACT_AFTER_ARGS= --exclude mozilla*/media/libpng
+.if exists(${FILESDIR}/patch-z-bug517422) || exists(${FILESDIR}/patch-zz-bug517422)
+soundtouch_LIB_DEPENDS= libSoundTouch.so:${PORTSDIR}/audio/soundtouch
+soundtouch_MOZ_OPTIONS= --with-system-soundtouch
+soundtouch_EXTRACT_AFTER_ARGS= --exclude mozilla*/media/libsoundtouch
+
+# XXX disabled: bug 913854 not yet upstreamed
+speex_LIB_DEPENDS= libspeexdsp.so:${PORTSDIR}/audio/speex
+speex_MOZ_OPTIONS= --with-system-speex
+speex_EXTRACT_AFTER_ARGS= --exclude mozilla*/media/libspeex_resampler
+.endif
+
sqlite_LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3
sqlite_MOZ_OPTIONS= --enable-system-sqlite
sqlite_EXTRACT_AFTER_ARGS= --exclude mozilla*/db/sqlite3
.if exists(${FILESDIR}/patch-z-bug517422) || exists(${FILESDIR}/patch-zz-bug517422)
+# XXX disabled: update to 1.2.x or review backported fixes
+theora_LIB_DEPENDS= libtheora.so:${PORTSDIR}/multimedia/libtheora
+theora_MOZ_OPTIONS= --with-system-theora
+theora_EXTRACT_AFTER_ARGS= --exclude mozilla*/media/libtheora
+
vorbis_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
vorbis_MOZ_OPTIONS= --with-system-vorbis --with-system-ogg
vorbis_EXTRACT_AFTER_ARGS= --exclude mozilla*/media/libvorbis \
@@ -217,7 +237,7 @@ vpx_EXTRACT_AFTER_ARGS= --exclude mozilla*/media/libvpx
${use:S/-/_WITHOUT_/}= ${TRUE}
.endfor
-.for dep in ${_ALL_DEPENDS}
+.for dep in ${_ALL_DEPENDS} ${USE_MOZILLA:M+*:S/+//}
.if !defined(_WITHOUT_${dep})
BUILD_DEPENDS+= ${${dep}_BUILD_DEPENDS}
LIB_DEPENDS+= ${${dep}_LIB_DEPENDS}
@@ -367,7 +387,12 @@ MOZ_OPTIONS+= --enable-alsa
.endif
.if ${PORT_OPTIONS:MPULSEAUDIO}
+. if ${PORT_OPTIONS:MALSA}
BUILD_DEPENDS+= pulseaudio>0:${PORTSDIR}/audio/pulseaudio
+. else
+# pull pulse package if we cannot fallback to another backend
+LIB_DEPENDS+= libpulse.so:${PORTSDIR}/audio/pulseaudio
+. endif
MOZ_OPTIONS+= --enable-pulseaudio
.else
MOZ_OPTIONS+= --disable-pulseaudio