aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gecko.mk
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2023-10-08 17:25:10 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2023-10-08 17:25:10 +0000
commiteb9f07125e7dba4f6666f8542632ee636970b272 (patch)
tree175fc0d57d7f371697ce324adaa48c7fa016f383 /Mk/bsd.gecko.mk
parentecfc3b7e08fc5d5f34748500a359edb3bfc8daa2 (diff)
downloadports-eb9f07125e7dba4f6666f8542632ee636970b272.tar.gz
ports-eb9f07125e7dba4f6666f8542632ee636970b272.zip
Mk/bsd.gecko.mk: cleanup
remove conditionals for gecko versions no longer present in our tree
Diffstat (limited to 'Mk/bsd.gecko.mk')
-rw-r--r--Mk/bsd.gecko.mk13
1 files changed, 0 insertions, 13 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 11c2a20b9d4c..98eb1ed72709 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -62,15 +62,9 @@ MOZILLA_BIN?= ${PORTNAME}-bin
MOZILLA_EXEC_NAME?=${MOZILLA}
USES+= compiler:c++17-lang cpe gl gmake gnome iconv localbase pkgconfig \
python:build desktop-file-utils
-. if ${MOZILLA_VER:R:R} < 115
-USES+= perl5
-. endif
CPE_VENDOR?=mozilla
USE_GL= gl
USE_GNOME= cairo gdkpixbuf2 gtk30
-. if ${MOZILLA_VER:R:R} < 115
-USE_PERL5= build
-. endif
USE_XORG= x11 xcb xcomposite xdamage xext xfixes xrandr xrender xt xtst
HAS_CONFIGURE= yes
CONFIGURE_OUTSOURCE= yes
@@ -89,9 +83,6 @@ LIB_DEPENDS+= libepoll-shim.so:devel/libepoll-shim
MOZ_EXPORT+= ${CONFIGURE_ENV} \
PYTHON3="${PYTHON_CMD}" \
RUSTFLAGS="${RUSTFLAGS}"
-. if ${MOZILLA_VER:R:R} < 115
-MOZ_EXPORT+= PERL="${PERL}"
-. endif
MOZ_OPTIONS+= --prefix="${PREFIX}"
MOZ_MK_OPTIONS+=MOZ_OBJDIR="${BUILD_WRKSRC}"
@@ -239,11 +230,7 @@ MOZ_OPTIONS+= --disable-dbus
. if ${PORT_OPTIONS:MFFMPEG}
# dom/media/platforms/ffmpeg/FFmpegRuntimeLinker.cpp
-. if ${MOZILLA_VER:R:R} < 112
-RUN_DEPENDS+= ffmpeg4>=4.4:multimedia/ffmpeg4
-. else
RUN_DEPENDS+= ffmpeg>=6.0,1:multimedia/ffmpeg
-. endif
. endif
. if ${PORT_OPTIONS:MLIBPROXY}