aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gstreamer.mk
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-09-26 14:36:23 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-09-26 14:36:23 +0000
commit7b97259096b0df72f16568f5b49a9a33cf1b4958 (patch)
tree6e57fabcf96c9308178f83f5236aab5d8f1b0127 /Mk/bsd.gstreamer.mk
parent79947ef8956812db831bc1ed9541b5dcbb27a3ad (diff)
downloadports-7b97259096b0df72f16568f5b49a9a33cf1b4958.tar.gz
ports-7b97259096b0df72f16568f5b49a9a33cf1b4958.zip
Update gstreamer1 ports to 1.6.0.
* gstreamer1-libav now uses ffmpeg from ports. * New ports: * gstreamer1-validate: Tools to detect if elements are not behaving as expected, mainly aimed at developers, or advanced debugging. * gstreamer1-rtsp-server: Base foundation for building a rtsp server ontop of GStreamer * Bunch of new plugins like: mpg123, rsvg, libde265, openh264, x265 and dtls. Release announcement: http://lists.freedesktop.org/archives/gstreamer-announce/2015-September/000357.html Obtained from: gnome devel repo
Notes
Notes: svn path=/head/; revision=397984
Diffstat (limited to 'Mk/bsd.gstreamer.mk')
-rw-r--r--Mk/bsd.gstreamer.mk26
1 files changed, 23 insertions, 3 deletions
diff --git a/Mk/bsd.gstreamer.mk b/Mk/bsd.gstreamer.mk
index 42c25bc1e33a..31d11f5291c5 100644
--- a/Mk/bsd.gstreamer.mk
+++ b/Mk/bsd.gstreamer.mk
@@ -89,9 +89,9 @@ _GSTREAMER_PLUGINS+= \
# plugins only in 1.0
.if defined(USE_GSTREAMER1)
_GSTREAMER_PLUGINS+= \
- assrender curl dvdread editing-services kate libav \
- modplug openjpeg png rtmp \
- spandsp vpx webp x ximagesrc zbar
+ assrender bs2b chromaprint curl dtls dvdread editing-services \
+ hls kate libav libde265 modplug mpg123 openh264 openjpeg \
+ png rsvg rtmp spandsp vpx webp x x265 ximagesrc zbar
# vaapi?
.endif
@@ -120,10 +120,14 @@ artsd_DEPENDS= audio/gstreamer-plugins-artsd
audiofile_DEPENDS= audio/gstreamer-plugins-audiofile
+bs2b_DEPENDS= audio/gstreamer-plugins-bs2b
+
cdaudio_DEPENDS= audio/gstreamer-plugins-cdaudio
cdparanoia_DEPENDS= audio/gstreamer-plugins-cdparanoia
+chromaprint_DEPENDS= audio/gstreamer-plugins-chromaprint
+
esound_DEPENDS= audio/gstreamer-plugins-esound
faac_DEPENDS= audio/gstreamer-plugins-faac
@@ -156,6 +160,8 @@ modplug_DEPENDS= audio/gstreamer-plugins-modplug
mp3_DEPENDS= audio/gstreamer-plugins-mp3
+mpg123_DEPENDS= audio/gstreamer-plugins-mpg123
+
musepack_DEPENDS= audio/gstreamer-plugins-musepack
nas_DEPENDS= audio/gstreamer-plugins-nas
@@ -246,6 +252,8 @@ openjpeg_DEPENDS= graphics/gstreamer-plugins-openjpeg
png_DEPENDS= graphics/gstreamer-plugins-png
+rsvg_DEPENDS= graphics/gstreamer-plugins-rsvg
+
webp_DEPENDS= graphics/gstreamer-plugins-webp
zbar_DEPENDS= graphics/gstreamer-plugins-zbar
@@ -280,6 +288,8 @@ good_DEPENDS= multimedia/gstreamer-plugins-good
gnonlin_DEPENDS= multimedia/gstreamer-plugins-gnonlin
+hls_DEPENDS= multimedia/gstreamer-plugins-hls
+
kate_DEPENDS= multimedia/gstreamer-plugins-kate
libav_DEPENDS= multimedia/gstreamer-libav
@@ -287,6 +297,8 @@ libav_GST_PREFIX= gstreamer1-
libav_GST_SUFX= # empty
libav_GST_VERSION= 1.0.0
+libde265_DEPENDS= multimedia/gstreamer-plugins-libde265
+
libfame_DEPENDS= multimedia/gstreamer-plugins-libfame
mm_DEPENDS= multimedia/gstreamermm
@@ -300,6 +312,8 @@ mpeg2enc_DEPENDS= multimedia/gstreamer-plugins-mpeg2enc
mplex_DEPENDS= multimedia/gstreamer-plugins-mplex
+openh264_DEPENDS= multimedia/gstreamer-plugins-openh264
+
qt4_DEPENDS= multimedia/gstreamer-qt4
qt4_GST_PREFIX= gstreamer-
@@ -335,6 +349,8 @@ vdpau_DEPENDS= multimedia/gstreamer-plugins-vdpau
x264_DEPENDS= multimedia/gstreamer-plugins-x264
+x265_DEPENDS= multimedia/gstreamer-plugins-x265
+
xvid_DEPENDS= multimedia/gstreamer-plugins-xvid
@@ -342,6 +358,10 @@ xvid_DEPENDS= multimedia/gstreamer-plugins-xvid
libmms_DEPENDS= net/gstreamer-plugins-libmms
+#-- security plugins section ----------------------------------------------#
+
+dtls_DEPENDS= security/gstreamer-plugins-dtls
+
#-- sysutils plugins section ----------------------------------------------#
cdio_DEPENDS= sysutils/gstreamer-plugins-cdio