aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.java.mk
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:07:24 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:07:24 +0000
commit0de3ff661acec63625e5bf537d3305273b9edd3e (patch)
tree61c495663ecd565ff7f7dad86105f6901a721a24 /Mk/bsd.java.mk
parentf4ec9c6ead3b8e182d8d38b1a298bf069656bb6c (diff)
downloadports-0de3ff661acec63625e5bf537d3305273b9edd3e.tar.gz
ports-0de3ff661acec63625e5bf537d3305273b9edd3e.zip
bsd.port.mk
[1] Remove DEPENDS [2] Add a new pkg-plist keyword @stopdaemon [3] Provide rc.subr script suffix as RC_SUBR_SUFFIX [4] Add USE_CDRTOOLS to abstract dependency on sysutils/cdrtool[-cjk] [5] Add DOS2UNIX_REGEX, allowing to pass a filename regex to CRLF replacement routine [6] Support partially translated manpages in MAN* variables [7] Fix USE_LDCONFIG on ports with @cwd in pkg-plist [8] Remove support for XFree86 3.X [9] Add user settable WITH_DEBUG flag that turns on -g in CFLAGS and resets STRIP [9] Fix `make install' to refuse overwriting of older version of the port [10] New category ports-mgmt [11] New category gnustep [12] Removed category picobsd bsd.java.mk [13] Remove deprecated syntax bsd.tcl.mk [14] Provide TCL_VER when USE_TK[_BUILD] is defined. Fixes cad/netgen ports/Makefile [15] Make csup default `make update' method on FreeBSD 6.2 and up PR: ports/99742 [1], ports/93373 [2], ports/100915 [3], ports/105161 [4], ports/106029 [5], ports/106252 [6], ports/106235 [7], ports/100939 [9], ports/97507 [10], ports/103931 [11], ports/106921 [12], ports/104136 [13], ports/105215 [15] Submitted by: sem [1] [2], Matthias Andree <matthias.andree@gmx.de> [3], nork [4], pav [5] [7] [14], Nick Barkas <snb@threerings.net> [6], flz [8], gabor [9], shaun [10], erwin [12], hq [13], Gurkan Sengun <gurkan@linuks.mine.nu> [11]
Notes
Notes: svn path=/head/; revision=183768
Diffstat (limited to 'Mk/bsd.java.mk')
-rw-r--r--Mk/bsd.java.mk66
1 files changed, 8 insertions, 58 deletions
diff --git a/Mk/bsd.java.mk b/Mk/bsd.java.mk
index 661d962b5c9c..567813915ad6 100644
--- a/Mk/bsd.java.mk
+++ b/Mk/bsd.java.mk
@@ -128,13 +128,11 @@ Java_Include_MAINTAINER= glewis@FreeBSD.org hq@FreeBSD.org
# There are the following stages:
#
# Stage 1: Define constants
-# Stage 2: bsd.java.mk 1.0 backward compatibility
-# Stage 3: Determine which JDK ports are installed and which JDK ports are
+# Stage 2: Determine which JDK ports are installed and which JDK ports are
# suitable
-# Stage 4: <REMOVED> (merged in stage 3)
-# Stage 5: Decide the exact JDK to use (or install)
-# Stage 6: Add any dependencies if necessary
-# Stage 7: Define all settings for the port to use
+# Stage 3: Decide the exact JDK to use (or install)
+# Stage 4: Add any dependencies if necessary
+# Stage 5: Define all settings for the port to use
#
. if defined(USE_JAVA)
@@ -255,53 +253,7 @@ DEPEND_JIKES= ${_JIKES_PATH}:${PORTSDIR}/java/jikes
#-------------------------------------------------------------------------------
-# Stage 2: bsd.java.mk 1.0 backward compatibility
-#
-
-# First detect if we are using bsd.java.mk v1.0
-_USE_BSD_JAVA_MK_1_0!= ${ECHO_CMD} "${_JAVA_VERSION_LIST}" \
- | ${TR} " " "\n" \
- | ${GREP} -q "^${USE_JAVA}$$" && ${ECHO_CMD} "yes" || ${ECHO_CMD} "no"
-. if (${_USE_BSD_JAVA_MK_1_0} == "yes")
-# Then affect the variables so that we may use v2.0
-# USE_JAVA --> JAVA_VERSION
-. if !defined(JAVA_VERSION)
-JAVA_VERSION= ${USE_JAVA}
-. else
-check-makevars::
- @${ECHO_CMD} "${PKGNAME}: Makefile error: The port is using bsd.java.mk 1.0 but sets a value for JAVA_VERSION. This may cause problems."
- @${FALSE}
-. endif
-# NO_{BUILD|RUN}_DEPENDS_JAVA --> JAVA_{BUILD|RUN}
-. if defined(NO_BUILD_DEPENDS_JAVA) && defined(NO_RUN_DEPENDS_JAVA)
-check-makevars::
- @${ECHO_CMD} "${PKGNAME}: Makefile error: NO_BUILD_DEPENDS_JAVA and NO_RUN_DEPENDS_JAVA cannot be set at the same time.";
- @${FALSE}
-. else
-. if !defined(NO_BUILD_DEPENDS_JAVA) && !defined(NO_BUILD)
-JAVA_BUILD= jdk
-. endif
-. if !defined(NO_RUN_DEPENDS_JAVA)
-JAVA_RUN= jdk
-. endif
-. endif
-# NEED_JAVAC --> JAVA_{BUILD|RUN}={jdk|jre}
-. if defined(NEED_JAVAC)
-. if (${NEED_JAVAC:U} == "YES")
-JAVA_BUILD= jdk
-. elif (${NEED_JAVAC:U} == "NO")
-JAVA_BUILD= jre
-. else
-check-makevars::
- @${ECHO_CMD} "${PKGNAME}: Makefile error: \"${NEED_JAVAC}\" is not a valid value for NEED_JAVAC. It should be YES or NO, or it should be undefined.";
- @${FALSE}
-. endif
-. endif
-. endif
-
-
-#-------------------------------------------------------------------------------
-# Stage 3: Determine which JDK ports are suitable and which JDK ports are
+# Stage 2: Determine which JDK ports are suitable and which JDK ports are
# suitable
#
@@ -397,7 +349,7 @@ _JAVA_PORTS_POSSIBLE= ${__JAVA_PORTS_POSSIBLE:C/ [ ]+/ /g}
#-------------------------------------------------------------------------------
-# Stage 5: Decide the exact JDK to use (or install)
+# Stage 3: Decide the exact JDK to use (or install)
#
# Find an installed JDK port that matches the requirements of the port
@@ -432,7 +384,7 @@ JAVA_PORT_VENDOR_DESCRIPTION:= ${JAVA_PORT_VENDOR:S/^/\${_JAVA_VENDOR_/:S/$/}/}
JAVA_PORT_OS_DESCRIPTION:= ${JAVA_PORT_OS:S/^/\${_JAVA_OS_/:S/$/}/}
#-------------------------------------------------------------------------------
-# Stage 6: Add any dependencies if necessary
+# Stage 4: Add any dependencies if necessary
#
# Jikes support: If USE_JIKES is set to YES, then use Jikes. If USE_JIKES is
@@ -507,7 +459,7 @@ do-build:
. endif
#-----------------------------------------------------------------------------
-# Stage 7: Define all settings for the port to use
+# Stage 5: Define all settings for the port to use
#
# At this stage both JAVA_HOME and JAVA_PORT are definitely given a value.
#
@@ -563,8 +515,6 @@ JAVA_CLASSES= ${JAVA_HOME}/jre/lib/rt.jar
# Debug target
# Use it to check Java dependency while porting
java-debug:
- @${ECHO_CMD} "_USE_BSD_JAVA_MK_1_0= ${_USE_BSD_JAVA_MK_1_0}"
- @${ECHO_CMD}
@${ECHO_CMD} "# User specified parameters:"
@${ECHO_CMD} "JAVA_VERSION= ${JAVA_VERSION} (${_JAVA_VERSION})"
@${ECHO_CMD} "JAVA_OS= ${JAVA_OS} (${_JAVA_OS})"