aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.java.mk
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2004-11-29 17:33:41 +0000
committerHerve Quiroz <hq@FreeBSD.org>2004-11-29 17:33:41 +0000
commit3bc39f5fdd7fc87582c44e2bad1aa5df8d8d84b0 (patch)
tree5625f53d474bc855bf3a6c5aa5eae4b22b61c161 /Mk/bsd.java.mk
parent54d7292f307305107fb8ea3e2b79ac0d99d1bb6c (diff)
downloadports-3bc39f5fdd7fc87582c44e2bad1aa5df8d8d84b0.tar.gz
ports-3bc39f5fdd7fc87582c44e2bad1aa5df8d8d84b0.zip
When USE_ANT is defined, JAVA_BUILD is automatically set to 'jdk' but this
conflicts with the default values for JAVA_BUILD and JAVA_RUN. Those variables are indeed set a default value when none of the them (together with JAVA_EXTRACT) is defined. Having USE_ANT set a value for JAVA_BUILD will cause JAVA_RUN not to be set its default value. This has RUN_DEPENDS not correctly set (missing the JDK entry) on many ports that use USE_ANT. This patch addresses this issue by moving the statements dealing with default values to have them executed before USE_ANT handling. Approved by: glewis (co-maintainer)
Notes
Notes: svn path=/head/; revision=122756
Diffstat (limited to 'Mk/bsd.java.mk')
-rw-r--r--Mk/bsd.java.mk18
1 files changed, 10 insertions, 8 deletions
diff --git a/Mk/bsd.java.mk b/Mk/bsd.java.mk
index a1641a4f8743..dccdc3b71345 100644
--- a/Mk/bsd.java.mk
+++ b/Mk/bsd.java.mk
@@ -330,6 +330,16 @@ check-makevars::
@${FALSE}
. endif
+# Set default values for JAVA_BUILD and JAVA_RUN
+# When nothing is set, assume JAVA_BUILD=jdk and JAVA_RUN=jre
+# (unless NO_BUILD is set)
+. if !defined(JAVA_EXTRACT) && !defined(JAVA_BUILD) && !defined(JAVA_RUN)
+. if !defined(NO_BUILD)
+JAVA_BUILD= jdk
+. endif
+JAVA_RUN= jre
+. endif
+
# JDK dependency setting
. undef _JAVA_PORTS_INSTALLED
. undef _JAVA_PORTS_POSSIBLE
@@ -444,14 +454,6 @@ JAVA_BUILD= jdk
# Add the JDK port to the dependencies
DEPEND_JAVA= ${JAVA}:${PORTSDIR}/${JAVA_PORT}
-# When nothing is set, assume JAVA_BUILD=jdk and JAVA_RUN=jre
-# (unless NO_BUILD is set)
-. if !defined(JAVA_EXTRACT) && !defined(JAVA_BUILD) && !defined(JAVA_RUN)
-. if !defined(NO_BUILD)
-JAVA_BUILD= jdk
-. endif
-JAVA_RUN= jre
-. endif
. if defined(JAVA_EXTRACT)
EXTRACT_DEPENDS+= ${DEPEND_JAVA}
. endif