aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.java.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 09:45:36 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 09:45:36 +0000
commit4a4ec28d37b64039d4eff0f34ad66b543767d758 (patch)
tree96cc94ba02edcc043c52eb3f26adbc632bbe44d8 /Mk/bsd.java.mk
parenta5d24d4bb4a43375b4bbb7f8bc673f8c557f06b4 (diff)
downloadports-4a4ec28d37b64039d4eff0f34ad66b543767d758.tar.gz
ports-4a4ec28d37b64039d4eff0f34ad66b543767d758.zip
Convert all :U to :tu and :L to :tl
Since FreeBSD 8.4 and FreeBSD 9.1 make(1) do support :tu and :tl as a replacement for :U and :L (which has been marked as deprecated) bmake which is the default on FreeBSD 10+ only support by default :tu/:tl a hack has been added at the time to support :U and :L to ease migration. This hack is now not necessary anymore Note that this makes the ports tree incompatible with make(1) from FreeBSD 8.3 or earlier With hat: portmgr
Notes
Notes: svn path=/head/; revision=352986
Diffstat (limited to 'Mk/bsd.java.mk')
-rw-r--r--Mk/bsd.java.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.java.mk b/Mk/bsd.java.mk
index 26d3db597676..636d3a186c4e 100644
--- a/Mk/bsd.java.mk
+++ b/Mk/bsd.java.mk
@@ -410,7 +410,7 @@ do-build:
# Then test if a JAVAC has to be set (JAVA_BUILD==jdk)
. if defined(JAVA_BUILD)
-. if (${JAVA_BUILD:U} == "JDK") && !defined(JAVAC)
+. if (${JAVA_BUILD:tu} == "JDK") && !defined(JAVAC)
JAVAC?= ${JAVA_HOME}/bin/javac
. endif
. endif