aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.java.mk
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2019-09-23 18:19:57 +0000
committerGreg Lewis <glewis@FreeBSD.org>2019-09-23 18:19:57 +0000
commite0d67b113cb14ac39fb8d4add1841694c970e580 (patch)
tree9e294b265342e7ef163e38898e8ef8410b289a88 /Mk/bsd.java.mk
parent3b6d1e1b4573ab04351d6fcd033208281807a660 (diff)
downloadports-e0d67b113cb14ac39fb8d4add1841694c970e580.tar.gz
ports-e0d67b113cb14ac39fb8d4add1841694c970e580.zip
Remove references to openjdk6
* Remove references to "6" in comments and examples * Remove java/openjdk6 from the list of Java ports that are considered to satisfy a dependency * Don't yet remove "6" as a valid version since many ports have "1.6+" as a version specifier (although none have just 1.6). Instead force this to mean "1.7+". PR: 234792 Sponsored by: The FreeBSD Foundation
Notes
Notes: svn path=/head/; revision=512662
Diffstat (limited to 'Mk/bsd.java.mk')
-rw-r--r--Mk/bsd.java.mk24
1 files changed, 11 insertions, 13 deletions
diff --git a/Mk/bsd.java.mk b/Mk/bsd.java.mk
index 9d12d404b03b..6ded2afdd666 100644
--- a/Mk/bsd.java.mk
+++ b/Mk/bsd.java.mk
@@ -25,7 +25,7 @@ Java_Include_MAINTAINER= java@FreeBSD.org
#
# JAVA_VERSION List of space-separated suitable java versions for the
# port. An optional "+" allows you to specify a range of
-# versions. (allowed values: 6[+] 7[+] 8[+] 9[+] 10[+]
+# versions. (allowed values: 7[+] 8[+] 9[+] 10[+]
# 11[+] 12[+])
#
# JAVA_OS List of space-separated suitable JDK port operating systems
@@ -53,9 +53,9 @@ Java_Include_MAINTAINER= java@FreeBSD.org
#-------------------------------------------------------------------------------
# Variables defined for the port:
#
-# JAVA_PORT The name of the JDK port. (e.g. 'java/openjdk6')
+# JAVA_PORT The name of the JDK port. (e.g. 'java/openjdk8')
#
-# JAVA_PORT_VERSION The version of the JDK port. (e.g. '6')
+# JAVA_PORT_VERSION The version of the JDK port. (e.g. '8')
#
# JAVA_PORT_OS The operating system used by the JDK port. (e.g. 'linux')
#
@@ -68,19 +68,19 @@ Java_Include_MAINTAINER= java@FreeBSD.org
# (e.g. 'OpenJDK BSD Porting Team')
#
# JAVA_HOME Path to the installation directory of the JDK. (e.g.
-# '/usr/local/openjdk6')
+# '/usr/local/openjdk8')
#
# JAVAC Path to the Java compiler to use. (e.g.
-# '/usr/local/openjdk6/bin/javac' or '/usr/local/bin/javac')
+# '/usr/local/openjdk8/bin/javac' or '/usr/local/bin/javac')
#
# JAR Path to the JAR tool to use. (e.g.
-# '/usr/local/openjdk6/bin/jar' or '/usr/local/bin/fastjar')
+# '/usr/local/openjdk8/bin/jar' or '/usr/local/bin/fastjar')
#
# APPLETVIEWER Path to the appletviewer utility. (e.g.
# '/usr/local/linux-jdk1.8.0/bin/appletviewer')
#
# JAVA Path to the java executable. Use this for executing Java
-# programs. (e.g. '/usr/local/openjdk6/bin/java')
+# programs. (e.g. '/usr/local/openjdk8/bin/java')
#
# JAVADOC Path to the javadoc utility program.
#
@@ -115,7 +115,7 @@ Java_Include_MAINTAINER= java@FreeBSD.org
#-------------------------------------------------------------------------------
# Porter's hints
#
-# To retrieve the Major version number from JAVA_PORT_VERSION (e.g. "1.6"):
+# To retrieve the Major version number from JAVA_PORT_VERSION (e.g. "1.8"):
# -> ${JAVA_PORT_VERSION:C/^([0-9])\.([0-9])(.*)$/\1.\2/}
#
#-------------------------------------------------------------------------------
@@ -170,8 +170,6 @@ _JAVA_VENDOR_LIST= openjdk oracle
# Set all meta-information about JDK ports:
# port location, corresponding JAVA_HOME, JDK version, OS, vendor
-_JAVA_PORT_NATIVE_OPENJDK_JDK_6_INFO= PORT=java/openjdk6 HOME=${LOCALBASE}/openjdk6 \
- VERSION=6 OS=native VENDOR=openjdk
_JAVA_PORT_NATIVE_OPENJDK_JDK_7_INFO= PORT=java/openjdk7 HOME=${LOCALBASE}/openjdk7 \
VERSION=7 OS=native VENDOR=openjdk
_JAVA_PORT_NATIVE_OPENJDK_JDK_8_INFO= PORT=java/openjdk8 HOME=${LOCALBASE}/openjdk8 \
@@ -196,11 +194,11 @@ _JAVA_OS_native= Native
_JAVA_OS_linux= Linux
# List all JDK ports in order of preference
-__JAVA_PORTS_ALL= JAVA_PORT_NATIVE_OPENJDK_JDK_8 \
+__JAVA_PORTS_ALL= \
+ JAVA_PORT_NATIVE_OPENJDK_JDK_8 \
JAVA_PORT_NATIVE_OPENJDK_JDK_11 \
JAVA_PORT_NATIVE_OPENJDK_JDK_12 \
JAVA_PORT_NATIVE_OPENJDK_JDK_7 \
- JAVA_PORT_NATIVE_OPENJDK_JDK_6 \
JAVA_PORT_LINUX_ORACLE_JDK_8 \
JAVA_PORT_LINUX_ORACLE_JDK_9 \
JAVA_PORT_LINUX_ORACLE_JDK_10
@@ -276,7 +274,7 @@ JAVA_RUN= jre
. undef _JAVA_PORTS_INSTALLED
. undef _JAVA_PORTS_POSSIBLE
. if defined(JAVA_VERSION)
-_JAVA_VERSION= ${JAVA_VERSION:S/1.6+/1.6 1.7+/:S/1.7+/1.7 1.8+/:S/1.8+/1.8 1.9+/:S/1.9+/1.9 10+/:S/1.6/6/:S/1.7/7/:S/1.8/8/:S/1.9/9/:S/6+/6 7+/:S/7+/7 8+/:S/8+/8 9+/:S/9+/9 10+/:S/10+/10 11+/:S/11+/11 12+/:S/12+/12/}
+_JAVA_VERSION= ${JAVA_VERSION:S/1.6+/1.7+/:S/1.7+/1.7 1.8+/:S/1.8+/1.8 1.9+/:S/1.9+/1.9 10+/:S/1.6/7/:S/1.7/7/:S/1.8/8/:S/1.9/9/:S/6+/7+/:S/7+/7 8+/:S/8+/8 9+/:S/9+/9 10+/:S/10+/10 11+/:S/11+/11 12+/:S/12+/12/}
. else
_JAVA_VERSION= ${__JAVA_VERSION_LIST}
. endif