aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.ocaml.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-09-26 08:41:45 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-09-26 08:41:45 +0000
commit9c60540e18b8489580890549981270c94c58f962 (patch)
tree34681fd433ac34c86d80c15ebef3e56b97c4bc4d /Mk/bsd.ocaml.mk
parentf8005ba9f4b388288f1b2c70a742b4597fa8a276 (diff)
downloadports-9c60540e18b8489580890549981270c94c58f962.tar.gz
ports-9c60540e18b8489580890549981270c94c58f962.zip
Explicitly run the ocaml command in post (de)installation
Notes
Notes: svn path=/head/; revision=397941
Diffstat (limited to 'Mk/bsd.ocaml.mk')
-rw-r--r--Mk/bsd.ocaml.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.ocaml.mk b/Mk/bsd.ocaml.mk
index 59ec309b915c..f78a5f1986c9 100644
--- a/Mk/bsd.ocaml.mk
+++ b/Mk/bsd.ocaml.mk
@@ -177,9 +177,9 @@ OCAML_LDLIBS?= ${OCAML_SITELIBDIR}/${PORTNAME}
. if !target(ocaml-ldconfig)
ocaml-ldconfig:
. for LIB in ${OCAML_LDLIBS}
- @${ECHO_CMD} "@exec ${ECHO_CMD} "%D/${LIB}" >> %D/${OCAML_LDCONF}" \
+ @${ECHO_CMD} "@postexec ${ECHO_CMD} "%D/${LIB}" >> %D/${OCAML_LDCONF}" \
>> ${TMPPLIST}
- @${ECHO_CMD} "@unexec ${SED} -i \"\" -e '/${LIB:S#/#\/#g}/d' %D/${OCAML_LDCONF}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@postunexec ${SED} -i \"\" -e '/${LIB:S#/#\/#g}/d' %D/${OCAML_LDCONF}" >> ${TMPPLIST}
. endfor
. endif
.endif
@@ -188,7 +188,7 @@ ocaml-ldconfig:
. if !target(ocaml-wash)
ocaml-wash:
# If ld.conf is empty
- @${ECHO_CMD} "@unexec if [ ! -s %D/${OCAML_LDCONF} ]; then ${RM} -f %D/${OCAML_LDCONF}; fi || true" >> ${TMPPLIST}
+ @${ECHO_CMD} "@postunexec if [ ! -s %D/${OCAML_LDCONF} ]; then ${RM} -f %D/${OCAML_LDCONF}; fi || true" >> ${TMPPLIST}
. endif
.endif