aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.openssl.mk
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2014-03-03 05:43:38 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2014-03-03 05:43:38 +0000
commit38dca0bc00a7c6bc44edf708ddcc7ced8d340a4c (patch)
treed62b0489b611ed9a613ed61205ef51d9b35bb3a2 /Mk/bsd.openssl.mk
parent4531be94b141f64140e445b22e5dc26066d85c99 (diff)
downloadports-38dca0bc00a7c6bc44edf708ddcc7ced8d340a4c.tar.gz
ports-38dca0bc00a7c6bc44edf708ddcc7ced8d340a4c.zip
Notes
Diffstat (limited to 'Mk/bsd.openssl.mk')
-rw-r--r--Mk/bsd.openssl.mk10
1 files changed, 1 insertions, 9 deletions
diff --git a/Mk/bsd.openssl.mk b/Mk/bsd.openssl.mk
index 605826b768dd..c6e8fe0e5563 100644
--- a/Mk/bsd.openssl.mk
+++ b/Mk/bsd.openssl.mk
@@ -8,7 +8,6 @@
#
# WITH_OPENSSL_BASE=yes - Use the version in the base system.
# WITH_OPENSSL_PORT=yes - Use the port, even if base is up to date
-# WITH_OPENSSL_HACK7=yes - Use not the version in the base system on FreeBSD 7.x
#
# USE_OPENSSL_RPATH=yes - Pass RFLAGS options in CFLAGS,
# needed for ports who don't use LDFLAGS
@@ -40,13 +39,6 @@ WITH_OPENSSL_BASE=yes
WITH_OPENSSL_PORT=yes
.endif
-.if defined(WITH_OPENSSL_HACK7)
-.if ${OSVERSION} < 800000
-# the openssl in base of FreeBSD 7.x is too old
-WITH_OPENSSL_PORT?= yes
-.endif
-.endif
-
# if no preference was set, check for an installed base version
# but give an installed port preference over it.
.if !defined(WITH_OPENSSL_BASE) && \
@@ -153,7 +145,7 @@ OPENSSLINC= ${OPENSSLBASE}/include
.if defined(USE_OPENSSL_RPATH)
CFLAGS+= -Wl,-rpath,${OPENSSLRPATH}
.endif
-OPENSSL_LDFLAGS+= -Wl,-rpath=${OPENSSLRPATH}
+OPENSSL_LDFLAGS+= -Wl,-rpath,${OPENSSLRPATH}
LDFLAGS+=${OPENSSL_LDFLAGS}