aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.options.mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-10-12 12:19:55 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-10-12 12:19:55 +0000
commit07231789ec895457d0819554f495ba83376ada8c (patch)
tree0bd5e58b67c4499ab54a707f70e5f05b51217193 /Mk/bsd.options.mk
parent6ade2931599e891ebc96de84cf6582c92b5c66ed (diff)
downloadports-07231789ec895457d0819554f495ba83376ada8c.tar.gz
ports-07231789ec895457d0819554f495ba83376ada8c.zip
Change the way opt_USE is parsed.
This makes it possible to have: opt_USE= ldconfig=${PREFIX}/lib/foo/bar Before this, it would have ended up doing USE_LDCONFIG=/lib/foo/bar, without ${PREFIX}. Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D8169
Notes
Notes: svn path=/head/; revision=423859
Diffstat (limited to 'Mk/bsd.options.mk')
-rw-r--r--Mk/bsd.options.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index fccbed6c070e..7399de4b1514 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -495,9 +495,9 @@ SUB_LIST:= ${SUB_LIST} ${opt}="@comment " NO_${opt}=""
. if ${PORT_OPTIONS:M${opt}}
. if defined(${opt}_USE)
-. for option in ${${opt}_USE}
-_u= ${option:C/=.*//g}
-USE_${_u:tu}+= ${option:C/.*=//g:C/,/ /g}
+. for option in ${${opt}_USE:C/=.*//:O:u}
+_u= ${option}
+USE_${_u:tu}+= ${${opt}_USE:M${option}=*:C/.*=//g:C/,/ /g}
. endfor
. endif
. if defined(${opt}_VARS)
@@ -545,9 +545,9 @@ _OPTIONS_${_target}:= ${_OPTIONS_${_target}} ${_prio}:${_type}-${_target}-${opt}
. endfor
. else
. if defined(${opt}_USE_OFF)
-. for option in ${${opt}_USE_OFF}
-_u= ${option:C/=.*//g}
-USE_${_u:tu}+= ${option:C/.*=//g:C/,/ /g}
+. for option in ${${opt}_USE_OFF:C/=.*//:O:u}
+_u= ${option}
+USE_${_u:tu}+= ${${opt}_USE_OFF:M${option}=*:C/.*=//g:C/,/ /g}
. endfor
. endif
. if defined(${opt}_VARS_OFF)