aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.options.mk
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-28 17:20:42 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-28 17:20:42 +0000
commit5c572259877cd7ca5a4290778fe5ebabf9dfb2a0 (patch)
treeacb73643f4fe5f57790ed056215bc1db842b57ce /Mk/bsd.options.mk
parent8edd9d818ed2c5af206b6d8566c6a4502218b89b (diff)
downloadports-5c572259877cd7ca5a4290778fe5ebabf9dfb2a0.tar.gz
ports-5c572259877cd7ca5a4290778fe5ebabf9dfb2a0.zip
Implemented complete support for test target.
You can now `make test' on any port to run test sequence, no-op by default. If a port defines TEST_TARGET, it'll run sub-make with specified target, usually `check' or `test', useful if upstream supports that. The port may instead define custom do-test target, as well as usual satellite targets: {pre,do,post}-test, {pre,do,post}-test-OPT, {pre,do,post}-test-OPT-off `make test' builds and stages port first, so test may use both WRKDIR and STAGEDIR, and both BUILD and RUN depends are available for test target. Additionally, TEST_DEPENDS is now properly supported and may be used to define additional depends specifically for testing. Framework may define default tests for specific cases. For instance, perl5.mk and cran.mk already provide default test target on their own. This commit also converts my ports which have tests to this new framework. Approved by: portmgr (bapt) Differential Revision: D3680
Notes
Notes: svn path=/head/; revision=398125
Diffstat (limited to 'Mk/bsd.options.mk')
-rw-r--r--Mk/bsd.options.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 594e8b4432bb..b299e548f43e 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -162,6 +162,7 @@ _OPTIONS_TARGETS= fetch:300:pre fetch:500:do fetch:700:post \
configure:300:pre configure:500:do configure:700:post \
build:300:pre build:500:do build:700:post \
install:300:pre install:500:do install:700:post \
+ test:300:pre test:500:do test:700:post \
package:300:pre package:500:do package:700:post \
stage:800:post