aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.options.mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-06-26 16:23:37 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-06-26 16:23:37 +0000
commit6c2e13095de35bb7c36eb9f45e2f957d5cf423c5 (patch)
tree17838943faf393f2b29b82a9631d9dde2fa55543 /Mk/bsd.options.mk
parent922165eb7679d36976cb564125c723733d15012f (diff)
downloadports-6c2e13095de35bb7c36eb9f45e2f957d5cf423c5.tar.gz
ports-6c2e13095de35bb7c36eb9f45e2f957d5cf423c5.zip
Add opt_CMAKE_BOOL_OFF, oposite of opt_CMAKE_BOOL.
PR: 210576 Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=417532
Diffstat (limited to 'Mk/bsd.options.mk')
-rw-r--r--Mk/bsd.options.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index aa4ad2a953e7..c2fe02b54533 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -101,6 +101,9 @@
# ${opt}_CMAKE_BOOL Will add to CMAKE_ARGS:
# Option enabled -D${content}:BOOL=true
# Option disabled -D${content}:BOOL=false
+# ${opt}_CMAKE_BOOL_OFF Will add to CMAKE_ARGS:
+# Option enabled -D${content}:BOOL=false
+# Option disabled -D${content}:BOOL=true
#
# ${opt}_QMAKE_ON When option is enabled, it will add its content to
# the QMAKE_ARGS.
@@ -522,6 +525,9 @@ CONFIGURE_ARGS+= ${${opt}_CONFIGURE_WITH:S/^/--with-/}
. if defined(${opt}_CMAKE_BOOL)
CMAKE_ARGS+= ${${opt}_CMAKE_BOOL:C/.*/-D&:BOOL=true/}
. endif
+. if defined(${opt}_CMAKE_BOOL_OFF)
+CMAKE_ARGS+= ${${opt}_CMAKE_BOOL_OFF:C/.*/-D&:BOOL=false/}
+. endif
. for configure in CONFIGURE CMAKE QMAKE
. if defined(${opt}_${configure}_ON)
${configure}_ARGS+= ${${opt}_${configure}_ON}
@@ -569,6 +575,9 @@ CONFIGURE_ARGS+= ${${opt}_CONFIGURE_WITH:S/^/--without-/:C/=.*//}
. if defined(${opt}_CMAKE_BOOL)
CMAKE_ARGS+= ${${opt}_CMAKE_BOOL:C/.*/-D&:BOOL=false/}
. endif
+. if defined(${opt}_CMAKE_BOOL_OFF)
+CMAKE_ARGS+= ${${opt}_CMAKE_BOOL_OFF:C/.*/-D&:BOOL=true/}
+. endif
. for configure in CONFIGURE CMAKE QMAKE
. if defined(${opt}_${configure}_OFF)
${configure}_ARGS+= ${${opt}_${configure}_OFF}