aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.options.mk
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-11-22 10:59:03 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-11-22 10:59:03 +0000
commitb23b23a180fa0a3fcbf7ea4bee29e90fe8e78dd3 (patch)
treed711ff93e18e07f31a422eedbdb93004a966f815 /Mk/bsd.options.mk
parent8d30ffe80c14426995af87d5d9a94fe0f09b065a (diff)
downloadports-b23b23a180fa0a3fcbf7ea4bee29e90fe8e78dd3.tar.gz
ports-b23b23a180fa0a3fcbf7ea4bee29e90fe8e78dd3.zip
Add support for ${opt}_QMAKE_ON/${opt}_QMAKE_OFF
Approved by: portmgr (bapt)
Notes
Notes: svn path=/head/; revision=334572
Diffstat (limited to 'Mk/bsd.options.mk')
-rw-r--r--Mk/bsd.options.mk27
1 files changed, 15 insertions, 12 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index a70cf8fb7089..0a326e5f0728 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -93,6 +93,11 @@
# ${opt}_CMAKE_OFF When option is disabled, it will add its content to
# the CMAKE_ARGS.
#
+# ${opt}_QMAKE_ON When option is enabled, it will add its content to
+# the QMAKE_ARGS.
+# ${opt}_QMAKE_OFF When option is disabled, it will add its content to
+# the QMAKE_ARGS.
+#
# ${opt}_USE= FOO=bar When option is enabled, it will enable
# USE_FOO+= bar
# If you need more than one option, you can do
@@ -398,12 +403,11 @@ CONFIGURE_ARGS+= --enable-${iopt}
CONFIGURE_ARGS+= --with-${iopt}
. endfor
. endif
-. if defined(${opt}_CONFIGURE_ON)
-CONFIGURE_ARGS+= ${${opt}_CONFIGURE_ON}
-. endif
-. if defined(${opt}_CMAKE_ON)
-CMAKE_ARGS+= ${${opt}_CMAKE_ON}
-. endif
+. for configure in CONFIGURE CMAKE QMAKE
+. if defined(${opt}_${configure}_ON)
+${configure}_ARGS+= ${${opt}_${configure}_ON}
+. endif
+. endfor
. for flags in CFLAGS CPPFLAGS CXXFLAGS LDFLAGS CONFIGURE_ENV MAKE_ARGS \
MAKE_ENV ALL_TARGET INSTALL_TARGET USES DISTFILES PLIST_FILES \
PLIST_DIRS PLIST_DIRSTRY EXTRA_PATCHES PATCHFILES PATCH_SITES CATEGORIES
@@ -427,12 +431,11 @@ CONFIGURE_ARGS+= --disable-${iopt}
CONFIGURE_ARGS+= --without-${iopt}
. endfor
. endif
-. if defined(${opt}_CONFIGURE_OFF)
-CONFIGURE_ARGS+= ${${opt}_CONFIGURE_OFF}
-. endif
-. if defined(${opt}_CMAKE_OFF)
-CMAKE_ARGS+= ${${opt}_CMAKE_OFF}
-. endif
+. for configure in CONFIGURE CMAKE QMAKE
+. if defined(${opt}_${configure}_OFF)
+${configure}_ARGS+= ${${opt}_${configure}_OFF}
+. endif
+. endfor
. endif
.endfor