aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.options.mk
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-01 16:27:52 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-01 16:27:52 +0000
commitcd19cf50f226127dba686270f3601cff68d5d2a2 (patch)
tree7d9e13ad2b9e992eaeca8b6a7fa3443276112957 /Mk/bsd.options.mk
parent8129b1db050ba7aa8ba0986c9f9a6e769704c00d (diff)
downloadports-cd19cf50f226127dba686270f3601cff68d5d2a2.tar.gz
ports-cd19cf50f226127dba686270f3601cff68d5d2a2.zip
- Add more OPTIONS helpers: MAKE_ARGS, PLIST_FILES, PLIST_DIRS and PLIST_DIRSTRY
- Fix typo PR: ports/182514 Submitted by: sunpoet (myself) Approved by: bdrewery (portmgr)
Notes
Notes: svn path=/head/; revision=328963
Diffstat (limited to 'Mk/bsd.options.mk')
-rw-r--r--Mk/bsd.options.mk11
1 files changed, 6 insertions, 5 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 81437ec31f80..d8b74421084c 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -70,7 +70,7 @@
# WITHOUT - Unset options from the command line
#
#
-# The following knobs are there to simplfy the handling of OPTIONS in simple
+# The following knobs are there to simplify the handling of OPTIONS in simple
# cases :
#
# OPTIONS_SUB When defined it will add to PLIST_SUB:
@@ -93,9 +93,9 @@
# ${opt}_CMAKE_OFF When option is disabled, it will add its content to
# the CMAKE_ARGS.
#
-# For each of CFLAGS CPPFLAGS CXXFLAGS LDFLAGS CONFIGURE_ENV MAKE_ENV USES
-# DISTFILES, defining ${opt}_${variable} will add it to the actual variable
-# when the option is enabled.
+# For each of CFLAGS CPPFLAGS CXXFLAGS LDFLAGS CONFIGURE_ENV MAKE_ARGS MAKE_ENV
+# USES DISTFILES PLIST_FILES PLIST_DIRS PLIST_DIRSTRY, defining
+# ${opt}_${variable} will add it to the actual variable when the option is enabled.
#
# For each of the depends target PKG EXTRACT PATCH FETCH BUILD LIB RUN,
# defining ${opt}_${deptype}_DEPENDS will add it to the actual dependency when
@@ -392,7 +392,8 @@ CONFIGURE_ARGS+= ${${opt}_CONFIGURE_ON}
. if defined(${opt}_CMAKE_ON)
CMAKE_ARGS+= ${${opt}_CMAKE_ON}
. endif
-. for flags in CFLAGS CPPFLAGS CXXFLAGS LDFLAGS CONFIGURE_ENV MAKE_ENV USES DISTFILES
+. for flags in CFLAGS CPPFLAGS CXXFLAGS LDFLAGS CONFIGURE_ENV MAKE_ARGS MAKE_ENV \
+ USES DISTFILES PLIST_FILES PLIST_DIRS PLIST_DIRSTRY
. if defined(${opt}_${flags})
${flags}+= ${${opt}_${flags}}
. endif