aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.options.mk
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2017-11-16 19:41:20 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2017-11-16 19:41:20 +0000
commitdc656b07fce5c41e6e5e0c49b0389c9b5ce05185 (patch)
treea95e493b868346c1b94f5ddd41f384c3852aa745 /Mk/bsd.options.mk
parent0ff3faf05ffec2132019d1a7dc5e872ffdaf22c4 (diff)
downloadports-dc656b07fce5c41e6e5e0c49b0389c9b5ce05185.tar.gz
ports-dc656b07fce5c41e6e5e0c49b0389c9b5ce05185.zip
Follow-up r454266: Sort and remove duplicates for [DE]SELECTED_OPTIONS.
Some ports like graphics/povray-meta do funky things like add the same option into PORT_OPTIONS twice. This also avoids a new leading blank space in some cases. With hat: portmgr
Notes
Notes: svn path=/head/; revision=454332
Diffstat (limited to 'Mk/bsd.options.mk')
-rw-r--r--Mk/bsd.options.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 203186addf4a..12ce3119f02d 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -643,13 +643,15 @@ _OPTIONS_${_target}:= ${_OPTIONS_${_target}} ${_prio}:${_type}-${_target}-${opt}
# Wait to expand PORT_OPTIONS until the last moment in case something modifies
# the selected OPTIONS after bsd.port.options.mk is included. This uses
# bmake's :@ for loop.
-SELECTED_OPTIONS= ${ALL_OPTIONS:@opt@${PORT_OPTIONS:M${opt}}@}
-DESELECTED_OPTIONS= ${ALL_OPTIONS:@opt@${"${PORT_OPTIONS:M${opt}}":?:${opt}}@}
+_SELECTED_OPTIONS= ${ALL_OPTIONS:@opt@${PORT_OPTIONS:M${opt}}@}
+_DESELECTED_OPTIONS= ${ALL_OPTIONS:@opt@${"${PORT_OPTIONS:M${opt}}":?:${opt}}@}
.for otype in MULTI GROUP SINGLE RADIO
. for m in ${OPTIONS_${otype}}
-SELECTED_OPTIONS+= ${OPTIONS_${otype}_${m}:@opt@${PORT_OPTIONS:M${opt}}@}
-DESELECTED_OPTIONS+= ${OPTIONS_${otype}_${m}:@opt@${"${PORT_OPTIONS:M${opt}}":?:${opt}}@}
+_SELECTED_OPTIONS+= ${OPTIONS_${otype}_${m}:@opt@${PORT_OPTIONS:M${opt}}@}
+_DESELECTED_OPTIONS+= ${OPTIONS_${otype}_${m}:@opt@${"${PORT_OPTIONS:M${opt}}":?:${opt}}@}
. endfor
.endfor
+SELECTED_OPTIONS= ${_SELECTED_OPTIONS:O:u}
+DESELECTED_OPTIONS= ${_DESELECTED_OPTIONS:O:u}
.endif