aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.options.mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-09-10 14:40:57 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-09-10 14:40:57 +0000
commitf4c9be1393c796e48cb915279435891d3bb75801 (patch)
treeb8fd5d67dfb67f23c512e22ade83140bc6893d3a /Mk/bsd.options.mk
parent2cd8808f7dc603edc147815d66bb0f7f316fbb72 (diff)
downloadports-f4c9be1393c796e48cb915279435891d3bb75801.tar.gz
ports-f4c9be1393c796e48cb915279435891d3bb75801.zip
Notes
Diffstat (limited to 'Mk/bsd.options.mk')
-rw-r--r--Mk/bsd.options.mk17
1 files changed, 13 insertions, 4 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 69852cf29303..27c150b33850 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -197,8 +197,6 @@ _OPTIONS_TARGETS= fetch:300:pre fetch:500:do fetch:700:post \
package:300:pre package:500:do package:700:post \
stage:800:post
-PORT_OPTIONS+= DOCS NLS EXAMPLES IPV6
-
# Add per arch options
.for opt in ${OPTIONS_DEFINE_${ARCH}}
.if empty(OPTIONS_DEFINE:M${opt})
@@ -223,11 +221,10 @@ _ALL_EXCLUDE+= ${opt}
. endif
.endfor
-# Remove options the port maintainer doesn't want
+# Remove options the port maintainer doesn't want, part 1
.for opt in ${_ALL_EXCLUDE:O:u}
OPTIONS_DEFAULT:= ${OPTIONS_DEFAULT:N${opt}}
OPTIONS_DEFINE:= ${OPTIONS_DEFINE:N${opt}}
-PORT_OPTIONS:= ${PORT_OPTIONS:N${opt}}
. for otype in SINGLE RADIO MULTI GROUP
. for m in ${OPTIONS_${otype}}
OPTIONS_${otype}_${m}:= ${OPTIONS_${otype}_${m}:N${opt}}
@@ -257,6 +254,18 @@ COMPLETE_OPTIONS_LIST+= ${OPTIONS_${otype}_${m}}
. endfor
.endfor
+# Some options are always enabled by default.
+.for _opt in DOCS NLS EXAMPLES IPV6
+.if ${COMPLETE_OPTIONS_LIST:M${_opt}}
+PORT_OPTIONS+= ${_opt}
+.endif
+.endfor
+
+# Remove options the port maintainer doesn't want, part 2
+.for opt in ${_ALL_EXCLUDE:O:u}
+PORT_OPTIONS:= ${PORT_OPTIONS:N${opt}}
+.endfor
+
## Now create the list of activated options
.if defined(OPTIONS_OVERRIDE)
# Special case $OPTIONS_OVERRIDE; if it is defined forget about anything done