aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-04 00:02:08 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-04 00:02:08 +0000
commit11e8713e2be383767f7a1b8aac38eae484bed054 (patch)
tree4933bce358ab8595dbbf34dbdb89eddbe9676908 /Mk/bsd.port.mk
parent15be8a25a0514a42cdb14ba1c378b8e33633bdce (diff)
downloadports-11e8713e2be383767f7a1b8aac38eae484bed054.tar.gz
ports-11e8713e2be383767f7a1b8aac38eae484bed054.zip
Mark all targets defines in _SEQ and .ORDER has .PHONY which they all should be
If one day we are no adding a target actually correspond to an actual file, simply adding the name of the target to the NOTPHONY will make it work as expected
Notes
Notes: svn path=/head/; revision=338601
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk12
1 files changed, 11 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index b8cf7f0b3dde..82d7ae8e588f 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1127,6 +1127,7 @@ SRC_BASE?= /usr/src
USESDIR?= ${PORTSDIR}/Mk/Uses
SCRIPTSDIR?= ${PORTSDIR}/Mk/Scripts
LIB_DIRS?= /lib /usr/lib ${LOCALBASE}/lib
+NOTPHONY?=
.if defined(FORCE_STAGE)
.undef NO_STAGE
@@ -4256,7 +4257,6 @@ security-check:
# call the necessary targets/scripts.
################################################################
-.PHONY: extract-message patch-message configure-message stage-message install-message package-message
extract-message:
@${ECHO_MSG} "===> Extracting for ${PKGNAME}"
patch-message:
@@ -6545,17 +6545,25 @@ _PACKAGE_SEQ= package-message pre-package pre-package-script \
.for _t in ${_TARGETS_STAGES}
. for s in ${_${_t}_SEQ}
. if target(${s})
+. if ! ${NOTPHONY:M${s}}
+_PHONY_TARGETS+= ${s}
+. endif
_${_t}_REAL_SEQ+= ${s}
. endif
. endfor
. for s in ${_${_t}_SUSEQ}
. if target(${s})
+. if ! ${NOTPHONY:M${s}}
+_PHONY_TARGETS+= ${s}
+. endif
_${_t}_REAL_SUSEQ+= ${s}
. endif
. endfor
.ORDER: ${_${_t}_DEP} ${_${_t}_REAL_SEQ}
.endfor
+.PHONY: ${_PHONY_TARGETS}
+
.for target in extract patch configure build stage install package
.if !target(${target}) && defined(_OPTIONS_OK)
@@ -6601,6 +6609,8 @@ ${${target:U}_COOKIE}::
.endfor
+.PHONY: check-sanity fetch pkg
+
.if !target(check-sanity)
check-sanity: ${_SANITY_REAL_SEQ}
.endif